9b5f583906
This is a swconfig driver for the Marvell 88E6171 switch, which is a 7-port GigE switch with two CPU ports and 64 802.1q VLANs. Signed-off-by: Claudio Leite <leitec@staticky.com> SVN-Revision: 43486
23 lines
752 B
Diff
23 lines
752 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -143,6 +143,10 @@ config MVSWITCH_PHY
|
|
tristate "Driver for Marvell 88E6060 switches"
|
|
select ETHERNET_PACKET_MANGLE
|
|
|
|
+config MVSW6171_PHY
|
|
+ tristate "Driver for Marvell 88E6171 switches"
|
|
+ select SWCONFIG
|
|
+
|
|
config IP17XX_PHY
|
|
tristate "Driver for IC+ IP17xx switches"
|
|
select SWCONFIG
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -20,6 +20,7 @@ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
|
|
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
|
|
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
|
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
|
+obj-$(CONFIG_MVSW6171_PHY) += mvsw6171.o
|
|
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
obj-$(CONFIG_AR8216_PHY) += ar8216.o
|