e71fffed64
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
139 lines
3.8 KiB
Diff
139 lines
3.8 KiB
Diff
From f8c331bda6a90b239f600020eec1b0defe7249b5 Mon Sep 17 00:00:00 2001
|
|
From: Florian Fainelli <f.fainelli@gmail.com>
|
|
Date: Wed, 22 Jun 2016 17:00:35 -0700
|
|
Subject: [PATCH] ARM: dts: BCM5301x: Add BCM953012ER board
|
|
|
|
Add support for the Broadcom BCM953012 Enterprise Router reference
|
|
board, enable the following peripherals:
|
|
|
|
- UART0 (UART1 is not populated)
|
|
- WPS and restart GPIO buttons
|
|
- Ethernet switch w/ only two facing ports
|
|
- NAND flash
|
|
- SPI-NOR flash
|
|
|
|
Acked-by: Jon Mason <jon.mason@broadcom.com>
|
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm953012er.dts | 104 ++++++++++++++++++++++++++++++++++++++
|
|
2 files changed, 105 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm953012er.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -79,6 +79,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
|
bcm47094-dlink-dir-885l.dtb \
|
|
bcm94708.dtb \
|
|
bcm94709.dtb \
|
|
+ bcm953012er.dtb \
|
|
bcm953012k.dtb
|
|
dtb-$(CONFIG_ARCH_BCM_63XX) += \
|
|
bcm963138dvt.dtb
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm953012er.dts
|
|
@@ -0,0 +1,104 @@
|
|
+/*
|
|
+ * BSD LICENSE
|
|
+ *
|
|
+ * Copyright(c) 2016 Broadcom. All rights reserved.
|
|
+ *
|
|
+ * Redistribution and use in source and binary forms, with or without
|
|
+ * modification, are permitted provided that the following conditions
|
|
+ * are met:
|
|
+ *
|
|
+ * * Redistributions of source code must retain the above copyright
|
|
+ * notice, this list of conditions and the following disclaimer.
|
|
+ * * Redistributions in binary form must reproduce the above copyright
|
|
+ * notice, this list of conditions and the following disclaimer in
|
|
+ * the documentation and/or other materials provided with the
|
|
+ * distribution.
|
|
+ * * Neither the name of Broadcom Corporation nor the names of its
|
|
+ * contributors may be used to endorse or promote products derived
|
|
+ * from this software without specific prior written permission.
|
|
+ *
|
|
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
|
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
|
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
|
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
|
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
|
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
|
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
|
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
|
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
|
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm4708.dtsi"
|
|
+#include "bcm5301x-nand-cs0-bch8.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "NorthStar Enterprise Router (BCM953012ER)";
|
|
+ compatible = "brcm,bcm953012er", "brcm,brcm53012", "brcm,bcm4708";
|
|
+
|
|
+ aliases {
|
|
+ serial0 = &uart0;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ reg = <0x00000000 0x8000000>;
|
|
+ };
|
|
+
|
|
+ gpio-keys {
|
|
+ compatible = "gpio-keys";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ wps {
|
|
+ label = "WPS";
|
|
+ linux,code = <KEY_WPS_BUTTON>;
|
|
+ gpios = <&chipcommon 6 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ restart {
|
|
+ label = "Reset";
|
|
+ linux,code = <KEY_RESTART>;
|
|
+ gpios = <&chipcommon 15 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&spi_nor {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&srab {
|
|
+ status = "okay";
|
|
+
|
|
+ ports {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ port@0 {
|
|
+ reg = <0>;
|
|
+ label = "port0";
|
|
+ };
|
|
+
|
|
+ port@1 {
|
|
+ reg = <1>;
|
|
+ label = "port1";
|
|
+ };
|
|
+
|
|
+ port@5 {
|
|
+ reg = <5>;
|
|
+ label = "cpu";
|
|
+ ethernet = <&gmac0>;
|
|
+ };
|
|
+ };
|
|
+};
|