e553dfc356
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
Index: linux-3.14.18/drivers/pinctrl/Kconfig
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/pinctrl/Kconfig
|
|
+++ linux-3.14.18/drivers/pinctrl/Kconfig
|
|
@@ -87,6 +87,15 @@ config PINCTRL_AT91
|
|
help
|
|
Say Y here to enable the at91 pinctrl driver
|
|
|
|
+config PINCTRL_OXNAS
|
|
+ bool "OXNAS pinctrl driver"
|
|
+ depends on OF
|
|
+ depends on ARCH_OXNAS
|
|
+ select PINMUX
|
|
+ select PINCONF
|
|
+ help
|
|
+ Say Y here to enable the oxnas pinctrl driver
|
|
+
|
|
config PINCTRL_BAYTRAIL
|
|
bool "Intel Baytrail GPIO pin control"
|
|
depends on GPIOLIB && ACPI && X86
|
|
Index: linux-3.14.18/drivers/pinctrl/Makefile
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/pinctrl/Makefile
|
|
+++ linux-3.14.18/drivers/pinctrl/Makefile
|
|
@@ -67,6 +67,7 @@ obj-$(CONFIG_PINCTRL_LANTIQ) += pinctrl-
|
|
obj-$(CONFIG_PINCTRL_TB10X) += pinctrl-tb10x.o
|
|
obj-$(CONFIG_PINCTRL_ST) += pinctrl-st.o
|
|
obj-$(CONFIG_PINCTRL_VF610) += pinctrl-vf610.o
|
|
+obj-$(CONFIG_PINCTRL_OXNAS) += pinctrl-oxnas.o
|
|
|
|
obj-$(CONFIG_PLAT_ORION) += mvebu/
|
|
obj-$(CONFIG_ARCH_SHMOBILE) += sh-pfc/
|