openwrtv4/target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch
Rafał Miłecki 1c063070cf generic: early (incomplete!) 4.0 support
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>

SVN-Revision: 44511
2015-02-23 22:59:53 +00:00

20 lines
488 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -1537,3 +1537,6 @@ source "drivers/crypto/Kconfig"
source crypto/asymmetric_keys/Kconfig
endif # if CRYPTO
+
+source "crypto/ocf/Kconfig"
+
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -102,6 +102,8 @@ obj-$(CONFIG_CRYPTO_USER_API_HASH) += al
obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
obj-$(CONFIG_CRYPTO_USER_API_RNG) += algif_rng.o
+obj-$(CONFIG_OCF_OCF) += ocf/
+
#
# generic algorithms and the async_tx api
#