7bbf4117c6
This add support for kernel 4.9 to the ar71xx target. It was compile tested with the generic, NAND and mikrotik subtarget. Multiple members of the community tested it on their boards and did not report any major problem so far. Especially the NAND part received some changes to adapt to the new kernel APIs. The serial driver hack used for the Arduino Yun was not ported because the kernel changed there a lot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
28 lines
787 B
Diff
28 lines
787 B
Diff
--- a/drivers/net/ethernet/atheros/Kconfig
|
|
+++ b/drivers/net/ethernet/atheros/Kconfig
|
|
@@ -5,7 +5,7 @@
|
|
config NET_VENDOR_ATHEROS
|
|
bool "Atheros devices"
|
|
default y
|
|
- depends on PCI
|
|
+ depends on (PCI || ATH79)
|
|
---help---
|
|
If you have a network (Ethernet) card belonging to this class, say Y.
|
|
|
|
@@ -78,4 +78,6 @@ config ALX
|
|
To compile this driver as a module, choose M here. The module
|
|
will be called alx.
|
|
|
|
+source drivers/net/ethernet/atheros/ag71xx/Kconfig
|
|
+
|
|
endif # NET_VENDOR_ATHEROS
|
|
--- a/drivers/net/ethernet/atheros/Makefile
|
|
+++ b/drivers/net/ethernet/atheros/Makefile
|
|
@@ -2,6 +2,7 @@
|
|
# Makefile for the Atheros network device drivers.
|
|
#
|
|
|
|
+obj-$(CONFIG_AG71XX) += ag71xx/
|
|
obj-$(CONFIG_ATL1) += atlx/
|
|
obj-$(CONFIG_ATL2) += atlx/
|
|
obj-$(CONFIG_ATL1E) += atl1e/
|