f997478655
Refresh patches. Remove upstreamed patches: - generic/190-1-5-e1000e-Fix-error-path-in-link-detection.patch - generic/190-3-5-e1000e-Fix-return-value-test.patch - generic/190-4-5-e1000e-Separate-signaling-for-link-check-link-up.patch - generic/190-5-5-e1000e-Avoid-receiver-overrun-interrupt-bursts.patch - ramips/0102-MIPS-ralink-Fix-MT7628-pinmux.patch - ramips/0103-MIPS-ralink-Fix-typo-in-mt7628-pinmux-function Update patches that no longer apply: - layerscape/815-spi-support-layerscape.patch - ramips/0099-pci-mt7620.patch Compile-tested on ar71xx, brcm2708/bcm2708, octeon and x86/64. Runtime-tested on ar71xx, brcm2708/bcm2708, octeon and x86/64. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
64 lines
1.8 KiB
Diff
64 lines
1.8 KiB
Diff
From e3692cb2fcd5ba1244512a0f43b8118f65f1c375 Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Sat, 8 Jul 2017 08:20:43 +0200
|
|
Subject: debloat: dmabuf
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
drivers/base/Kconfig | 2 +-
|
|
drivers/dma-buf/Makefile | 10 +++++++---
|
|
drivers/dma-buf/dma-buf.c | 4 +++-
|
|
kernel/sched/core.c | 1 +
|
|
4 files changed, 12 insertions(+), 5 deletions(-)
|
|
|
|
--- a/drivers/base/Kconfig
|
|
+++ b/drivers/base/Kconfig
|
|
@@ -241,7 +241,7 @@ config SOC_BUS
|
|
source "drivers/base/regmap/Kconfig"
|
|
|
|
config DMA_SHARED_BUFFER
|
|
- bool
|
|
+ tristate
|
|
default n
|
|
select ANON_INODES
|
|
help
|
|
--- a/drivers/dma-buf/Makefile
|
|
+++ b/drivers/dma-buf/Makefile
|
|
@@ -1,3 +1,7 @@
|
|
-obj-y := dma-buf.o fence.o reservation.o seqno-fence.o fence-array.o
|
|
-obj-$(CONFIG_SYNC_FILE) += sync_file.o
|
|
-obj-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
|
|
+obj-$(CONFIG_DMA_SHARED_BUFFER) := dma-shared-buffer.o
|
|
+
|
|
+dma-buf-objs-y := dma-buf.o fence.o reservation.o seqno-fence.o fence-array.o
|
|
+dma-buf-objs-$(CONFIG_SYNC_FILE) += sync_file.o
|
|
+dma-buf-objs-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
|
|
+
|
|
+dma-shared-buffer-objs := $(dma-buf-objs-y)
|
|
--- a/drivers/dma-buf/dma-buf.c
|
|
+++ b/drivers/dma-buf/dma-buf.c
|
|
@@ -34,6 +34,7 @@
|
|
#include <linux/poll.h>
|
|
#include <linux/reservation.h>
|
|
#include <linux/mm.h>
|
|
+#include <linux/module.h>
|
|
|
|
#include <uapi/linux/dma-buf.h>
|
|
|
|
@@ -977,4 +978,5 @@ static void __exit dma_buf_deinit(void)
|
|
{
|
|
dma_buf_uninit_debugfs();
|
|
}
|
|
-__exitcall(dma_buf_deinit);
|
|
+module_exit(dma_buf_deinit);
|
|
+MODULE_LICENSE("GPL");
|
|
--- a/kernel/sched/core.c
|
|
+++ b/kernel/sched/core.c
|
|
@@ -2170,6 +2170,7 @@ int wake_up_state(struct task_struct *p,
|
|
{
|
|
return try_to_wake_up(p, state, 0);
|
|
}
|
|
+EXPORT_SYMBOL_GPL(wake_up_state);
|
|
|
|
/*
|
|
* This function clears the sched_dl_entity static params.
|