7bbf4117c6
This add support for kernel 4.9 to the ar71xx target. It was compile tested with the generic, NAND and mikrotik subtarget. Multiple members of the community tested it on their boards and did not report any major problem so far. Especially the NAND part received some changes to adapt to the new kernel APIs. The serial driver hack used for the Arduino Yun was not ported because the kernel changed there a lot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
23 lines
936 B
Diff
23 lines
936 B
Diff
--- a/drivers/mtd/nand/Kconfig
|
|
+++ b/drivers/mtd/nand/Kconfig
|
|
@@ -577,6 +577,10 @@ config MTD_NAND_RB750
|
|
tristate "NAND flash driver for the RouterBoard 750"
|
|
depends on MTD_NAND && ATH79_MACH_RB750
|
|
|
|
+config MTD_NAND_RB91X
|
|
+ tristate "NAND flash driver for the RouterBOARD 91x series"
|
|
+ depends on MTD_NAND && ATH79_MACH_RB91X
|
|
+
|
|
config MTD_NAND_AR934X
|
|
tristate "NAND flash driver for the Qualcomm Atheros AR934x/QCA955x SoCs"
|
|
depends on (SOC_AR934X || SOC_QCA955X)
|
|
--- a/drivers/mtd/nand/Makefile
|
|
+++ b/drivers/mtd/nand/Makefile
|
|
@@ -36,6 +36,7 @@ obj-$(CONFIG_MTD_NAND_TMIO) += tmio_nan
|
|
obj-$(CONFIG_MTD_NAND_PLATFORM) += plat_nand.o
|
|
obj-$(CONFIG_MTD_NAND_RB4XX) += rb4xx_nand.o
|
|
obj-$(CONFIG_MTD_NAND_RB750) += rb750_nand.o
|
|
+obj-$(CONFIG_MTD_NAND_RB91X) += rb91x_nand.o
|
|
obj-$(CONFIG_MTD_NAND_PASEMI) += pasemi_nand.o
|
|
obj-$(CONFIG_MTD_NAND_ORION) += orion_nand.o
|
|
obj-$(CONFIG_MTD_NAND_FSL_ELBC) += fsl_elbc_nand.o
|