openwrtv4/package/libpcap/patches/101-makefile_create_bindir.patch
Travis Kemen c859a20e69 fix missing parts of r19997.
SVN-Revision: 20057
2010-03-08 14:21:32 +00:00

11 lines
443 B
Diff

--- a/Makefile.in
+++ b/Makefile.in
@@ -484,6 +484,8 @@ install: libpcap.a pcap-config
$(DESTDIR)$(includedir)/pcap-bpf.h
$(INSTALL_DATA) $(srcdir)/pcap-namedb.h \
$(DESTDIR)$(includedir)/pcap-namedb.h
+ [ -d $(DESTDIR)$(bindir) ] || \
+ (mkdir -p $(DESTDIR)$(bindir); chmod 755 $(DESTDIR)$(bindir))
$(INSTALL_PROGRAM) pcap-config $(DESTDIR)$(bindir)/pcap-config
for i in $(MAN1); do \
$(INSTALL_DATA) $(srcdir)/$$i \