04d3308b62
This patch adds support for GL.iNet GL-B1300 Specification: - SOC: IPQ4028 / QCA Dakota - RAM: 256 MiB - FLASH: 32 MiB - ETH: Qualcomm Atheros QCA8075 Gigabit Switch (2 x LAN, 1 x WAN) - USB: 1 x 3.0 (via Synopsys DesignWare DWC3 controller in the SoC) - WLAN1: Qualcomm Atheros QCA4028 2.4GHz 802.11bgn 2:2x2 - WLAN2: Qualcomm Atheros QCA4028 5GHz 802.11a/n/ac 2:2x2 - INPUT: one reset and one WPS button - LEDS: 3 leds: Power, WIFI(only for 2.4G currently), and one reserved - UART: 1 x UART on PCB (3.3V, TX, RX, GND) - 115200 8N1 Installation: Method 1: - use serial port to stop uboot - uboot command: run lf Method 2: - push down reset button and power on - wait until three leds constantly on then release - upgrade by uboot web at http://192.168.1.1 Note: - the sysupgrade image need to be renamed to lede-gl-b1300.bin in both method. - the sysupgrade image can be automatically downloaded if tftp server at 192.168.1.2 have that file. - the wifi led will be flashing when writing image. Signed-off-by: Dongming Han <handongming@gl-inet.com>
33 lines
1,022 B
Diff
33 lines
1,022 B
Diff
From 8f68331e14dff9a101f2d0e1d6bec84a031f27ee Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Thu, 9 Mar 2017 11:03:18 +0100
|
|
Subject: [PATCH 69/69] arm: boot: add dts files
|
|
|
|
Signed-off-by: John Crispin <john@phrozen.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 8 ++++++++
|
|
1 file changed, 8 insertions(+)
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -616,9 +616,20 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
|
qcom-apq8074-dragonboard.dtb \
|
|
qcom-apq8084-ifc6540.dtb \
|
|
qcom-apq8084-mtp.dtb \
|
|
+ qcom-ipq4019-a42.dtb \
|
|
+ qcom-ipq4019-gl-b1300.dtb \
|
|
qcom-ipq4019-ap.dk01.1-c1.dtb \
|
|
qcom-ipq4019-ap.dk04.1-c1.dtb \
|
|
+ qcom-ipq4019-fritz4040.dtb \
|
|
qcom-ipq8064-ap148.dtb \
|
|
+ qcom-ipq8064-c2600.dtb \
|
|
+ qcom-ipq8064-d7800.dtb \
|
|
+ qcom-ipq8064-db149.dtb \
|
|
+ qcom-ipq8064-ea8500.dtb \
|
|
+ qcom-ipq8064-r7500.dtb \
|
|
+ qcom-ipq8064-r7500v2.dtb \
|
|
+ qcom-ipq8065-nbg6817.dtb \
|
|
+ qcom-ipq8065-r7800.dtb \
|
|
qcom-msm8660-surf.dtb \
|
|
qcom-msm8960-cdp.dtb \
|
|
qcom-msm8974-lge-nexus5-hammerhead.dtb \
|