0331657a4f
Backport appropriate patches to allow using device tree only board defintions. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 38280
439 lines
14 KiB
Diff
439 lines
14 KiB
Diff
From 3bfe255171bf03fa4b776e8e10b93d4dbd7df1e8 Mon Sep 17 00:00:00 2001
|
|
From: Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>
|
|
Date: Tue, 2 Jul 2013 13:00:22 +0200
|
|
Subject: [PATCH 25/29] ARM: kirkwood: remove redundant DT board files
|
|
|
|
With DT support for mv643xx_eth board specific init for some boards now
|
|
is unneccessary. Remove those board files, Kconfig entries, and
|
|
corresponding entries in kirkwood_defconfig.
|
|
|
|
Signed-off-by: Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>
|
|
---
|
|
arch/arm/mach-kirkwood/Kconfig | 148 --------------------------------
|
|
arch/arm/mach-kirkwood/Makefile | 22 +----
|
|
arch/arm/mach-kirkwood/board-dnskw.c | 7 --
|
|
arch/arm/mach-kirkwood/board-dt.c | 80 +----------------
|
|
arch/arm/mach-kirkwood/board-lsxl.c | 52 -----------
|
|
arch/arm/mach-kirkwood/board-readynas.c | 28 ------
|
|
6 files changed, 2 insertions(+), 335 deletions(-)
|
|
delete mode 100644 arch/arm/mach-kirkwood/board-lsxl.c
|
|
delete mode 100644 arch/arm/mach-kirkwood/board-readynas.c
|
|
|
|
diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
|
index b56bd3d..dc99588 100644
|
|
--- a/arch/arm/mach-kirkwood/Kconfig
|
|
+++ b/arch/arm/mach-kirkwood/Kconfig
|
|
@@ -140,20 +140,6 @@ config ARCH_KIRKWOOD_DT
|
|
Say 'Y' here if you want your kernel to support the
|
|
Marvell Kirkwood using flattened device tree.
|
|
|
|
-config MACH_CLOUDBOX_DT
|
|
- bool "LaCie CloudBox NAS (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the LaCie
|
|
- CloudBox NAS, using Flattened Device Tree.
|
|
-
|
|
-config MACH_DB88F628X_BP_DT
|
|
- bool "Marvell DB-88F628x-BP Development Board (Flattened Device Tree)"
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the Marvell
|
|
- DB-88F6281-BP and DB-88F6282-BP Development Board (Flattened
|
|
- Device Tree).
|
|
-
|
|
config MACH_DLINK_KIRKWOOD_DT
|
|
bool "D-Link Kirkwood-based NAS (Flattened Device Tree)"
|
|
select ARCH_KIRKWOOD_DT
|
|
@@ -162,140 +148,6 @@ config MACH_DLINK_KIRKWOOD_DT
|
|
Kirkwood-based D-Link NASes such as DNS-320 & DNS-325,
|
|
using Flattened Device Tree.
|
|
|
|
-config MACH_DOCKSTAR_DT
|
|
- bool "Seagate FreeAgent Dockstar (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- Seagate FreeAgent Dockstar (Flattened Device Tree).
|
|
-
|
|
-config MACH_DREAMPLUG_DT
|
|
- bool "Marvell DreamPlug (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- Marvell DreamPlug (Flattened Device Tree).
|
|
-
|
|
-config MACH_GOFLEXNET_DT
|
|
- bool "Seagate GoFlex Net (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- Seagate GoFlex Net (Flattened Device Tree).
|
|
-
|
|
-config MACH_GURUPLUG_DT
|
|
- bool "Marvell GuruPlug Reference Board (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- Marvell GuruPlug Reference Board (Flattened Device Tree).
|
|
-
|
|
-config MACH_IB62X0_DT
|
|
- bool "RaidSonic IB-NAS6210, IB-NAS6220 (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- RaidSonic IB-NAS6210 & IB-NAS6220 devices, using
|
|
- Flattened Device Tree.
|
|
-
|
|
-config MACH_ICONNECT_DT
|
|
- bool "Iomega Iconnect (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here to enable Iomega Iconnect support.
|
|
-
|
|
-config MACH_INETSPACE_V2_DT
|
|
- bool "LaCie Internet Space v2 NAS (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the LaCie
|
|
- Internet Space v2 NAS, using Flattened Device Tree.
|
|
-
|
|
-config MACH_IOMEGA_IX2_200_DT
|
|
- bool "Iomega StorCenter ix2-200 (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- Iomega StorCenter ix2-200 (Flattened Device Tree).
|
|
-
|
|
-config MACH_KM_KIRKWOOD_DT
|
|
- bool "Keymile Kirkwood Reference Design (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- Keymile Kirkwood Reference Desgin, using Flattened Device Tree.
|
|
-
|
|
-config MACH_LSXL_DT
|
|
- bool "Buffalo Linkstation LS-XHL, LS-CHLv2 (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- Buffalo Linkstation LS-XHL & LS-CHLv2 devices, using
|
|
- Flattened Device Tree.
|
|
-
|
|
-config MACH_MPLCEC4_DT
|
|
- bool "MPL CEC4 (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- MPL CEC4 (Flattened Device Tree).
|
|
-
|
|
-config MACH_NETSPACE_LITE_V2_DT
|
|
- bool "LaCie Network Space Lite v2 NAS (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the LaCie
|
|
- Network Space Lite v2 NAS, using Flattened Device Tree.
|
|
-
|
|
-config MACH_NETSPACE_MAX_V2_DT
|
|
- bool "LaCie Network Space Max v2 NAS (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the LaCie
|
|
- Network Space Max v2 NAS, using Flattened Device Tree.
|
|
-
|
|
-config MACH_NETSPACE_MINI_V2_DT
|
|
- bool "LaCie Network Space Mini v2 NAS (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the LaCie
|
|
- Network Space Mini v2 NAS using Flattened Device Tree.
|
|
-
|
|
- This board is embedded in a product named CloudBox, which
|
|
- provides automatic backup on a 100GB cloud storage. This
|
|
- should not confused with a more recent LaCie NAS also named
|
|
- CloudBox. For this last, the disk capacity is 1TB or above.
|
|
-
|
|
-config MACH_NETSPACE_V2_DT
|
|
- bool "LaCie Network Space v2 NAS (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the LaCie
|
|
- Network Space v2 NAS, using Flattened Device Tree.
|
|
-
|
|
-config MACH_OPENBLOCKS_A6_DT
|
|
- bool "Plat'Home OpenBlocks A6 (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- Plat'Home OpenBlocks A6 (Flattened Device Tree).
|
|
-
|
|
-config MACH_READYNAS_DT
|
|
- bool "NETGEAR ReadyNAS Duo v2 (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- select ARM_APPENDED_DTB
|
|
- select ARM_ATAG_DTB_COMPAT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- NETGEAR ReadyNAS Duo v2 using Fattened Device Tree.
|
|
-
|
|
-config MACH_TOPKICK_DT
|
|
- bool "USI Topkick (Flattened Device Tree)"
|
|
- select ARCH_KIRKWOOD_DT
|
|
- help
|
|
- Say 'Y' here if you want your kernel to support the
|
|
- USI Topkick, using Flattened Device Tree
|
|
-
|
|
config MACH_TS219_DT
|
|
bool "Device Tree for QNAP TS-11X, TS-21X NAS"
|
|
select ARCH_KIRKWOOD_DT
|
|
diff --git a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
|
|
index 2fdc3a7..062f8c7 100644
|
|
--- a/arch/arm/mach-kirkwood/Makefile
|
|
+++ b/arch/arm/mach-kirkwood/Makefile
|
|
@@ -19,25 +19,5 @@ obj-$(CONFIG_MACH_TS219) += ts219-setup.o tsx1x-common.o
|
|
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
|
|
|
|
obj-$(CONFIG_ARCH_KIRKWOOD_DT) += board-dt.o
|
|
-obj-$(CONFIG_MACH_CLOUDBOX_DT) += board-ns2.o
|
|
-obj-$(CONFIG_MACH_DB88F628X_BP_DT) += board-db88f628x-bp.o
|
|
obj-$(CONFIG_MACH_DLINK_KIRKWOOD_DT) += board-dnskw.o
|
|
-obj-$(CONFIG_MACH_DOCKSTAR_DT) += board-dockstar.o
|
|
-obj-$(CONFIG_MACH_DREAMPLUG_DT) += board-dreamplug.o
|
|
-obj-$(CONFIG_MACH_GOFLEXNET_DT) += board-goflexnet.o
|
|
-obj-$(CONFIG_MACH_GURUPLUG_DT) += board-guruplug.o
|
|
-obj-$(CONFIG_MACH_IB62X0_DT) += board-ib62x0.o
|
|
-obj-$(CONFIG_MACH_ICONNECT_DT) += board-iconnect.o
|
|
-obj-$(CONFIG_MACH_INETSPACE_V2_DT) += board-ns2.o
|
|
-obj-$(CONFIG_MACH_IOMEGA_IX2_200_DT) += board-iomega_ix2_200.o
|
|
-obj-$(CONFIG_MACH_KM_KIRKWOOD_DT) += board-km_kirkwood.o
|
|
-obj-$(CONFIG_MACH_LSXL_DT) += board-lsxl.o
|
|
-obj-$(CONFIG_MACH_MPLCEC4_DT) += board-mplcec4.o
|
|
-obj-$(CONFIG_MACH_NETSPACE_LITE_V2_DT) += board-ns2.o
|
|
-obj-$(CONFIG_MACH_NETSPACE_MAX_V2_DT) += board-ns2.o
|
|
-obj-$(CONFIG_MACH_NETSPACE_MINI_V2_DT) += board-ns2.o
|
|
-obj-$(CONFIG_MACH_NETSPACE_V2_DT) += board-ns2.o
|
|
-obj-$(CONFIG_MACH_OPENBLOCKS_A6_DT) += board-openblocks_a6.o
|
|
-obj-$(CONFIG_MACH_READYNAS_DT) += board-readynas.o
|
|
-obj-$(CONFIG_MACH_TOPKICK_DT) += board-usi_topkick.o
|
|
-obj-$(CONFIG_MACH_TS219_DT) += board-ts219.o tsx1x-common.o
|
|
+obj-$(CONFIG_MACH_TS219_DT) += tsx1x-common.o
|
|
diff --git a/arch/arm/mach-kirkwood/board-dnskw.c b/arch/arm/mach-kirkwood/board-dnskw.c
|
|
index a1aa87f..2af7a95 100644
|
|
--- a/arch/arm/mach-kirkwood/board-dnskw.c
|
|
+++ b/arch/arm/mach-kirkwood/board-dnskw.c
|
|
@@ -14,14 +14,9 @@
|
|
#include <linux/kernel.h>
|
|
#include <linux/init.h>
|
|
#include <linux/platform_device.h>
|
|
-#include <linux/mv643xx_eth.h>
|
|
#include <linux/gpio.h>
|
|
#include "common.h"
|
|
|
|
-static struct mv643xx_eth_platform_data dnskw_ge00_data = {
|
|
- .phy_addr = MV643XX_ETH_PHY_ADDR(8),
|
|
-};
|
|
-
|
|
/* Register any GPIO for output and set the value */
|
|
static void __init dnskw_gpio_register(unsigned gpio, char *name, int def)
|
|
{
|
|
@@ -36,8 +31,6 @@ static void __init dnskw_gpio_register(unsigned gpio, char *name, int def)
|
|
|
|
void __init dnskw_init(void)
|
|
{
|
|
- kirkwood_ge00_init(&dnskw_ge00_data);
|
|
-
|
|
/* Set NAS to turn back on after a power failure */
|
|
dnskw_gpio_register(37, "dnskw:power:recover", 1);
|
|
}
|
|
diff --git a/arch/arm/mach-kirkwood/board-dt.c b/arch/arm/mach-kirkwood/board-dt.c
|
|
index f5aed1f..15e61c8 100644
|
|
--- a/arch/arm/mach-kirkwood/board-dt.c
|
|
+++ b/arch/arm/mach-kirkwood/board-dt.c
|
|
@@ -106,92 +106,14 @@ static void __init kirkwood_dt_init(void)
|
|
kexec_reinit = kirkwood_enable_pcie;
|
|
#endif
|
|
|
|
- if (of_machine_is_compatible("globalscale,dreamplug"))
|
|
- dreamplug_init();
|
|
-
|
|
- if (of_machine_is_compatible("globalscale,guruplug"))
|
|
- guruplug_dt_init();
|
|
-
|
|
if (of_machine_is_compatible("dlink,dns-kirkwood"))
|
|
dnskw_init();
|
|
|
|
- if (of_machine_is_compatible("iom,iconnect"))
|
|
- iconnect_init();
|
|
-
|
|
- if (of_machine_is_compatible("raidsonic,ib-nas62x0"))
|
|
- ib62x0_init();
|
|
-
|
|
- if (of_machine_is_compatible("qnap,ts219"))
|
|
- qnap_dt_ts219_init();
|
|
-
|
|
- if (of_machine_is_compatible("seagate,dockstar"))
|
|
- dockstar_dt_init();
|
|
-
|
|
- if (of_machine_is_compatible("seagate,goflexnet"))
|
|
- goflexnet_init();
|
|
-
|
|
- if (of_machine_is_compatible("buffalo,lsxl"))
|
|
- lsxl_init();
|
|
-
|
|
- if (of_machine_is_compatible("iom,ix2-200"))
|
|
- iomega_ix2_200_init();
|
|
-
|
|
- if (of_machine_is_compatible("keymile,km_kirkwood"))
|
|
- km_kirkwood_init();
|
|
-
|
|
- if (of_machine_is_compatible("lacie,cloudbox") ||
|
|
- of_machine_is_compatible("lacie,inetspace_v2") ||
|
|
- of_machine_is_compatible("lacie,netspace_lite_v2") ||
|
|
- of_machine_is_compatible("lacie,netspace_max_v2") ||
|
|
- of_machine_is_compatible("lacie,netspace_mini_v2") ||
|
|
- of_machine_is_compatible("lacie,netspace_v2"))
|
|
- ns2_init();
|
|
-
|
|
- if (of_machine_is_compatible("marvell,db-88f6281-bp") ||
|
|
- of_machine_is_compatible("marvell,db-88f6282-bp"))
|
|
- db88f628x_init();
|
|
-
|
|
- if (of_machine_is_compatible("mpl,cec4"))
|
|
- mplcec4_init();
|
|
-
|
|
- if (of_machine_is_compatible("netgear,readynas-duo-v2"))
|
|
- netgear_readynas_init();
|
|
-
|
|
- if (of_machine_is_compatible("plathome,openblocks-a6"))
|
|
- openblocks_a6_init();
|
|
-
|
|
- if (of_machine_is_compatible("usi,topkick"))
|
|
- usi_topkick_init();
|
|
-
|
|
of_platform_populate(NULL, kirkwood_dt_match_table, NULL, NULL);
|
|
}
|
|
|
|
static const char * const kirkwood_dt_board_compat[] = {
|
|
- "globalscale,dreamplug",
|
|
- "globalscale,guruplug",
|
|
- "dlink,dns-320",
|
|
- "dlink,dns-325",
|
|
- "iom,iconnect",
|
|
- "raidsonic,ib-nas62x0",
|
|
- "qnap,ts219",
|
|
- "seagate,dockstar",
|
|
- "seagate,goflexnet",
|
|
- "buffalo,lsxl",
|
|
- "iom,ix2-200",
|
|
- "keymile,km_kirkwood",
|
|
- "lacie,cloudbox",
|
|
- "lacie,inetspace_v2",
|
|
- "lacie,netspace_lite_v2",
|
|
- "lacie,netspace_max_v2",
|
|
- "lacie,netspace_mini_v2",
|
|
- "lacie,netspace_v2",
|
|
- "marvell,db-88f6281-bp",
|
|
- "marvell,db-88f6282-bp",
|
|
- "mpl,cec4",
|
|
- "netgear,readynas-duo-v2",
|
|
- "plathome,openblocks-a6",
|
|
- "usi,topkick",
|
|
- "zyxel,nsa310",
|
|
+ "marvell,kirkwood",
|
|
NULL
|
|
};
|
|
|
|
diff --git a/arch/arm/mach-kirkwood/board-lsxl.c b/arch/arm/mach-kirkwood/board-lsxl.c
|
|
deleted file mode 100644
|
|
index 4ec8b7a..0000000
|
|
--- a/arch/arm/mach-kirkwood/board-lsxl.c
|
|
+++ /dev/null
|
|
@@ -1,52 +0,0 @@
|
|
-/*
|
|
- * Copyright 2012 (C), Michael Walle <michael@walle.cc>
|
|
- *
|
|
- * arch/arm/mach-kirkwood/board-lsxl.c
|
|
- *
|
|
- * Buffalo Linkstation LS-XHL and LS-CHLv2 init for drivers not
|
|
- * converted to flattened device tree yet.
|
|
- *
|
|
- * This file is licensed under the terms of the GNU General Public
|
|
- * License version 2. This program is licensed "as is" without any
|
|
- * warranty of any kind, whether express or implied.
|
|
- */
|
|
-
|
|
-#include <linux/kernel.h>
|
|
-#include <linux/init.h>
|
|
-#include <linux/platform_device.h>
|
|
-#include <linux/mv643xx_eth.h>
|
|
-#include "common.h"
|
|
-
|
|
-static struct mv643xx_eth_platform_data lsxl_ge00_data = {
|
|
- .phy_addr = MV643XX_ETH_PHY_ADDR(0),
|
|
-};
|
|
-
|
|
-static struct mv643xx_eth_platform_data lsxl_ge01_data = {
|
|
- .phy_addr = MV643XX_ETH_PHY_ADDR(8),
|
|
-};
|
|
-
|
|
-/*
|
|
- * On the LS-XHL/LS-CHLv2, the shutdown process is following:
|
|
- * - Userland monitors key events until the power switch goes to off position
|
|
- * - The board reboots
|
|
- * - U-boot starts and goes into an idle mode waiting for the user
|
|
- * to move the switch to ON position
|
|
- *
|
|
- */
|
|
-static void lsxl_power_off(void)
|
|
-{
|
|
- kirkwood_restart('h', NULL);
|
|
-}
|
|
-
|
|
-void __init lsxl_init(void)
|
|
-{
|
|
- /*
|
|
- * Basic setup. Needs to be called early.
|
|
- */
|
|
-
|
|
- kirkwood_ge00_init(&lsxl_ge00_data);
|
|
- kirkwood_ge01_init(&lsxl_ge01_data);
|
|
-
|
|
- /* register power-off method */
|
|
- pm_power_off = lsxl_power_off;
|
|
-}
|
|
diff --git a/arch/arm/mach-kirkwood/board-readynas.c b/arch/arm/mach-kirkwood/board-readynas.c
|
|
deleted file mode 100644
|
|
index fb42c20..0000000
|
|
--- a/arch/arm/mach-kirkwood/board-readynas.c
|
|
+++ /dev/null
|
|
@@ -1,28 +0,0 @@
|
|
-/*
|
|
- * NETGEAR ReadyNAS Duo v2 Board setup for drivers not already
|
|
- * converted to DT.
|
|
- *
|
|
- * Copyright (C) 2013, Arnaud EBALARD <arno@natisbad.org>
|
|
- *
|
|
- * This program is free software; you can redistribute it and/or
|
|
- * modify it under the terms of the GNU General Public License
|
|
- * as published by the Free Software Foundation; either version
|
|
- * 2 of the License, or (at your option) any later version.
|
|
- */
|
|
-
|
|
-#include <linux/kernel.h>
|
|
-#include <linux/init.h>
|
|
-#include <linux/platform_device.h>
|
|
-#include <linux/mv643xx_eth.h>
|
|
-#include <mach/kirkwood.h>
|
|
-#include "common.h"
|
|
-
|
|
-static struct mv643xx_eth_platform_data netgear_readynas_ge00_data = {
|
|
- .phy_addr = MV643XX_ETH_PHY_ADDR(0),
|
|
-};
|
|
-
|
|
-void __init netgear_readynas_init(void)
|
|
-{
|
|
- kirkwood_ge00_init(&netgear_readynas_ge00_data);
|
|
- kirkwood_pcie_init(KW_PCIE0);
|
|
-}
|
|
--
|
|
1.8.4.rc1
|
|
|