Index: linux-2.6.25.4/drivers/leds/Kconfig
===================================================================
--- linux-2.6.25.4.orig/drivers/leds/Kconfig
+++ linux-2.6.25.4/drivers/leds/Kconfig
@@ -125,6 +125,12 @@ config LEDS_GPIO
 	  outputs. To be useful the particular board must have LEDs
 	  and they must be connected to the GPIO lines.
 
+config LEDS_LATCH
+	tristate "LED Support for Memory Latched LEDs"
+	depends on LEDS_CLASS
+	help
+		-- To Do --
+
 config LEDS_CM_X270
 	tristate "LED Support for the CM-X270 LEDs"
 	depends on LEDS_CLASS && MACH_ARMCORE
Index: linux-2.6.25.4/drivers/leds/leds-latch.c
===================================================================
--- /dev/null
+++ linux-2.6.25.4/drivers/leds/leds-latch.c
@@ -0,0 +1,141 @@
+/*
+ * LEDs driver for Memory Latched Devices
+ *
+ * Copyright (C) 2008 Gateworks Corp.
+ * Chris Lang <clang@gateworks.com>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ *
+ */
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/leds.h>
+#include <linux/workqueue.h>
+#include <asm/io.h>
+#include <linux/spinlock.h>
+
+static unsigned int mem_keep = 0xFF;
+static spinlock_t mem_lock;
+static unsigned char *iobase;
+
+struct latch_led_data {
+	struct led_classdev cdev;
+	struct work_struct work;
+	u8 new_level;
+	u8 bit;
+};
+
+static void latch_led_set(struct led_classdev *led_cdev,
+	enum led_brightness value)
+{
+	struct latch_led_data *led_dat =
+		container_of(led_cdev, struct latch_led_data, cdev);
+
+	spin_lock(mem_lock);
+
+	if (value == LED_OFF)
+		mem_keep |= (0x1 << led_dat->bit);
+	else
+		mem_keep &= ~(0x1 << led_dat->bit);
+
+	writeb(mem_keep, iobase);
+
+	spin_unlock(mem_lock);
+}
+
+static int latch_led_probe(struct platform_device *pdev)
+{
+	struct latch_led_platform_data *pdata = pdev->dev.platform_data;
+	struct latch_led *cur_led;
+	struct latch_led_data *leds_data, *led_dat;
+	int i, ret = 0;
+
+	if (!pdata)
+		return -EBUSY;
+
+	leds_data = kzalloc(sizeof(struct latch_led_data) * pdata->num_leds,
+				GFP_KERNEL);
+	if (!leds_data)
+		return -ENOMEM;
+
+	iobase = ioremap_nocache(pdata->mem, 0x1000);
+	writeb(0xFF, iobase);
+
+	for (i = 0; i < pdata->num_leds; i++) {
+		cur_led = &pdata->leds[i];
+		led_dat = &leds_data[i];
+
+		led_dat->cdev.name = cur_led->name;
+		led_dat->cdev.default_trigger = cur_led->default_trigger;
+		led_dat->cdev.brightness_set = latch_led_set;
+		led_dat->cdev.brightness = LED_OFF;
+		led_dat->bit = cur_led->bit;
+
+		ret = led_classdev_register(&pdev->dev, &led_dat->cdev);
+		if (ret < 0) {
+			goto err;
+		}
+	}
+
+	platform_set_drvdata(pdev, leds_data);
+
+	return 0;
+
+err:
+	if (i > 0) {
+		for (i = i - 1; i >= 0; i--) {
+			led_classdev_unregister(&leds_data[i].cdev);
+		}
+	}
+
+	kfree(leds_data);
+
+	return ret;
+}
+
+static int __devexit latch_led_remove(struct platform_device *pdev)
+{
+	int i;
+	struct latch_led_platform_data *pdata = pdev->dev.platform_data;
+	struct latch_led_data *leds_data;
+
+	leds_data = platform_get_drvdata(pdev);
+
+	for (i = 0; i < pdata->num_leds; i++) {
+		led_classdev_unregister(&leds_data[i].cdev);
+		cancel_work_sync(&leds_data[i].work);
+	}
+
+	kfree(leds_data);
+
+	return 0;
+}
+
+static struct platform_driver latch_led_driver = {
+	.probe		= latch_led_probe,
+	.remove		= __devexit_p(latch_led_remove),
+	.driver		= {
+		.name	= "leds-latch",
+		.owner	= THIS_MODULE,
+	},
+};
+
+static int __init latch_led_init(void)
+{
+	return platform_driver_register(&latch_led_driver);
+}
+
+static void __exit latch_led_exit(void)
+{
+	platform_driver_unregister(&latch_led_driver);
+}
+
+module_init(latch_led_init);
+module_exit(latch_led_exit);
+
+MODULE_AUTHOR("Chris Lang <clang@gateworks.com>");
+MODULE_DESCRIPTION("Latch LED driver");
+MODULE_LICENSE("GPL");
Index: linux-2.6.25.4/drivers/leds/Makefile
===================================================================
--- linux-2.6.25.4.orig/drivers/leds/Makefile
+++ linux-2.6.25.4/drivers/leds/Makefile
@@ -19,6 +19,7 @@ obj-$(CONFIG_LEDS_H1940)		+= leds-h1940.
 obj-$(CONFIG_LEDS_COBALT_QUBE)		+= leds-cobalt-qube.o
 obj-$(CONFIG_LEDS_COBALT_RAQ)		+= leds-cobalt-raq.o
 obj-$(CONFIG_LEDS_GPIO)			+= leds-gpio.o
+obj-$(CONFIG_LEDS_LATCH)     += leds-latch.o
 obj-$(CONFIG_LEDS_CM_X270)              += leds-cm-x270.o
 obj-$(CONFIG_LEDS_CLEVO_MAIL)		+= leds-clevo-mail.o
 obj-$(CONFIG_LEDS_HP6XX)		+= leds-hp6xx.o
Index: linux-2.6.25.4/include/linux/leds.h
===================================================================
--- linux-2.6.25.4.orig/include/linux/leds.h
+++ linux-2.6.25.4/include/linux/leds.h
@@ -136,5 +136,18 @@ struct gpio_led_platform_data {
 	struct gpio_led *leds;
 };
 
+/* For the leds-latch driver */
+struct latch_led {
+	const char *name;
+	char *default_trigger;
+	unsigned  bit;
+};
+
+struct latch_led_platform_data {
+	int     num_leds;
+	u32     mem;
+	struct latch_led *leds;
+};
+
 
 #endif		/* __LINUX_LEDS_H_INCLUDED */