removed a missed dependancy on curl remove use of autogen, just run the one needed command from in it
SVN-Revision: 11991
This commit is contained in:
parent
029ef41bb1
commit
f988ff9a3a
3 changed files with 32 additions and 10 deletions
|
@ -22,7 +22,6 @@ include $(INCLUDE_DIR)/package.mk
|
|||
define Package/opkg
|
||||
SECTION:=base
|
||||
CATEGORY:=Base system
|
||||
DEPENDS:=+libcurl
|
||||
TITLE:=opkg package management system
|
||||
URL:=http://wiki.openmoko.org/wiki/Opkg
|
||||
endef
|
||||
|
@ -46,7 +45,7 @@ CONFIGURE_ARGS += \
|
|||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
./autogen.sh \
|
||||
autoreconf -v --install || exit 1 \
|
||||
);
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
|
|
@ -75,3 +75,34 @@ Index: opkg-4561/configure.ac
|
|||
|
||||
|
||||
dnl **********
|
||||
Index: opkg-4561/libopkg/opkg.c
|
||||
===================================================================
|
||||
--- opkg-4561/libopkg/opkg.c-orig 2008-07-28 16:27:53.000000000 -0500
|
||||
+++ opkg-4561/libopkg/opkg.c 2008-07-29 07:46:42.000000000 -0500
|
||||
@@ -1013,8 +1013,9 @@
|
||||
|
||||
return package;
|
||||
}
|
||||
-
|
||||
+#ifdef HAVE_CURL
|
||||
#include <curl/curl.h>
|
||||
+#endif
|
||||
/**
|
||||
* @brief Check the accessibility of repositories. It will try to access the repository to check if the respository is accessible throught current network status.
|
||||
* @param opkg The opkg_t
|
||||
@@ -1064,6 +1065,7 @@
|
||||
repositories--;
|
||||
|
||||
err = opkg_download(opkg->conf, iter1->data, "/dev/null", NULL, NULL);
|
||||
+ #ifdef HAVE_CURL
|
||||
if (!(err == CURLE_OK ||
|
||||
err == CURLE_HTTP_RETURNED_ERROR ||
|
||||
err == CURLE_FILE_COULDNT_READ_FILE ||
|
||||
@@ -1072,6 +1074,7 @@
|
||||
)) {
|
||||
ret++;
|
||||
}
|
||||
+ #endif
|
||||
str_list_elt_deinit(iter1);
|
||||
free(iter1);
|
||||
}
|
||||
|
|
|
@ -1,8 +0,0 @@
|
|||
--- opkg-4561/autogen.sh-orig 2008-07-28 18:00:33.000000000 -0500
|
||||
+++ opkg-4561/autogen.sh 2008-07-28 18:00:45.000000000 -0500
|
||||
@@ -1,5 +1,3 @@
|
||||
#! /bin/sh
|
||||
autoreconf -v --install || exit 1
|
||||
glib-gettextize --force --copy || exit 1
|
||||
-./configure --enable-maintainer-mode "$@"
|
||||
-
|
Loading…
Reference in a new issue