refresh patches
SVN-Revision: 15018
This commit is contained in:
parent
62595883fb
commit
f5dc2ce0aa
5 changed files with 19 additions and 28 deletions
|
@ -31,4 +31,3 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||
#else
|
||||
static inline int mips_clockevent_init(void)
|
||||
{
|
||||
|
||||
|
|
|
@ -19,7 +19,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
|
|||
|
||||
--- a/drivers/usb/host/ehci-hcd.c
|
||||
+++ b/drivers/usb/host/ehci-hcd.c
|
||||
@@ -1039,6 +1039,11 @@ MODULE_LICENSE ("GPL");
|
||||
@@ -1041,6 +1041,11 @@ MODULE_LICENSE ("GPL");
|
||||
#define PLATFORM_DRIVER ixp4xx_ehci_driver
|
||||
#endif
|
||||
|
||||
|
@ -33,7 +33,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
|
|||
#error "missing bus glue for ehci-hcd"
|
||||
--- a/drivers/usb/host/ehci.h
|
||||
+++ b/drivers/usb/host/ehci.h
|
||||
@@ -755,6 +755,11 @@ ehci_port_speed(struct ehci_hcd *ehci, u
|
||||
@@ -761,6 +761,11 @@ ehci_port_speed(struct ehci_hcd *ehci, u
|
||||
#define writel_be(val, addr) __raw_writel(val, (__force unsigned *)addr)
|
||||
#endif
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/spi/Kconfig 2009-03-06 02:24:35.000000000 +0100
|
||||
+++ b/drivers/spi/Kconfig 2009-03-06 02:25:01.000000000 +0100
|
||||
@@ -217,6 +217,13 @@
|
||||
--- a/drivers/spi/Kconfig
|
||||
+++ b/drivers/spi/Kconfig
|
||||
@@ -217,6 +217,13 @@ config SPI_XILINX
|
||||
See the "OPB Serial Peripheral Interface (SPI) (v1.00e)"
|
||||
Product Specification document (DS464) for hardware details.
|
||||
|
||||
|
@ -14,9 +14,9 @@
|
|||
#
|
||||
# Add new SPI master controllers in alphabetical order above this line
|
||||
#
|
||||
--- a/drivers/spi/Makefile 2009-03-06 02:25:07.000000000 +0100
|
||||
+++ b/drivers/spi/Makefile 2009-03-06 02:24:13.000000000 +0100
|
||||
@@ -30,6 +30,7 @@
|
||||
--- a/drivers/spi/Makefile
|
||||
+++ b/drivers/spi/Makefile
|
||||
@@ -30,6 +30,7 @@ obj-$(CONFIG_SPI_S3C24XX) += spi_s3c24x
|
||||
obj-$(CONFIG_SPI_TXX9) += spi_txx9.o
|
||||
obj-$(CONFIG_SPI_XILINX) += xilinx_spi.o
|
||||
obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.o
|
||||
|
|
|
@ -664,7 +664,7 @@
|
|||
#ifdef CONFIG_BRIDGE_NETFILTER
|
||||
struct nf_bridge_info *nf_bridge;
|
||||
#endif
|
||||
@@ -1642,6 +1646,10 @@ static inline void __nf_copy(struct sk_b
|
||||
@@ -1633,6 +1637,10 @@ static inline void __nf_copy(struct sk_b
|
||||
dst->nfct_reasm = src->nfct_reasm;
|
||||
nf_conntrack_get_reasm(src->nfct_reasm);
|
||||
#endif
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
Index: linux-2.6.28.7/drivers/ssb/pci.c
|
||||
===================================================================
|
||||
--- linux-2.6.28.7.orig/drivers/ssb/pci.c 2009-02-26 20:37:02.000000000 +0100
|
||||
+++ linux-2.6.28.7/drivers/ssb/pci.c 2009-02-26 20:41:44.000000000 +0100
|
||||
@@ -514,6 +514,7 @@ unsupported:
|
||||
--- a/drivers/ssb/pci.c
|
||||
+++ b/drivers/ssb/pci.c
|
||||
@@ -500,6 +500,7 @@ unsupported:
|
||||
static int ssb_pci_sprom_get(struct ssb_bus *bus,
|
||||
struct ssb_sprom *sprom)
|
||||
{
|
||||
|
@ -10,7 +8,7 @@ Index: linux-2.6.28.7/drivers/ssb/pci.c
|
|||
int err = -ENOMEM;
|
||||
u16 *buf;
|
||||
|
||||
@@ -533,12 +534,23 @@ static int ssb_pci_sprom_get(struct ssb_
|
||||
@@ -519,12 +520,23 @@ static int ssb_pci_sprom_get(struct ssb_
|
||||
bus->sprom_size = SSB_SPROMSIZE_WORDS_R4;
|
||||
sprom_do_read(bus, buf);
|
||||
err = sprom_check_crc(buf, bus->sprom_size);
|
||||
|
@ -35,10 +33,8 @@ Index: linux-2.6.28.7/drivers/ssb/pci.c
|
|||
kfree(buf);
|
||||
out:
|
||||
return err;
|
||||
Index: linux-2.6.28.7/drivers/ssb/sprom.c
|
||||
===================================================================
|
||||
--- linux-2.6.28.7.orig/drivers/ssb/sprom.c 2009-02-26 20:33:21.000000000 +0100
|
||||
+++ linux-2.6.28.7/drivers/ssb/sprom.c 2009-02-26 20:52:35.000000000 +0100
|
||||
--- a/drivers/ssb/sprom.c
|
||||
+++ b/drivers/ssb/sprom.c
|
||||
@@ -14,6 +14,9 @@
|
||||
#include "ssb_private.h"
|
||||
|
||||
|
@ -86,10 +82,8 @@ Index: linux-2.6.28.7/drivers/ssb/sprom.c
|
|||
+{
|
||||
+ return fallback_sprom;
|
||||
+}
|
||||
Index: linux-2.6.28.7/drivers/ssb/ssb_private.h
|
||||
===================================================================
|
||||
--- linux-2.6.28.7.orig/drivers/ssb/ssb_private.h 2009-02-26 20:36:33.000000000 +0100
|
||||
+++ linux-2.6.28.7/drivers/ssb/ssb_private.h 2009-02-26 20:36:56.000000000 +0100
|
||||
--- a/drivers/ssb/ssb_private.h
|
||||
+++ b/drivers/ssb/ssb_private.h
|
||||
@@ -131,6 +131,7 @@ ssize_t ssb_attr_sprom_store(struct ssb_
|
||||
const char *buf, size_t count,
|
||||
int (*sprom_check_crc)(const u16 *sprom, size_t size),
|
||||
|
@ -98,10 +92,8 @@ Index: linux-2.6.28.7/drivers/ssb/ssb_private.h
|
|||
|
||||
|
||||
/* core.c */
|
||||
Index: linux-2.6.28.7/include/linux/ssb/ssb.h
|
||||
===================================================================
|
||||
--- linux-2.6.28.7.orig/include/linux/ssb/ssb.h 2009-02-26 20:26:34.000000000 +0100
|
||||
+++ linux-2.6.28.7/include/linux/ssb/ssb.h 2009-02-26 20:32:30.000000000 +0100
|
||||
--- a/include/linux/ssb/ssb.h
|
||||
+++ b/include/linux/ssb/ssb.h
|
||||
@@ -339,6 +339,10 @@ extern int ssb_bus_pcmciabus_register(st
|
||||
|
||||
extern void ssb_bus_unregister(struct ssb_bus *bus);
|
||||
|
|
Loading…
Reference in a new issue