kernel: update 3.14 to 3.14.14
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 41898
This commit is contained in:
parent
7dabdbde78
commit
f548b18353
6 changed files with 8 additions and 8 deletions
|
@ -20,8 +20,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.13.7)
|
||||
LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.14.12)
|
||||
LINUX_KERNEL_MD5SUM:=7e76da2910683fe4dfbcec6ebfdd9a32
|
||||
ifeq ($(LINUX_VERSION),3.14.14)
|
||||
LINUX_KERNEL_MD5SUM:=aeea3b29cc823ada11270cfc23a27ae6
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/mtd/mtdpart.c
|
||||
+++ b/drivers/mtd/mtdpart.c
|
||||
@@ -331,7 +331,14 @@ static int part_lock(struct mtd_info *mt
|
||||
@@ -332,7 +332,14 @@ static int part_lock(struct mtd_info *mt
|
||||
static int part_unlock(struct mtd_info *mtd, loff_t ofs, uint64_t len)
|
||||
{
|
||||
struct mtd_part *part = PART(mtd);
|
||||
|
|
|
@ -79,7 +79,7 @@
|
|||
help
|
||||
--- a/net/core/dev.c
|
||||
+++ b/net/core/dev.c
|
||||
@@ -2607,10 +2607,20 @@ int dev_hard_start_xmit(struct sk_buff *
|
||||
@@ -2614,10 +2614,20 @@ int dev_hard_start_xmit(struct sk_buff *
|
||||
if (!list_empty(&ptype_all))
|
||||
dev_queue_xmit_nit(skb, dev);
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/mm/shmem.c
|
||||
+++ b/mm/shmem.c
|
||||
@@ -2963,6 +2963,15 @@ put_memory:
|
||||
@@ -3043,6 +3043,15 @@ put_memory:
|
||||
return res;
|
||||
}
|
||||
|
||||
|
@ -16,7 +16,7 @@
|
|||
/**
|
||||
* shmem_kernel_file_setup - get an unlinked file living in tmpfs which must be
|
||||
* kernel internal. There will be NO LSM permission checks against the
|
||||
@@ -3002,11 +3011,8 @@ int shmem_zero_setup(struct vm_area_stru
|
||||
@@ -3082,11 +3091,8 @@ int shmem_zero_setup(struct vm_area_stru
|
||||
file = shmem_file_setup("dev/zero", size, vma->vm_flags);
|
||||
if (IS_ERR(file))
|
||||
return PTR_ERR(file);
|
||||
|
|
|
@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
|
|||
CPU_SUBTYPE:=vfpv3
|
||||
MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.14.12
|
||||
LINUX_VERSION:=3.14.14
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=x86_64
|
|||
FEATURES:=ext4 vdi vmdk targz
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.14.12
|
||||
LINUX_VERSION:=3.14.14
|
||||
|
||||
KERNELNAME:=bzImage
|
||||
|
||||
|
|
Loading…
Reference in a new issue