parent
ac2af6affa
commit
f34b4c6e57
3 changed files with 17 additions and 15 deletions
|
@ -31,7 +31,6 @@ define KernelPackage/acx-mac80211
|
|||
TITLE:=ACX111 Mac80211 driver
|
||||
DESCRIPTION:=Driver for acx111 cards (Mac80211 version)
|
||||
DEPENDS:=@LINUX_2_6 +kmod-mac80211
|
||||
KCONFIG:=CONFIG_MAC80211
|
||||
FILES:=$(PKG_BUILD_DIR)/acx-mac80211.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
|
||||
endef
|
||||
|
|
|
@ -10,12 +10,16 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=acx
|
||||
PKG_VERSION:=20070101
|
||||
PKG_VERSION:=20070610
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@openwrt/
|
||||
PKG_MD5SUM:=ec6322b9c82781897a9433ef0cefda6f
|
||||
PKG_MD5SUM:=ce36d3d00f87a331d3dee6d5359d4499
|
||||
|
||||
PKG_FW_NAME:=tiacx111c16
|
||||
PKG_FW_URL:=http://teknoraver.campuslife.it/software/acx-mac80211/
|
||||
PKG_FW_MD5SUM:=7026826460376f6b174f9225bd7781b9
|
||||
|
||||
PKG_UNPACK:= \
|
||||
bzcat $(DL_DIR)/$(PKG_SOURCE) | \
|
||||
|
@ -37,6 +41,12 @@ define KernelPackage/acx/description
|
|||
This package contains a driver for TI ACX1xx 802.11a/b/g chipsets.
|
||||
endef
|
||||
|
||||
$(STAMP_BUILT): $(DL_DIR)/$(PKG_FW_NAME)
|
||||
|
||||
$(DL_DIR)/$(PKG_FW_NAME):
|
||||
$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_NAME)" "$(PKG_FW_MD5SUM)" $(PKG_FW_URL)
|
||||
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(LINUX_DIR) \
|
||||
SUBDIRS="$(PKG_BUILD_DIR)" \
|
||||
|
@ -53,4 +63,9 @@ define Build/Compile
|
|||
modules
|
||||
endef
|
||||
|
||||
define KernelPackage/acx/install
|
||||
$(INSTALL_DIR) $(1)/lib/firmware
|
||||
$(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_NAME) $(1)/lib/firmware/
|
||||
endef
|
||||
|
||||
$(eval $(call KernelPackage,acx))
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff -Nur acx-20070101/common.c acx-20070101-owrt/common.c
|
||||
--- acx-20070101/common.c 2007-01-10 22:15:27.000000000 +0100
|
||||
+++ acx-20070101-owrt/common.c 2007-06-02 18:02:39.000000000 +0200
|
||||
@@ -2754,7 +2754,7 @@
|
||||
skb->dev = adev->ndev;
|
||||
skb->dev->last_rx = jiffies;
|
||||
|
||||
- skb->mac.raw = skb->data;
|
||||
+// skb->mac.raw = skb->data;
|
||||
skb->ip_summed = CHECKSUM_NONE;
|
||||
skb->pkt_type = PACKET_OTHERHOST;
|
||||
skb->protocol = htons(ETH_P_80211_RAW);
|
Loading…
Reference in a new issue