x86: refresh kernel patches

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 44810
This commit is contained in:
Felix Fietkau 2015-03-16 07:12:31 +00:00
parent 9e0759ea26
commit f2f8f6974b
5 changed files with 7 additions and 7 deletions

View file

@ -1,6 +1,6 @@
--- a/arch/x86/Kconfig --- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig +++ b/arch/x86/Kconfig
@@ -480,6 +480,8 @@ config X86_RDC321X @@ -531,6 +531,8 @@ config X86_RDC321X
depends on X86_EXTENDED_PLATFORM depends on X86_EXTENDED_PLATFORM
select M486 select M486
select X86_REBOOTFIXUPS select X86_REBOOTFIXUPS

View file

@ -72,7 +72,7 @@
+ +
--- a/arch/x86/Kconfig --- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig +++ b/arch/x86/Kconfig
@@ -478,6 +478,7 @@ config X86_RDC321X @@ -529,6 +529,7 @@ config X86_RDC321X
bool "RDC R-321x SoC" bool "RDC R-321x SoC"
depends on X86_32 depends on X86_32
depends on X86_EXTENDED_PLATFORM depends on X86_EXTENDED_PLATFORM
@ -82,7 +82,7 @@
select EMBEDDED select EMBEDDED
--- a/arch/x86/include/asm/processor.h --- a/arch/x86/include/asm/processor.h
+++ b/arch/x86/include/asm/processor.h +++ b/arch/x86/include/asm/processor.h
@@ -137,7 +137,8 @@ struct cpuinfo_x86 { @@ -136,7 +136,8 @@ struct cpuinfo_x86 {
#define X86_VENDOR_CENTAUR 5 #define X86_VENDOR_CENTAUR 5
#define X86_VENDOR_TRANSMETA 7 #define X86_VENDOR_TRANSMETA 7
#define X86_VENDOR_NSC 8 #define X86_VENDOR_NSC 8
@ -94,7 +94,7 @@
--- a/arch/x86/kernel/cpu/Makefile --- a/arch/x86/kernel/cpu/Makefile
+++ b/arch/x86/kernel/cpu/Makefile +++ b/arch/x86/kernel/cpu/Makefile
@@ -26,6 +26,7 @@ obj-$(CONFIG_CPU_SUP_CYRIX_32) += cyrix @@ -29,6 +29,7 @@ obj-$(CONFIG_CPU_SUP_CYRIX_32) += cyrix
obj-$(CONFIG_CPU_SUP_CENTAUR) += centaur.o obj-$(CONFIG_CPU_SUP_CENTAUR) += centaur.o
obj-$(CONFIG_CPU_SUP_TRANSMETA_32) += transmeta.o obj-$(CONFIG_CPU_SUP_TRANSMETA_32) += transmeta.o
obj-$(CONFIG_CPU_SUP_UMC_32) += umc.o obj-$(CONFIG_CPU_SUP_UMC_32) += umc.o

View file

@ -1,6 +1,6 @@
--- a/scripts/Makefile.lib --- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib +++ b/scripts/Makefile.lib
@@ -304,7 +304,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^) @@ -325,7 +325,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
quiet_cmd_lzma = LZMA $@ quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \ cmd_lzma = (cat $(filter-out FORCE,$^) | \

View file

@ -11,7 +11,7 @@
struct erase_info erase; struct erase_info erase;
--- a/include/linux/mtd/mtd.h --- a/include/linux/mtd/mtd.h
+++ b/include/linux/mtd/mtd.h +++ b/include/linux/mtd/mtd.h
@@ -414,6 +414,9 @@ extern void register_mtd_user (struct mt @@ -416,6 +416,9 @@ extern void register_mtd_user (struct mt
extern int unregister_mtd_user (struct mtd_notifier *old); extern int unregister_mtd_user (struct mtd_notifier *old);
void *mtd_kmalloc_up_to(const struct mtd_info *mtd, size_t *size); void *mtd_kmalloc_up_to(const struct mtd_info *mtd, size_t *size);

View file

@ -1,6 +1,6 @@
--- a/drivers/mfd/rdc321x-southbridge.c --- a/drivers/mfd/rdc321x-southbridge.c
+++ b/drivers/mfd/rdc321x-southbridge.c +++ b/drivers/mfd/rdc321x-southbridge.c
@@ -86,6 +86,8 @@ static int rdc321x_sb_probe(struct pci_d @@ -85,6 +85,8 @@ static int rdc321x_sb_probe(struct pci_d
rdc321x_gpio_pdata.sb_pdev = pdev; rdc321x_gpio_pdata.sb_pdev = pdev;
rdc321x_wdt_pdata.sb_pdev = pdev; rdc321x_wdt_pdata.sb_pdev = pdev;