bcm53xx: use final (backported) patch fixing serial console

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>

SVN-Revision: 44059
This commit is contained in:
Rafał Miłecki 2015-01-20 08:04:27 +00:00
parent ea1fe45fae
commit f0d73a4381
6 changed files with 25 additions and 13 deletions

View file

@ -3,7 +3,7 @@ This patch does not contain any further code not in this mainline kernel.
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -371,6 +371,8 @@ source "drivers/mtd/onenand/Kconfig"
@@ -366,6 +366,8 @@ source "drivers/mtd/onenand/Kconfig"
source "drivers/mtd/lpddr/Kconfig"
@ -14,7 +14,7 @@ This patch does not contain any further code not in this mainline kernel.
endif # MTD
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -39,4 +39,5 @@ inftl-objs := inftlcore.o inftlmount.o
@@ -35,4 +35,5 @@ inftl-objs := inftlcore.o inftlmount.o
obj-y += chips/ lpddr/ maps/ devices/ nand/ onenand/ tests/

View file

@ -1,16 +1,19 @@
From 310a267714f7565dba8934dd51cdead6adc3b630 Mon Sep 17 00:00:00 2001
From 140bd60383309e82b5cae3294a907c11a0a12b90 Mon Sep 17 00:00:00 2001
From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sun, 14 Sep 2014 21:02:35 +0200
Subject: [PATCH 4/4] ARM: BCM5301X: fix early serial console
Date: Sun, 14 Sep 2014 21:43:40 +0200
Subject: [PATCH] ARM: BCM5301X: fix early serial console
This device actually has a 8250 serial with a shift of 0.
Tested this on a BCM4708.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
---
arch/arm/Kconfig.debug | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/Kconfig.debug b/arch/arm/Kconfig.debug
index 1c4889d..a528843 100644
--- a/arch/arm/Kconfig.debug
+++ b/arch/arm/Kconfig.debug
@@ -109,7 +109,7 @@ choice
@ -31,3 +34,6 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
default 2
config DEBUG_UART_8250_WORD
--
1.8.4.5

View file

@ -18,8 +18,8 @@ diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 91bd5bd..ff4a5ae 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -57,6 +57,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b-plus.dtb
@@ -52,6 +52,7 @@ dtb-$(CONFIG_ARCH_BCM_MOBILE) += bcm1135
dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
dtb-$(CONFIG_ARCH_BCM_5301X) += \
bcm4708-buffalo-wzr-1750dhp.dtb \
+ bcm4708-luxul-xwc-1000.dtb \

View file

@ -1,16 +1,19 @@
From 310a267714f7565dba8934dd51cdead6adc3b630 Mon Sep 17 00:00:00 2001
From 140bd60383309e82b5cae3294a907c11a0a12b90 Mon Sep 17 00:00:00 2001
From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sun, 14 Sep 2014 21:02:35 +0200
Subject: [PATCH 4/4] ARM: BCM5301X: fix early serial console
Date: Sun, 14 Sep 2014 21:43:40 +0200
Subject: [PATCH] ARM: BCM5301X: fix early serial console
This device actually has a 8250 serial with a shift of 0.
Tested this on a BCM4708.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
---
arch/arm/Kconfig.debug | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/Kconfig.debug b/arch/arm/Kconfig.debug
index 1c4889d..a528843 100644
--- a/arch/arm/Kconfig.debug
+++ b/arch/arm/Kconfig.debug
@@ -113,7 +113,7 @@ choice
@ -31,3 +34,6 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
default 2
config DEBUG_UART_8250_WORD
--
1.8.4.5

View file

@ -18,8 +18,8 @@ diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 91bd5bd..ff4a5ae 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -57,6 +57,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b-plus.dtb
@@ -56,6 +56,7 @@ dtb-$(CONFIG_ARCH_AXXIA) += axm5516-amar
dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
dtb-$(CONFIG_ARCH_BCM_5301X) += \
bcm4708-buffalo-wzr-1750dhp.dtb \
+ bcm4708-luxul-xwc-1000.dtb \

View file

@ -21,7 +21,7 @@ diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
index 4733d32..ab18030 100644
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -2286,6 +2286,8 @@ source "net/Kconfig"
@@ -2166,6 +2166,8 @@ source "net/Kconfig"
source "drivers/Kconfig"