mac80211: include the kfifo backport in compat.ko if necessary (fixes libertas, rt2x00)
SVN-Revision: 24978
This commit is contained in:
parent
2c0ac457ed
commit
f05691af93
2 changed files with 28 additions and 0 deletions
|
@ -994,6 +994,10 @@ MAKE_OPTS:= \
|
|||
KLIB=$(TARGET_MODULES_DIR) \
|
||||
KERNEL_SUBLEVEL=$(lastword $(subst ., ,$(KERNEL_PATCHVER)))
|
||||
|
||||
ifeq ($(CONFIG_PACKAGE_kmod-libertas-sd)$(CONFIG_PACKAGE_kmod-libertas-usb)$(CONFIG_PACKAGE_kmod-rt2x00-lib),)
|
||||
MAKE_OPTS += CONFIG_COMPAT_KFIFO=
|
||||
endif
|
||||
|
||||
define Build/Prepare
|
||||
rm -rf $(PKG_BUILD_DIR)
|
||||
mkdir -p $(PKG_BUILD_DIR)
|
||||
|
|
24
package/mac80211/patches/040-include_kfifo.patch
Normal file
24
package/mac80211/patches/040-include_kfifo.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- a/compat/Makefile
|
||||
+++ b/compat/Makefile
|
||||
@@ -2,9 +2,9 @@ obj-m += compat.o
|
||||
#compat-objs :=
|
||||
|
||||
obj-$(CONFIG_COMPAT_FIRMWARE_CLASS) += compat_firmware_class.o
|
||||
-obj-$(CONFIG_COMPAT_KFIFO) += kfifo.o
|
||||
|
||||
compat-y += main.o
|
||||
+compat-$(CONFIG_COMPAT_KFIFO) += kfifo.o
|
||||
|
||||
# Compat kernel compatibility code
|
||||
compat-$(CONFIG_COMPAT_KERNEL_14) += compat-2.6.14.o
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -90,7 +90,7 @@ endif #CONFIG_FW_LOADER
|
||||
endif #CONFIG_COMPAT_KERNEL_33
|
||||
|
||||
ifdef CONFIG_COMPAT_KERNEL_36
|
||||
-CONFIG_COMPAT_KFIFO=m
|
||||
+CONFIG_COMPAT_KFIFO=y
|
||||
endif #CONFIG_COMPAT_KERNEL_36
|
||||
|
||||
|
Loading…
Reference in a new issue