util-linux: fix endianess bug and stage libraries properly
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36985
This commit is contained in:
parent
9e7adce6a4
commit
ed6e69444a
2 changed files with 18 additions and 5 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=util-linux
|
||||
PKG_VERSION:=2.21.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.21
|
||||
|
@ -33,7 +33,7 @@ endef
|
|||
CONFIGURE_ARGS += \
|
||||
--enable-new-mount \
|
||||
--with-ncurses \
|
||||
--disable-nls \
|
||||
--disable-nls \
|
||||
--disable-tls \
|
||||
--without-udev
|
||||
|
||||
|
@ -58,9 +58,9 @@ define Build/InstallDev
|
|||
$(CP) $(PKG_BUILD_DIR)/libuuid/src/uuid.h $(1)/usr/include/uuid
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/libblkid/src/.libs/libblkid.{a,so.*} $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/libmount/src/.libs/libmount.{a,so.*} $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/libuuid/src/.libs/libuuid.{a,so.*} $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/libblkid/src/.libs/libblkid.{a,so*} $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/libmount/src/.libs/libmount.{a,so*} $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/libuuid/src/.libs/libuuid.{a,so*} $(1)/usr/lib
|
||||
endef
|
||||
|
||||
define Package/libblkid
|
||||
|
|
13
package/util-linux/patches/002-fix-endianess.patch
Normal file
13
package/util-linux/patches/002-fix-endianess.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
Index: util-linux-2.21.2/libblkid/src/superblocks/swap.c
|
||||
===================================================================
|
||||
--- util-linux-2.21.2.orig/libblkid/src/superblocks/swap.c 2012-05-15 13:51:45.814410455 +0200
|
||||
+++ util-linux-2.21.2/libblkid/src/superblocks/swap.c 2013-06-12 23:23:03.270742199 +0200
|
||||
@@ -48,7 +48,7 @@
|
||||
|
||||
/* SWAPSPACE2 - check for wrong version or zeroed pagecount */
|
||||
if (strcmp(version, "2") == 0 &&
|
||||
- (hdr->version != 1 || hdr->lastpage == 0))
|
||||
+ ((hdr->version != 1 && swab32(hdr->version) != 1) || hdr->lastpage == 0))
|
||||
return -1;
|
||||
|
||||
/* arbitrary sanity check.. is there any garbage down there? */
|
Loading…
Reference in a new issue