binutils: remove old unused versions
Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
3764caa934
commit
ecc091b0f6
10 changed files with 0 additions and 212 deletions
|
@ -7,21 +7,11 @@ choice
|
||||||
help
|
help
|
||||||
Select the version of binutils you wish to use.
|
Select the version of binutils you wish to use.
|
||||||
|
|
||||||
config BINUTILS_USE_VERSION_2_24_LINARO
|
|
||||||
depends on !arc
|
|
||||||
bool "Linaro binutils 2.24"
|
|
||||||
select BINUTILS_VERSION_2_24_LINARO
|
|
||||||
|
|
||||||
config BINUTILS_USE_VERSION_2_25_1
|
config BINUTILS_USE_VERSION_2_25_1
|
||||||
depends on !arc
|
depends on !arc
|
||||||
bool "Binutils 2.25.1"
|
bool "Binutils 2.25.1"
|
||||||
select BINUTILS_VERSION_2_25_1
|
select BINUTILS_VERSION_2_25_1
|
||||||
|
|
||||||
config BINUTILS_USE_VERSION_2_26_1
|
|
||||||
depends on !arc
|
|
||||||
bool "Binutils 2.26.1"
|
|
||||||
select BINUTILS_VERSION_2_26_1
|
|
||||||
|
|
||||||
config BINUTILS_USE_VERSION_2_27
|
config BINUTILS_USE_VERSION_2_27
|
||||||
depends on !arc
|
depends on !arc
|
||||||
bool "Binutils 2.27"
|
bool "Binutils 2.27"
|
||||||
|
|
|
@ -1,13 +1,7 @@
|
||||||
config BINUTILS_VERSION_2_24_LINARO
|
|
||||||
bool
|
|
||||||
|
|
||||||
config BINUTILS_VERSION_2_25_1
|
config BINUTILS_VERSION_2_25_1
|
||||||
default y if (!TOOLCHAINOPTS && !arc)
|
default y if (!TOOLCHAINOPTS && !arc)
|
||||||
bool
|
bool
|
||||||
|
|
||||||
config BINUTILS_VERSION_2_26_1
|
|
||||||
bool
|
|
||||||
|
|
||||||
config BINUTILS_VERSION_2_27
|
config BINUTILS_VERSION_2_27
|
||||||
bool
|
bool
|
||||||
|
|
||||||
|
@ -17,9 +11,7 @@ config BINUTILS_VERSION_2_26_ARC
|
||||||
|
|
||||||
config BINUTILS_VERSION
|
config BINUTILS_VERSION
|
||||||
string
|
string
|
||||||
default "2.24-linaro" if BINUTILS_VERSION_2_24_LINARO
|
|
||||||
default "2.25.1" if BINUTILS_VERSION_2_25_1
|
default "2.25.1" if BINUTILS_VERSION_2_25_1
|
||||||
default "2.26.1" if BINUTILS_VERSION_2_26_1
|
|
||||||
default "2.27" if BINUTILS_VERSION_2_27
|
default "2.27" if BINUTILS_VERSION_2_27
|
||||||
default "arc-2016.03" if BINUTILS_VERSION_2_26_ARC
|
default "arc-2016.03" if BINUTILS_VERSION_2_26_ARC
|
||||||
|
|
||||||
|
|
|
@ -1,22 +0,0 @@
|
||||||
--- a/ld/Makefile.am
|
|
||||||
+++ b/ld/Makefile.am
|
|
||||||
@@ -54,7 +54,7 @@ endif
|
|
||||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
|
||||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
|
||||||
# directives need to be different for native and cross linkers.
|
|
||||||
-scriptdir = $(tooldir)/lib
|
|
||||||
+scriptdir = $(libdir)
|
|
||||||
|
|
||||||
EMUL = @EMUL@
|
|
||||||
EMULATION_OFILES = @EMULATION_OFILES@
|
|
||||||
--- a/ld/Makefile.in
|
|
||||||
+++ b/ld/Makefile.in
|
|
||||||
@@ -388,7 +388,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
|
|
||||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
|
||||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
|
||||||
# directives need to be different for native and cross linkers.
|
|
||||||
-scriptdir = $(tooldir)/lib
|
|
||||||
+scriptdir = $(libdir)
|
|
||||||
BASEDIR = $(srcdir)/..
|
|
||||||
BFDDIR = $(BASEDIR)/bfd
|
|
||||||
INCDIR = $(BASEDIR)/include
|
|
|
@ -1,20 +0,0 @@
|
||||||
--- a/ld/emultempl/elf32.em
|
|
||||||
+++ b/ld/emultempl/elf32.em
|
|
||||||
@@ -1198,6 +1198,8 @@ fragment <<EOF
|
|
||||||
&& command_line.rpath == NULL)
|
|
||||||
{
|
|
||||||
lib_path = (const char *) getenv ("LD_RUN_PATH");
|
|
||||||
+ if ((lib_path) && (strlen (lib_path) == 0))
|
|
||||||
+ lib_path = NULL;
|
|
||||||
if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
|
|
||||||
force))
|
|
||||||
break;
|
|
||||||
@@ -1461,6 +1463,8 @@ gld${EMULATION_NAME}_before_allocation (
|
|
||||||
rpath = command_line.rpath;
|
|
||||||
if (rpath == NULL)
|
|
||||||
rpath = (const char *) getenv ("LD_RUN_PATH");
|
|
||||||
+ if ((rpath) && (strlen (rpath) == 0))
|
|
||||||
+ rpath = NULL;
|
|
||||||
|
|
||||||
for (abfd = link_info.input_bfds; abfd; abfd = abfd->link.next)
|
|
||||||
if (bfd_get_flavour (abfd) == bfd_target_elf_flavour)
|
|
|
@ -1,18 +0,0 @@
|
||||||
--- a/bfd/elfxx-mips.c
|
|
||||||
+++ b/bfd/elfxx-mips.c
|
|
||||||
@@ -7689,6 +7689,7 @@ _bfd_mips_elf_create_dynamic_sections (b
|
|
||||||
|
|
||||||
name = SGI_COMPAT (abfd) ? "_DYNAMIC_LINK" : "_DYNAMIC_LINKING";
|
|
||||||
bh = NULL;
|
|
||||||
+ if (0) {
|
|
||||||
if (!(_bfd_generic_link_add_one_symbol
|
|
||||||
(info, abfd, name, BSF_GLOBAL, bfd_abs_section_ptr, 0,
|
|
||||||
NULL, FALSE, get_elf_backend_data (abfd)->collect, &bh)))
|
|
||||||
@@ -7701,6 +7702,7 @@ _bfd_mips_elf_create_dynamic_sections (b
|
|
||||||
|
|
||||||
if (! bfd_elf_link_record_dynamic_symbol (info, h))
|
|
||||||
return FALSE;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
if (! mips_elf_hash_table (info)->use_rld_obj_head)
|
|
||||||
{
|
|
|
@ -1,37 +0,0 @@
|
||||||
--- a/bfd/config.bfd
|
|
||||||
+++ b/bfd/config.bfd
|
|
||||||
@@ -1062,12 +1062,12 @@ case "${targ}" in
|
|
||||||
targ_selvecs="mips_elf32_le_vec mips_elf64_be_vec mips_elf64_le_vec mips_ecoff_be_vec mips_ecoff_le_vec"
|
|
||||||
;;
|
|
||||||
mips64*el-*-linux*)
|
|
||||||
- targ_defvec=mips_elf32_ntrad_le_vec
|
|
||||||
- targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_le_vec mips_elf64_trad_be_vec"
|
|
||||||
+ targ_defvec=mips_elf64_trad_le_vec
|
|
||||||
+ targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_be_vec"
|
|
||||||
;;
|
|
||||||
mips64*-*-linux*)
|
|
||||||
- targ_defvec=mips_elf32_ntrad_be_vec
|
|
||||||
- targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_be_vec mips_elf64_trad_le_vec"
|
|
||||||
+ targ_defvec=mips_elf64_trad_be_vec
|
|
||||||
+ targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_le_vec"
|
|
||||||
;;
|
|
||||||
mips*el-*-linux*)
|
|
||||||
targ_defvec=mips_elf32_trad_le_vec
|
|
||||||
--- a/ld/configure.tgt
|
|
||||||
+++ b/ld/configure.tgt
|
|
||||||
@@ -476,11 +476,11 @@ mips*el-*-vxworks*) targ_emul=elf32elmip
|
|
||||||
mips*-*-vxworks*) targ_emul=elf32ebmipvxworks
|
|
||||||
targ_extra_emuls="elf32elmipvxworks" ;;
|
|
||||||
mips*-*-windiss) targ_emul=elf32mipswindiss ;;
|
|
||||||
-mips64*el-*-linux-*) targ_emul=elf32ltsmipn32
|
|
||||||
- targ_extra_emuls="elf32btsmipn32 elf32ltsmip elf32btsmip elf64ltsmip elf64btsmip"
|
|
||||||
+mips64*el-*-linux-*) targ_emul=elf64ltsmip
|
|
||||||
+ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32ltsmip elf32btsmip elf64btsmip"
|
|
||||||
targ_extra_libpath=$targ_extra_emuls ;;
|
|
||||||
-mips64*-*-linux-*) targ_emul=elf32btsmipn32
|
|
||||||
- targ_extra_emuls="elf32ltsmipn32 elf32btsmip elf32ltsmip elf64btsmip elf64ltsmip"
|
|
||||||
+mips64*-*-linux-*) targ_emul=elf64btsmip
|
|
||||||
+ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32btsmip elf32ltsmip elf64ltsmip"
|
|
||||||
targ_extra_libpath=$targ_extra_emuls ;;
|
|
||||||
mips*el-*-linux-*) targ_emul=elf32ltsmip
|
|
||||||
targ_extra_emuls="elf32btsmip elf32ltsmipn32 elf64ltsmip elf32btsmipn32 elf64btsmip"
|
|
|
@ -1,22 +0,0 @@
|
||||||
--- a/ld/Makefile.am
|
|
||||||
+++ b/ld/Makefile.am
|
|
||||||
@@ -54,7 +54,7 @@ endif
|
|
||||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
|
||||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
|
||||||
# directives need to be different for native and cross linkers.
|
|
||||||
-scriptdir = $(tooldir)/lib
|
|
||||||
+scriptdir = $(libdir)
|
|
||||||
|
|
||||||
EMUL = @EMUL@
|
|
||||||
EMULATION_OFILES = @EMULATION_OFILES@
|
|
||||||
--- a/ld/Makefile.in
|
|
||||||
+++ b/ld/Makefile.in
|
|
||||||
@@ -386,7 +386,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
|
|
||||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
|
||||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
|
||||||
# directives need to be different for native and cross linkers.
|
|
||||||
-scriptdir = $(tooldir)/lib
|
|
||||||
+scriptdir = $(libdir)
|
|
||||||
BASEDIR = $(srcdir)/..
|
|
||||||
BFDDIR = $(BASEDIR)/bfd
|
|
||||||
INCDIR = $(BASEDIR)/include
|
|
|
@ -1,20 +0,0 @@
|
||||||
--- a/ld/emultempl/elf32.em
|
|
||||||
+++ b/ld/emultempl/elf32.em
|
|
||||||
@@ -1267,6 +1267,8 @@ fragment <<EOF
|
|
||||||
&& command_line.rpath == NULL)
|
|
||||||
{
|
|
||||||
lib_path = (const char *) getenv ("LD_RUN_PATH");
|
|
||||||
+ if ((lib_path) && (strlen (lib_path) == 0))
|
|
||||||
+ lib_path = NULL;
|
|
||||||
if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
|
|
||||||
force))
|
|
||||||
break;
|
|
||||||
@@ -1518,6 +1520,8 @@ gld${EMULATION_NAME}_before_allocation (
|
|
||||||
rpath = command_line.rpath;
|
|
||||||
if (rpath == NULL)
|
|
||||||
rpath = (const char *) getenv ("LD_RUN_PATH");
|
|
||||||
+ if ((rpath) && (strlen (rpath) == 0))
|
|
||||||
+ rpath = NULL;
|
|
||||||
|
|
||||||
for (abfd = link_info.input_bfds; abfd; abfd = abfd->link_next)
|
|
||||||
if (bfd_get_flavour (abfd) == bfd_target_elf_flavour)
|
|
|
@ -1,18 +0,0 @@
|
||||||
--- a/bfd/elfxx-mips.c
|
|
||||||
+++ b/bfd/elfxx-mips.c
|
|
||||||
@@ -7450,6 +7450,7 @@ _bfd_mips_elf_create_dynamic_sections (b
|
|
||||||
|
|
||||||
name = SGI_COMPAT (abfd) ? "_DYNAMIC_LINK" : "_DYNAMIC_LINKING";
|
|
||||||
bh = NULL;
|
|
||||||
+ if (0) {
|
|
||||||
if (!(_bfd_generic_link_add_one_symbol
|
|
||||||
(info, abfd, name, BSF_GLOBAL, bfd_abs_section_ptr, 0,
|
|
||||||
NULL, FALSE, get_elf_backend_data (abfd)->collect, &bh)))
|
|
||||||
@@ -7462,6 +7463,7 @@ _bfd_mips_elf_create_dynamic_sections (b
|
|
||||||
|
|
||||||
if (! bfd_elf_link_record_dynamic_symbol (info, h))
|
|
||||||
return FALSE;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
if (! mips_elf_hash_table (info)->use_rld_obj_head)
|
|
||||||
{
|
|
|
@ -1,37 +0,0 @@
|
||||||
--- a/bfd/config.bfd
|
|
||||||
+++ b/bfd/config.bfd
|
|
||||||
@@ -1053,12 +1053,12 @@ case "${targ}" in
|
|
||||||
targ_selvecs="bfd_elf32_littlemips_vec bfd_elf64_bigmips_vec bfd_elf64_littlemips_vec ecoff_big_vec ecoff_little_vec"
|
|
||||||
;;
|
|
||||||
mips64*el-*-linux*)
|
|
||||||
- targ_defvec=bfd_elf32_ntradlittlemips_vec
|
|
||||||
- targ_selvecs="bfd_elf32_ntradbigmips_vec bfd_elf32_tradlittlemips_vec bfd_elf32_tradbigmips_vec bfd_elf64_tradlittlemips_vec bfd_elf64_tradbigmips_vec"
|
|
||||||
+ targ_defvec=bfd_elf64_tradlittlemips_vec
|
|
||||||
+ targ_selvecs="bfd_elf32_ntradbigmips_vec bfd_elf32_ntradlittlemips_vec bfd_elf32_tradlittlemips_vec bfd_elf32_tradbigmips_vec bfd_elf64_tradbigmips_vec"
|
|
||||||
;;
|
|
||||||
mips64*-*-linux*)
|
|
||||||
- targ_defvec=bfd_elf32_ntradbigmips_vec
|
|
||||||
- targ_selvecs="bfd_elf32_ntradlittlemips_vec bfd_elf32_tradbigmips_vec bfd_elf32_tradlittlemips_vec bfd_elf64_tradbigmips_vec bfd_elf64_tradlittlemips_vec"
|
|
||||||
+ targ_defvec=bfd_elf64_tradbigmips_vec
|
|
||||||
+ targ_selvecs="bfd_elf32_ntradbigmips_vec bfd_elf32_ntradlittlemips_vec bfd_elf32_tradbigmips_vec bfd_elf32_tradlittlemips_vec bfd_elf64_tradlittlemips_vec"
|
|
||||||
;;
|
|
||||||
mips*el-*-linux*)
|
|
||||||
targ_defvec=bfd_elf32_tradlittlemips_vec
|
|
||||||
--- a/ld/configure.tgt
|
|
||||||
+++ b/ld/configure.tgt
|
|
||||||
@@ -472,11 +472,11 @@ mips*el-*-vxworks*) targ_emul=elf32elmip
|
|
||||||
mips*-*-vxworks*) targ_emul=elf32ebmipvxworks
|
|
||||||
targ_extra_emuls="elf32elmipvxworks" ;;
|
|
||||||
mips*-*-windiss) targ_emul=elf32mipswindiss ;;
|
|
||||||
-mips64*el-*-linux-*) targ_emul=elf32ltsmipn32
|
|
||||||
- targ_extra_emuls="elf32btsmipn32 elf32ltsmip elf32btsmip elf64ltsmip elf64btsmip"
|
|
||||||
+mips64*el-*-linux-*) targ_emul=elf64ltsmip
|
|
||||||
+ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32ltsmip elf32btsmip elf64btsmip"
|
|
||||||
targ_extra_libpath=$targ_extra_emuls ;;
|
|
||||||
-mips64*-*-linux-*) targ_emul=elf32btsmipn32
|
|
||||||
- targ_extra_emuls="elf32ltsmipn32 elf32btsmip elf32ltsmip elf64btsmip elf64ltsmip"
|
|
||||||
+mips64*-*-linux-*) targ_emul=elf64btsmip
|
|
||||||
+ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32btsmip elf32ltsmip elf64ltsmip"
|
|
||||||
targ_extra_libpath=$targ_extra_emuls ;;
|
|
||||||
mips*el-*-linux-*) targ_emul=elf32ltsmip
|
|
||||||
targ_extra_emuls="elf32btsmip elf32ltsmipn32 elf64ltsmip elf32btsmipn32 elf64btsmip"
|
|
Loading…
Reference in a new issue