parent
da932d9e1a
commit
e96a64d75e
8 changed files with 24 additions and 52 deletions
|
@ -9,13 +9,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dropbear
|
||||
PKG_VERSION:=0.49
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.50
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
|
||||
http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
|
||||
PKG_MD5SUM:=7b20c85f1ee34f018a1b948eae003df9
|
||||
http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
|
||||
PKG_MD5SUM:=5c0f7405b915799c3d952d3a93a5df69
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -75,8 +75,7 @@ endef
|
|||
|
||||
define Package/dropbear/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearmulti \
|
||||
$(1)/usr/sbin/dropbear
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearmulti $(1)/usr/sbin/dropbear
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
ln -sf ../sbin/dropbear $(1)/usr/bin/scp
|
||||
ln -sf ../sbin/dropbear $(1)/usr/bin/ssh
|
||||
|
@ -93,8 +92,7 @@ endef
|
|||
|
||||
define Package/dropbearconvert/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearconvert \
|
||||
$(1)/usr/bin/dropbearconvert
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearconvert $(1)/usr/bin/dropbearconvert
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,dropbear))
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
Index: dropbear-0.49/svr-authpubkey.c
|
||||
Index: dropbear-0.50/svr-authpubkey.c
|
||||
===================================================================
|
||||
--- dropbear-0.49.orig/svr-authpubkey.c 2007-06-04 13:21:39.475975408 +0200
|
||||
+++ dropbear-0.49/svr-authpubkey.c 2007-06-04 13:21:39.542965224 +0200
|
||||
--- dropbear-0.50.orig/svr-authpubkey.c 2007-08-10 23:47:48.000000000 +0200
|
||||
+++ dropbear-0.50/svr-authpubkey.c 2007-08-10 23:47:48.000000000 +0200
|
||||
@@ -176,6 +176,8 @@
|
||||
goto out;
|
||||
}
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
Index: dropbear-0.49/svr-chansession.c
|
||||
Index: dropbear-0.50/svr-chansession.c
|
||||
===================================================================
|
||||
--- dropbear-0.49.orig/svr-chansession.c 2007-06-04 13:21:39.455978448 +0200
|
||||
+++ dropbear-0.49/svr-chansession.c 2007-06-04 13:21:39.751933456 +0200
|
||||
--- dropbear-0.50.orig/svr-chansession.c 2007-08-10 23:47:48.000000000 +0200
|
||||
+++ dropbear-0.50/svr-chansession.c 2007-08-10 23:47:48.000000000 +0200
|
||||
@@ -908,12 +908,12 @@
|
||||
/* We can only change uid/gid as root ... */
|
||||
if (getuid() == 0) {
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
Index: dropbear-0.49/cli-kex.c
|
||||
===================================================================
|
||||
--- dropbear-0.49.orig/cli-kex.c 2007-06-04 13:21:39.435981488 +0200
|
||||
+++ dropbear-0.49/cli-kex.c 2007-06-04 13:21:39.937905184 +0200
|
||||
@@ -126,7 +126,7 @@
|
||||
m_free(fp);
|
||||
return;
|
||||
}
|
||||
- fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)\n",
|
||||
+ fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)",
|
||||
cli_opts.remotehost,
|
||||
fp);
|
||||
m_free(fp);
|
|
@ -1,8 +1,8 @@
|
|||
Index: dropbear-0.49/cli-runopts.c
|
||||
Index: dropbear-0.50/cli-runopts.c
|
||||
===================================================================
|
||||
--- dropbear-0.49.orig/cli-runopts.c 2007-06-04 13:21:39.414984680 +0200
|
||||
+++ dropbear-0.49/cli-runopts.c 2007-06-04 13:21:40.122877064 +0200
|
||||
@@ -203,6 +203,10 @@
|
||||
--- dropbear-0.50.orig/cli-runopts.c 2007-08-10 23:47:47.000000000 +0200
|
||||
+++ dropbear-0.50/cli-runopts.c 2007-08-10 23:47:49.000000000 +0200
|
||||
@@ -219,6 +219,10 @@
|
||||
debug_trace = 1;
|
||||
break;
|
||||
#endif
|
||||
|
@ -13,7 +13,7 @@ Index: dropbear-0.49/cli-runopts.c
|
|||
case 'F':
|
||||
case 'e':
|
||||
case 'c':
|
||||
@@ -214,7 +218,6 @@
|
||||
@@ -230,7 +234,6 @@
|
||||
#ifndef ENABLE_CLI_LOCALTCPFWD
|
||||
case 'L':
|
||||
#endif
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
Index: dropbear-0.49/options.h
|
||||
===================================================================
|
||||
--- dropbear-0.49.orig/options.h 2007-06-04 13:21:39.394987720 +0200
|
||||
+++ dropbear-0.49/options.h 2007-06-04 13:21:40.305849248 +0200
|
||||
@@ -159,7 +159,7 @@
|
||||
* however significantly reduce the security of your ssh connections
|
||||
* if the PRNG state becomes guessable - make sure you know what you are
|
||||
* doing if you change this. */
|
||||
-#define DROPBEAR_RANDOM_DEV "/dev/random"
|
||||
+#define DROPBEAR_RANDOM_DEV "/dev/urandom"
|
||||
|
||||
/* prngd must be manually set up to produce output */
|
||||
/*#define DROPBEAR_PRNGD_SOCKET "/var/run/dropbear-rng"*/
|
|
@ -1,7 +1,7 @@
|
|||
Index: dropbear-0.49/options.h
|
||||
Index: dropbear-0.50/options.h
|
||||
===================================================================
|
||||
--- dropbear-0.49.orig/options.h 2007-06-04 13:21:40.305849248 +0200
|
||||
+++ dropbear-0.49/options.h 2007-06-04 13:21:40.493820672 +0200
|
||||
--- dropbear-0.50.orig/options.h 2007-08-10 23:47:47.000000000 +0200
|
||||
+++ dropbear-0.50/options.h 2007-08-10 23:47:49.000000000 +0200
|
||||
@@ -5,6 +5,11 @@
|
||||
#ifndef _OPTIONS_H_
|
||||
#define _OPTIONS_H_
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
Index: dropbear-0.49/common-channel.c
|
||||
Index: dropbear-0.50/common-channel.c
|
||||
===================================================================
|
||||
--- dropbear-0.49.orig/common-channel.c 2007-06-04 13:21:39.354993800 +0200
|
||||
+++ dropbear-0.49/common-channel.c 2007-06-04 13:21:40.676792856 +0200
|
||||
@@ -310,10 +310,10 @@
|
||||
--- dropbear-0.50.orig/common-channel.c 2007-08-10 23:47:47.000000000 +0200
|
||||
+++ dropbear-0.50/common-channel.c 2007-08-10 23:47:50.000000000 +0200
|
||||
@@ -311,10 +311,10 @@
|
||||
send_msg_channel_eof(channel);
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue