qca-nss-gmac: update to latest version

Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>

SVN-Revision: 45346
This commit is contained in:
John Crispin 2015-04-10 08:29:05 +00:00
parent 6adf864770
commit e946028610
2 changed files with 17 additions and 2 deletions

View file

@ -6,14 +6,14 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=qca-nss-gmac
PKG_VERSION:=20150210
PKG_VERSION:=20150408
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=git://codeaurora.org/quic/qsdk/oss/lklm/nss-gmac
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=969aab0aff40a3a5afe70d0f00e783b1c57aaea6
PKG_SOURCE_VERSION:=3dcb945b467f8f6b3c81338e63c917f768deb11e
PKG_LICENSE:=ISC

View file

@ -0,0 +1,15 @@
diff --git a/ipq806x/nss_gmac_tx_rx_offload.c b/ipq806x/nss_gmac_tx_rx_offload.c
index bc684a5..383403b 100644
--- a/ipq806x/nss_gmac_tx_rx_offload.c
+++ b/ipq806x/nss_gmac_tx_rx_offload.c
@@ -896,8 +896,8 @@ int nss_gmac_open(struct net_device *netdev)
nss_gmac_rx_refill(gmacdev);
/* Register IRQ */
- err = request_irq(netdev->irq, nss_gmac_handle_irq,
- IRQF_DISABLED, "nss-gmac", gmacdev);
+ err = request_irq(netdev->irq, nss_gmac_handle_irq, 0,
+ "nss-gmac", gmacdev);
if (err) {
netdev_dbg(netdev, "Mac %d IRQ %d request failed\n",
gmacdev->macid, netdev->irq);