madwifi: Fix linux 3.0 detection
Allows madwifi to be built against linux 3.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> SVN-Revision: 27188
This commit is contained in:
parent
dfcd340721
commit
e8974127fb
1 changed files with 25 additions and 0 deletions
25
package/madwifi/patches/476-3.0_detection_fix.patch
Normal file
25
package/madwifi/patches/476-3.0_detection_fix.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -155,13 +155,15 @@ unload:
|
||||
configcheck:
|
||||
@echo -n "Checking kernel configuration... "
|
||||
|
||||
- @# check version of kernel
|
||||
- @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \
|
||||
- echo "FAILED"; \
|
||||
- echo "Only kernel versions 2.4.x and above are supported."; \
|
||||
- echo "You have $(KERNELRELEASE)."; \
|
||||
- exit 1; \
|
||||
- }
|
||||
+ @# check kernel version
|
||||
+ @case $(KERNELRELEASE) in \
|
||||
+ 2.[456].*) ;; \
|
||||
+ [3-9].*) ;; \
|
||||
+ *) echo "FAILED"; \
|
||||
+ echo "Only kernel versions 2.4.x and above are supported."; \
|
||||
+ echo "You have $(KERNELRELEASE)."; \
|
||||
+ exit 1 ;; \
|
||||
+ esac
|
||||
|
||||
@# check kernel configuration
|
||||
@if [ -z "$(CONFIG_SYSCTL)" ]; then \
|
Loading…
Reference in a new issue