curl: update to version 7.50.3
This fixes the following security problems: 7.50.1: CVE-2016-5419 TLS session resumption client cert bypass CVE-2016-5420 Re-using connections with wrong client cert CVE-2016-5421 use of connection struct after free 7.50.2: CVE-2016-7141 Incorrect reuse of client certificates 7.50.3: CVE-2016-7167 curl escape and unescape integer overflows Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
6926325829
commit
df9efc9497
2 changed files with 3 additions and 3 deletions
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=curl
|
PKG_NAME:=curl
|
||||||
PKG_VERSION:=7.50.0
|
PKG_VERSION:=7.50.3
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
|
||||||
ftp://ftp.planetmirror.com/pub/curl/ \
|
ftp://ftp.planetmirror.com/pub/curl/ \
|
||||||
http://www.mirrormonster.com/curl/download/ \
|
http://www.mirrormonster.com/curl/download/ \
|
||||||
http://curl.mirrors.cyberservers.net/download/
|
http://curl.mirrors.cyberservers.net/download/
|
||||||
PKG_MD5SUM:=9e463ff8fdc1b5daa81c850c514980ec
|
PKG_MD5SUM:=7b7347d976661d02c84a1f4d6daf40dee377efdc45b9e2c77dedb8acf140d8ec
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -11,7 +11,7 @@
|
||||||
version>>24, (version>>16)&0xff, (version>>8)&0xff);
|
version>>24, (version>>16)&0xff, (version>>8)&0xff);
|
||||||
--- a/lib/vtls/mbedtls.c
|
--- a/lib/vtls/mbedtls.c
|
||||||
+++ b/lib/vtls/mbedtls.c
|
+++ b/lib/vtls/mbedtls.c
|
||||||
@@ -705,7 +705,7 @@ void Curl_mbedtls_session_free(void *ptr
|
@@ -713,7 +713,7 @@ void Curl_mbedtls_session_free(void *ptr
|
||||||
|
|
||||||
size_t Curl_mbedtls_version(char *buffer, size_t size)
|
size_t Curl_mbedtls_version(char *buffer, size_t size)
|
||||||
{
|
{
|
||||||
|
|
Loading…
Reference in a new issue