pkg-config: fix occasional install problem
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38886
This commit is contained in:
parent
3044b185d1
commit
d8b7d99478
2 changed files with 23 additions and 1 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2013 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
|
22
tools/pkg-config/patches/001-fix-package-rebuild.patch
Normal file
22
tools/pkg-config/patches/001-fix-package-rebuild.patch
Normal file
|
@ -0,0 +1,22 @@
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -39,7 +39,7 @@
|
||||||
|
if HOST_TOOL
|
||||||
|
host_tool = $(host)-pkg-config$(EXEEXT)
|
||||||
|
install-exec-hook:
|
||||||
|
- cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
|
||||||
|
+ cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
|
||||||
|
uninstall-hook:
|
||||||
|
cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
|
||||||
|
endif
|
||||||
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
|
@@ -1093,7 +1093,7 @@
|
||||||
|
uninstall-man1
|
||||||
|
|
||||||
|
@HOST_TOOL_TRUE@install-exec-hook:
|
||||||
|
-@HOST_TOOL_TRUE@ cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
|
||||||
|
+@HOST_TOOL_TRUE@ cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
|
||||||
|
@HOST_TOOL_TRUE@uninstall-hook:
|
||||||
|
@HOST_TOOL_TRUE@ cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
|
||||||
|
|
Loading…
Reference in a new issue