tools/quilt: fix openSUSE/patch-2.6.1.81 issue (closes #7635)
SVN-Revision: 22397
This commit is contained in:
parent
7a052dc799
commit
d83a959719
2 changed files with 12 additions and 0 deletions
|
@ -16,6 +16,7 @@ PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
|
|||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
define Host/Configure
|
||||
cd $(HOST_BUILD_DIR) && autoconf
|
||||
$(call Host/Configure/Default)
|
||||
[ -f $(HOST_BUILD_DIR)/Makefile ]
|
||||
endef
|
||||
|
|
11
tools/quilt/patches/100-patch_2.6.1_version.patch
Normal file
11
tools/quilt/patches/100-patch_2.6.1_version.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -274,7 +274,7 @@ fi
|
||||
AC_MSG_CHECKING([the version of $PATCH])
|
||||
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
|
||||
set -- `$PATCH --version 2> /dev/null`
|
||||
- patch_version=$2
|
||||
+ test $2 == "patch" && patch_version=$3 || patch_version=$2
|
||||
AC_MSG_RESULT($patch_version)
|
||||
saved_IFS=$IFS; IFS='.'
|
||||
set -- $patch_version
|
Loading…
Reference in a new issue