update to 2.6.32.29
SVN-Revision: 25583
This commit is contained in:
parent
31709b2c76
commit
d3c2b87213
23 changed files with 28 additions and 28 deletions
|
@ -8,8 +8,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),2.6.31.14)
|
||||
LINUX_KERNEL_MD5SUM:=3e7feb224197d8e174a90dd3759979fd
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.32.27)
|
||||
LINUX_KERNEL_MD5SUM:=c8df8bed01a3b7e4ce13563e74181d71
|
||||
ifeq ($(LINUX_VERSION),2.6.32.29)
|
||||
LINUX_KERNEL_MD5SUM:=0eea644c2cef06b4ec170228866b9685
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.34.7)
|
||||
LINUX_KERNEL_MD5SUM:=8964e26120e84844998a673464a980ea
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
BOARD:=adm5120
|
||||
BOARDNAME:=Infineon/ADMtek ADM5120
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
SUBTARGETS:=router_le router_be
|
||||
INITRAMFS_EXTRA_FILES:=
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=ar7
|
|||
BOARDNAME:=TI AR7
|
||||
FEATURES:=squashfs jffs2 atm
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
|
||||
SUBTARGETS:=generic nand
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
|||
BOARDNAME:=Atheros AR231x/AR5312
|
||||
FEATURES:=squashfs jffs2
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
|
|||
FEATURES:=targz pci ext4
|
||||
CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=etrax
|
|||
MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
|
||||
BOARDNAME:=Axis ETRAX 100LX
|
||||
FEATURES:=squashfs jffs2 usb
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
DEVICE_TYPE=
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -958,7 +958,7 @@
|
|||
dev_queue_xmit_nit(skb, dev);
|
||||
|
||||
if (netif_needs_gso(dev, skb)) {
|
||||
@@ -1789,8 +1796,7 @@ u16 skb_tx_hash(const struct net_device
|
||||
@@ -1797,8 +1804,7 @@ u16 skb_tx_hash(const struct net_device
|
||||
}
|
||||
EXPORT_SYMBOL(skb_tx_hash);
|
||||
|
||||
|
@ -968,7 +968,7 @@
|
|||
{
|
||||
const struct net_device_ops *ops = dev->netdev_ops;
|
||||
u16 queue_index = 0;
|
||||
@@ -1803,6 +1809,7 @@ static struct netdev_queue *dev_pick_tx(
|
||||
@@ -1811,6 +1817,7 @@ static struct netdev_queue *dev_pick_tx(
|
||||
skb_set_queue_mapping(skb, queue_index);
|
||||
return netdev_get_tx_queue(dev, queue_index);
|
||||
}
|
||||
|
|
|
@ -81,7 +81,7 @@
|
|||
|
||||
#include <asm/uaccess.h>
|
||||
|
||||
@@ -1405,3 +1406,121 @@ bool printk_timed_ratelimit(unsigned lon
|
||||
@@ -1407,3 +1408,121 @@ bool printk_timed_ratelimit(unsigned lon
|
||||
}
|
||||
EXPORT_SYMBOL(printk_timed_ratelimit);
|
||||
#endif
|
||||
|
|
|
@ -15,7 +15,7 @@
|
|||
+#endif
|
||||
--- a/init/Kconfig
|
||||
+++ b/init/Kconfig
|
||||
@@ -710,6 +710,9 @@ config NET_NS
|
||||
@@ -688,6 +688,9 @@ config NET_NS
|
||||
Allow user space to create what appear to be multiple instances
|
||||
of the network stack.
|
||||
|
||||
|
|
|
@ -40,7 +40,7 @@
|
|||
{
|
||||
--- a/kernel/exit.c
|
||||
+++ b/kernel/exit.c
|
||||
@@ -507,6 +507,7 @@ struct files_struct *get_files_struct(st
|
||||
@@ -514,6 +514,7 @@ struct files_struct *get_files_struct(st
|
||||
|
||||
return files;
|
||||
}
|
||||
|
@ -48,7 +48,7 @@
|
|||
|
||||
void put_files_struct(struct files_struct *files)
|
||||
{
|
||||
@@ -526,6 +527,7 @@ void put_files_struct(struct files_struc
|
||||
@@ -533,6 +534,7 @@ void put_files_struct(struct files_struc
|
||||
free_fdtable(fdt);
|
||||
}
|
||||
}
|
||||
|
@ -68,7 +68,7 @@
|
|||
* macro override instead of weak attribute alias, to workaround
|
||||
--- a/kernel/sched.c
|
||||
+++ b/kernel/sched.c
|
||||
@@ -6223,6 +6223,7 @@ int can_nice(const struct task_struct *p
|
||||
@@ -6362,6 +6362,7 @@ int can_nice(const struct task_struct *p
|
||||
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
|
||||
capable(CAP_SYS_NICE));
|
||||
}
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Intel IOP32x
|
|||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
SUBTARGETS=generic harddisk
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP35xx
|
|||
FEATURES:=broken
|
||||
SUBTARGETS=beagleboard gumstix
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
KERNELNAME:="uImage"
|
||||
|
||||
DEVICE_TYPE=developerboard
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Marvell/Intel PXA2xx
|
|||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
|||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=jffs2 pci targz
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=RDC 321x
|
|||
FEATURES:=squashfs jffs2 pci usb pcmcia
|
||||
CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=fpu
|
|||
CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=x86
|
|||
FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
|
||||
SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
|
||||
|
||||
LINUX_VERSION:=2.6.32.27
|
||||
LINUX_VERSION:=2.6.32.29
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
Loading…
Reference in a new issue