toolchain: Bump ARC tools to arc-2016.03
This change switches ARC tools to the most recent arc-2016.03 version. ARC GNU tools of version arc-2016.03 bring some quite significant changes like: * Binutils v2.26+ (upstream commit id 202ac19 with additional ARC * patches) * GCC v4.8.5 * GDB 7.10 More about changes, improvements and fixes could be found here: https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/tag/arc-2016.03 Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
This commit is contained in:
parent
8d105653b1
commit
d354bfde17
29 changed files with 49 additions and 23 deletions
|
@ -3,7 +3,7 @@
|
|||
choice
|
||||
prompt "Binutils Version" if TOOLCHAINOPTS
|
||||
default BINUTILS_USE_VERSION_2_25_1 if !arc
|
||||
default BINUTILS_USE_VERSION_2_23_ARC if arc
|
||||
default BINUTILS_USE_VERSION_2_26_ARC if arc
|
||||
help
|
||||
Select the version of binutils you wish to use.
|
||||
|
||||
|
@ -17,10 +17,10 @@ choice
|
|||
bool "Binutils 2.25.1"
|
||||
select BINUTILS_VERSION_2_25_1
|
||||
|
||||
config BINUTILS_USE_VERSION_2_23_ARC
|
||||
config BINUTILS_USE_VERSION_2_26_ARC
|
||||
depends on arc
|
||||
bool "ARC binutils 2.23"
|
||||
select BINUTILS_VERSION_2_23_ARC
|
||||
bool "ARC binutils 2.26"
|
||||
select BINUTILS_VERSION_2_26_ARC
|
||||
|
||||
endchoice
|
||||
|
||||
|
|
|
@ -5,7 +5,7 @@ config BINUTILS_VERSION_2_25_1
|
|||
default y if (!TOOLCHAINOPTS && !arc)
|
||||
bool
|
||||
|
||||
config BINUTILS_VERSION_2_23_ARC
|
||||
config BINUTILS_VERSION_2_26_ARC
|
||||
default y if (!TOOLCHAINOPTS && arc)
|
||||
bool
|
||||
|
||||
|
@ -13,5 +13,5 @@ config BINUTILS_VERSION
|
|||
string
|
||||
default "2.24-linaro" if BINUTILS_VERSION_2_24_LINARO
|
||||
default "2.25.1" if BINUTILS_VERSION_2_25_1
|
||||
default "arc-2015.06" if BINUTILS_VERSION_2_23_ARC
|
||||
default "arc-2016.03" if BINUTILS_VERSION_2_26_ARC
|
||||
|
||||
|
|
|
@ -26,11 +26,11 @@ ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
|
|||
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
|
||||
endif
|
||||
|
||||
ifneq ($(CONFIG_BINUTILS_VERSION_2_23_ARC),)
|
||||
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2015.06/
|
||||
PKG_REV:=2015.06
|
||||
ifneq ($(CONFIG_BINUTILS_VERSION_2_26_ARC),)
|
||||
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2016.03/
|
||||
PKG_REV:=2016.03
|
||||
PKG_SOURCE:=$(PKG_NAME)-arc-$(PKG_REV).tar.gz
|
||||
PKG_MD5SUM:=961a3564de857238c255c381f8e4360b
|
||||
PKG_MD5SUM:=d4387bab089df77a8049c81980b9fa12
|
||||
BINUTILS_DIR:=$(PKG_NAME)-gdb-arc-$(PKG_REV)
|
||||
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
|
||||
endif
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
diff --git a/bfd/config.bfd b/bfd/config.bfd
|
||||
index 5145d4a..a9c9c99 100644
|
||||
--- a/bfd/config.bfd
|
||||
+++ b/bfd/config.bfd
|
||||
@@ -275,7 +275,7 @@ case "${targ}" in
|
||||
targ_defvec=am33_elf32_linux_vec
|
||||
;;
|
||||
|
||||
- arc*-*-elf* | arc*-*-linux-uclibc*)
|
||||
+ arc*-*-elf* | arc*-*-linux-*)
|
||||
targ_defvec=arc_elf32_le_vec
|
||||
targ_selvecs=arc_elf32_be_vec
|
||||
;;
|
|
@ -5,7 +5,7 @@ config GCC_VERSION_4_8_ARC
|
|||
config GCC_VERSION
|
||||
string
|
||||
default "4.8-linaro" if GCC_VERSION_4_8_LINARO
|
||||
default "arc-2015.06" if GCC_VERSION_4_8_ARC
|
||||
default "arc-2016.03" if GCC_VERSION_4_8_ARC
|
||||
default "5.3.0"
|
||||
|
||||
config GCC_VERSION_4_8
|
||||
|
|
|
@ -33,11 +33,11 @@ ifeq ($(PKG_VERSION),5.3.0)
|
|||
endif
|
||||
|
||||
ifneq ($(CONFIG_GCC_VERSION_4_8_ARC),)
|
||||
PKG_VERSION:=4.8.4
|
||||
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/archive/arc-2015.06
|
||||
PKG_VERSION:=4.8.5
|
||||
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/archive/arc-2016.03
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(GCC_VERSION).tar.gz
|
||||
PKG_MD5SUM:=25007ebb02a5f6c32532b103bb5984a0
|
||||
PKG_REV:=2015.06
|
||||
PKG_MD5SUM:=ca59c8140d6efd07b97a18869bddbb53
|
||||
PKG_REV:=2016.03
|
||||
GCC_DIR:=gcc-arc-$(PKG_REV)
|
||||
HOST_BUILD_DIR = $(BUILD_DIR_HOST)/$(PKG_NAME)-$(GCC_VERSION)
|
||||
endif
|
||||
|
|
|
@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=gdb
|
||||
|
||||
ifeq ($(CONFIG_arc),y)
|
||||
PKG_VERSION:=arc-2015.06-gdb
|
||||
PKG_VERSION:=arc-2016.03-gdb
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2015.06-gdb/
|
||||
PKG_MD5SUM:=d318829bfd2ed62714817f0d25706825
|
||||
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2016.03-gdb
|
||||
PKG_MD5SUM:=775caaf6385c16f20b6f53c0a2b95f79
|
||||
GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
|
||||
else
|
||||
PKG_VERSION:=7.11
|
||||
|
|
|
@ -21,11 +21,11 @@
|
|||
+#endif /* DEFINE_NON_INLINE_P */
|
||||
--- a/sim/common/sim-arange.h
|
||||
+++ b/sim/common/sim-arange.h
|
||||
@@ -62,7 +62,7 @@ extern void sim_addr_range_delete (ADDR_
|
||||
@@ -73,7 +73,7 @@ extern void sim_addr_range_delete (ADDR_
|
||||
|
||||
/* Return non-zero if ADDR is in range AR, traversing the entire tree.
|
||||
If no range is specified, that is defined to mean "everything". */
|
||||
-extern INLINE int
|
||||
-SIM_ARANGE_INLINE int
|
||||
+extern int
|
||||
sim_addr_range_hit_p (ADDR_RANGE * /*ar*/, address_word /*addr*/);
|
||||
#define ADDR_RANGE_HIT_P(ar, addr) \
|
|
@ -1,6 +1,6 @@
|
|||
--- a/gdb/configure
|
||||
+++ b/gdb/configure
|
||||
@@ -855,8 +855,7 @@ MAKEINFOFLAGS
|
||||
@@ -870,8 +870,7 @@ MAKEINFOFLAGS
|
||||
YACC
|
||||
YFLAGS
|
||||
XMKMF'
|
||||
|
@ -10,7 +10,7 @@
|
|||
multi-ice
|
||||
gdbserver'
|
||||
|
||||
@@ -5168,7 +5167,7 @@ $as_echo "$with_auto_load_safe_path" >&6
|
||||
@@ -5610,7 +5610,7 @@ $as_echo "$with_auto_load_safe_path" >&6
|
||||
|
||||
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- a/gdb/gdbserver/configure
|
||||
+++ b/gdb/gdbserver/configure
|
||||
@@ -2183,7 +2183,7 @@ $as_echo "$as_me: error: \`$ac_var' was
|
||||
@@ -2468,7 +2468,7 @@ $as_echo "$as_me: error: \`$ac_var' was
|
||||
ac_cache_corrupted=: ;;
|
||||
,);;
|
||||
*)
|
|
@ -0,0 +1,13 @@
|
|||
diff --git a/bfd/config.bfd b/bfd/config.bfd
|
||||
index 5145d4a..a9c9c99 100644
|
||||
--- a/bfd/config.bfd
|
||||
+++ b/bfd/config.bfd
|
||||
@@ -275,7 +275,7 @@ case "${targ}" in
|
||||
targ_defvec=am33_elf32_linux_vec
|
||||
;;
|
||||
|
||||
- arc*-*-elf* | arc*-*-linux-uclibc*)
|
||||
+ arc*-*-elf* | arc*-*-linux-*)
|
||||
targ_defvec=arc_elf32_le_vec
|
||||
targ_selvecs=arc_elf32_be_vec
|
||||
;;
|
Loading…
Reference in a new issue