uboot-mvebu: add package
Signed-off-by: Andrej Vlasic <andrej.vlasic@sartura.hr> Signed-off-by: Vladimir Vid <vladimir.vid@sartura.hr> SVN-Revision: 49088
This commit is contained in:
parent
8258f8edb6
commit
d1aa4bfe1d
2 changed files with 102 additions and 0 deletions
91
package/boot/uboot-mvebu/Makefile
Normal file
91
package/boot/uboot-mvebu/Makefile
Normal file
|
@ -0,0 +1,91 @@
|
|||
#
|
||||
# Copyright (C) 2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=u-boot
|
||||
PKG_VERSION:=2016.03
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=\
|
||||
http://mirror2.openwrt.org/sources \
|
||||
ftp://ftp.denx.de/pub/u-boot
|
||||
PKG_MD5SUM:=973c1d896be751321cc3aafa564f64b2
|
||||
|
||||
PKG_LICENSE:=GPL-2.0 GPL-2.0+
|
||||
PKG_LICENSE_FILES:=Licenses/README
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define uboot/Default
|
||||
TITLE:=
|
||||
endef
|
||||
|
||||
define uboot/clearfog
|
||||
TITLE:=U-Boot for SolidRun ClearFog A1
|
||||
endef
|
||||
|
||||
UBOOTS:= \
|
||||
clearfog
|
||||
|
||||
define Package/uboot/template
|
||||
define Package/uboot-mvebu-$(1)
|
||||
SECTION:=boot
|
||||
CATEGORY:=Boot Loaders
|
||||
DEPENDS:=@TARGET_mvebu
|
||||
TITLE:=$(2)
|
||||
URL:=http://www.denx.de/wiki/U-Boot
|
||||
VARIANT:=$(1)
|
||||
MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||
endef
|
||||
endef
|
||||
|
||||
define BuildUBootPackage
|
||||
$(eval $(uboot/Default))
|
||||
$(eval $(uboot/$(1)))
|
||||
$(call Package/uboot/template,$(1),$(TITLE))
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
||||
$(BUILD_VARIANT)_config
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
||||
CROSS_COMPILE=$(TARGET_CROSS) \
|
||||
DTC_DIR=$(LINUX_DIR)/scripts/dtc/
|
||||
endef
|
||||
|
||||
define Package/uboot/install/default
|
||||
$(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
|
||||
$(CP) $(PKG_BUILD_DIR)/u-boot-spl.kwb \
|
||||
$(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot-spl.kwb
|
||||
$(INSTALL_DIR) $(BIN_DIR)/u-boot-kwboot/
|
||||
$(CP) $(PKG_BUILD_DIR)/tools/kwboot \
|
||||
$(BIN_DIR)/u-boot-kwboot/
|
||||
endef
|
||||
|
||||
define Package/uboot/install/template
|
||||
define Package/uboot-mvebu-$(1)/install
|
||||
$(call Package/uboot/install/default,$(2))
|
||||
endef
|
||||
endef
|
||||
|
||||
$(foreach u,$(UBOOTS), \
|
||||
$(eval $(call Package/uboot/install/template,$(u),$(u))) \
|
||||
)
|
||||
|
||||
$(foreach u,$(UBOOTS), \
|
||||
$(eval $(call BuildUBootPackage,$(u))) \
|
||||
$(eval $(call BuildPackage,uboot-mvebu-$(u))) \
|
||||
)
|
11
package/boot/uboot-mvebu/patches/001-use-dtc-in-kernel.patch
Normal file
11
package/boot/uboot-mvebu/patches/001-use-dtc-in-kernel.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -348,7 +348,7 @@ OBJDUMP = $(CROSS_COMPILE)objdump
|
||||
AWK = awk
|
||||
PERL = perl
|
||||
PYTHON = python
|
||||
-DTC = dtc
|
||||
+DTC = $(DTC_DIR)dtc
|
||||
CHECK = sparse
|
||||
|
||||
CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \
|
Loading…
Reference in a new issue