tools: add tar host build, required for --sort=name which was only added in the latest version
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46876
This commit is contained in:
parent
accc5e3693
commit
caddbf5431
3 changed files with 50 additions and 0 deletions
|
@ -81,6 +81,9 @@ endif
|
|||
# dependency for tools which have patches directory
|
||||
$(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/install)))
|
||||
|
||||
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/tar/install))
|
||||
tools-y += tar
|
||||
|
||||
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
|
||||
$(curdir)/builddirs-default := $(tools-y)
|
||||
|
||||
|
|
30
tools/tar/Makefile
Normal file
30
tools/tar/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
#
|
||||
# Copyright (C) 2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tar
|
||||
PKG_VERSION:=1.28
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/tar
|
||||
PKG_MD5SUM:=49b6306167724fe48f419a33a5beb857
|
||||
|
||||
HOST_BUILD_PARALLEL := 1
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
HOSTCC := $(HOSTCC_NOCACHE)
|
||||
HOSTCXX := $(HOSTCXX_NOCACHE)
|
||||
|
||||
HOST_CONFIGURE_ARGS += \
|
||||
--without-posix-acls \
|
||||
--without-selinux \
|
||||
--without-xattrs \
|
||||
--disable-acl \
|
||||
--disable-nls
|
||||
|
||||
$(eval $(call HostBuild))
|
17
tools/tar/patches/100-fix_xattr_disable.patch
Normal file
17
tools/tar/patches/100-fix_xattr_disable.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- a/lib/xattr-at.c
|
||||
+++ b/lib/xattr-at.c
|
||||
@@ -18,6 +18,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#ifdef HAVE_XATTRS
|
||||
+
|
||||
#include "xattr-at.h"
|
||||
#include "openat.h"
|
||||
|
||||
@@ -108,3 +110,5 @@
|
||||
#undef AT_FUNC_RESULT
|
||||
#undef AT_FUNC_POST_FILE_PARAM_DECLS
|
||||
#undef AT_FUNC_POST_FILE_ARGS
|
||||
+
|
||||
+#endif
|
Loading…
Reference in a new issue