package/boot: update uboot-kirkwood to 2017.03
Bump uboot-kirkwood to upstream release 2017.03 Signed-off-by: Paul Wassi <p.wassi@gmx.at>
This commit is contained in:
parent
2fd1a3e912
commit
c95c3165b9
9 changed files with 30 additions and 29 deletions
|
@ -7,10 +7,10 @@
|
|||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_VERSION:=2016.09.01
|
||||
PKG_VERSION:=2017.03
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_HASH:=95728e89dd476d17428f94080752ab48884be477b6a678941582aeef618b70bb
|
||||
PKG_HASH:=f54baf3f9325bf444c7905f3a5b6f83680edb1e6e1a4d5f8a5ad80abe885113f
|
||||
|
||||
include $(INCLUDE_DIR)/u-boot.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
|
|
@ -27,7 +27,7 @@ diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
|||
index 9205b1e..819bd3b 100644
|
||||
--- a/arch/arm/mach-kirkwood/Kconfig
|
||||
+++ b/arch/arm/mach-kirkwood/Kconfig
|
||||
@@ -49,6 +49,9 @@ config TARGET_GOFLEXHOME
|
||||
@@ -53,6 +53,9 @@ config TARGET_GOFLEXHOME
|
||||
config TARGET_NAS220
|
||||
bool "BlackArmor NAS220"
|
||||
|
||||
|
@ -37,7 +37,7 @@ index 9205b1e..819bd3b 100644
|
|||
config TARGET_NSA310S
|
||||
bool "Zyxel NSA310S"
|
||||
|
||||
@@ -72,6 +75,7 @@ source "board/raidsonic/ib62x0/Kconfig"
|
||||
@@ -77,6 +80,7 @@ source "board/raidsonic/ib62x0/Kconfig"
|
||||
source "board/Seagate/dockstar/Kconfig"
|
||||
source "board/Seagate/goflexhome/Kconfig"
|
||||
source "board/Seagate/nas220/Kconfig"
|
||||
|
|
|
@ -2,7 +2,7 @@ diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
|||
index 819bd3b..6a2d578 100644
|
||||
--- a/arch/arm/mach-kirkwood/Kconfig
|
||||
+++ b/arch/arm/mach-kirkwood/Kconfig
|
||||
@@ -55,6 +55,9 @@ config TARGET_NSA310
|
||||
@@ -59,6 +59,9 @@ config TARGET_NSA310
|
||||
config TARGET_NSA310S
|
||||
bool "Zyxel NSA310S"
|
||||
|
||||
|
@ -12,7 +12,7 @@ index 819bd3b..6a2d578 100644
|
|||
endchoice
|
||||
|
||||
config SYS_SOC
|
||||
@@ -77,5 +80,6 @@ source "board/Seagate/goflexhome/Kconfig"
|
||||
@@ -82,5 +85,6 @@ source "board/Seagate/goflexhome/Kconfig"
|
||||
source "board/Seagate/nas220/Kconfig"
|
||||
source "board/zyxel/nsa310/Kconfig"
|
||||
source "board/zyxel/nsa310s/Kconfig"
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
--- a/include/configs/dockstar.h
|
||||
+++ b/include/configs/dockstar.h
|
||||
@@ -31,6 +31,7 @@
|
||||
* Commands configuration
|
||||
*/
|
||||
#define CONFIG_SYS_NO_FLASH /* Declare no flash (NOR/SPI) */
|
||||
@@ -19,6 +19,7 @@
|
||||
#define CONFIG_KW88F6281 1 /* SOC Name */
|
||||
#define CONFIG_MACH_DOCKSTAR /* Machine type */
|
||||
#define CONFIG_SKIP_LOWLEVEL_INIT /* disable board lowlevel_init */
|
||||
+#define CONFIG_SYS_MVFS
|
||||
#define CONFIG_CMD_ENV
|
||||
#define CONFIG_CMD_NAND
|
||||
|
||||
/*
|
||||
@@ -53,29 +54,29 @@
|
||||
* Commands configuration
|
||||
@@ -45,29 +46,29 @@
|
||||
* it has to be rounded to sector size
|
||||
*/
|
||||
#define CONFIG_ENV_SIZE 0x20000 /* 128k */
|
||||
|
@ -26,11 +26,12 @@
|
|||
- "ubifsload 0x800000 ${kernel}; " \
|
||||
- "ubifsload 0x1100000 ${initrd}; " \
|
||||
- "bootm 0x800000 0x1100000"
|
||||
-
|
||||
-#define CONFIG_MTDPARTS "mtdparts=orion_nand:1m(uboot),-(root)\0"
|
||||
+ "ubi part ubi; " \
|
||||
+ "ubi read 0x800000 kernel; " \
|
||||
+ "bootm 0x800000"
|
||||
|
||||
-#define CONFIG_MTDPARTS "mtdparts=orion_nand:1m(uboot),-(root)\0"
|
||||
+
|
||||
+#define CONFIG_MTDPARTS \
|
||||
+ "mtdparts=orion_nand:" \
|
||||
+ "0xe0000@0x0(uboot)," \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/include/configs/iconnect.h
|
||||
+++ b/include/configs/iconnect.h
|
||||
@@ -59,30 +59,29 @@
|
||||
@@ -51,30 +51,29 @@
|
||||
#define CONFIG_ENV_IS_NOWHERE
|
||||
#endif
|
||||
#define CONFIG_ENV_SIZE 0x20000
|
||||
|
@ -42,7 +42,7 @@
|
|||
* Ethernet driver configuration
|
||||
--- a/configs/iconnect_defconfig
|
||||
+++ b/configs/iconnect_defconfig
|
||||
@@ -7,6 +7,7 @@ CONFIG_SYS_PROMPT="iconnect => "
|
||||
@@ -9,6 +9,7 @@ CONFIG_SYS_PROMPT="iconnect => "
|
||||
# CONFIG_CMD_FLASH is not set
|
||||
CONFIG_CMD_USB=y
|
||||
# CONFIG_CMD_SETEXPR is not set
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/include/configs/ib62x0.h
|
||||
+++ b/include/configs/ib62x0.h
|
||||
@@ -62,27 +62,22 @@
|
||||
@@ -54,27 +54,22 @@
|
||||
*/
|
||||
#define CONFIG_BOOTCOMMAND \
|
||||
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/include/configs/pogo_e02.h
|
||||
+++ b/include/configs/pogo_e02.h
|
||||
@@ -54,23 +54,30 @@
|
||||
@@ -49,23 +49,30 @@
|
||||
#endif
|
||||
|
||||
#define CONFIG_ENV_SIZE 0x20000 /* 128k */
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/include/configs/goflexhome.h
|
||||
+++ b/include/configs/goflexhome.h
|
||||
@@ -87,20 +87,18 @@
|
||||
@@ -77,20 +77,18 @@
|
||||
*/
|
||||
#define CONFIG_BOOTCOMMAND \
|
||||
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/arch/arm/mach-kirkwood/Kconfig
|
||||
+++ b/arch/arm/mach-kirkwood/Kconfig
|
||||
@@ -78,4 +78,7 @@ source "board/Seagate/nas220/Kconfig"
|
||||
source "board/zyxel/nsa310/Kconfig"
|
||||
@@ -87,4 +87,7 @@ source "board/Seagate/nas220/Kconfig"
|
||||
source "board/zyxel/nsa310s/Kconfig"
|
||||
source "board/zyxel/nsa325/Kconfig"
|
||||
|
||||
+config SECOND_STAGE
|
||||
+ bool "OpenWrt second stage hack"
|
||||
|
@ -10,7 +10,7 @@
|
|||
endif
|
||||
--- a/include/configs/dockstar.h
|
||||
+++ b/include/configs/dockstar.h
|
||||
@@ -98,4 +98,6 @@
|
||||
@@ -89,4 +89,6 @@
|
||||
#define CONFIG_CMD_MTDPARTS
|
||||
#define CONFIG_LZO
|
||||
|
||||
|
@ -19,7 +19,7 @@
|
|||
#endif /* _CONFIG_DOCKSTAR_H */
|
||||
--- a/include/configs/ib62x0.h
|
||||
+++ b/include/configs/ib62x0.h
|
||||
@@ -108,4 +108,6 @@
|
||||
@@ -99,4 +99,6 @@
|
||||
#define CONFIG_RTC_MV
|
||||
#endif /* CONFIG_CMD_DATE */
|
||||
|
||||
|
@ -28,7 +28,7 @@
|
|||
#endif /* _CONFIG_IB62x0_H */
|
||||
--- a/include/configs/iconnect.h
|
||||
+++ b/include/configs/iconnect.h
|
||||
@@ -103,4 +103,6 @@
|
||||
@@ -94,4 +94,6 @@
|
||||
#define CONFIG_MTD_PARTITIONS
|
||||
#define CONFIG_CMD_MTDPARTS
|
||||
|
||||
|
@ -80,7 +80,7 @@
|
|||
+#endif /* __OPENWRT_KIRKWOOD_COMMON_H */
|
||||
--- a/include/configs/pogo_e02.h
|
||||
+++ b/include/configs/pogo_e02.h
|
||||
@@ -99,4 +99,6 @@
|
||||
@@ -93,4 +93,6 @@
|
||||
#define CONFIG_CMD_MTDPARTS
|
||||
#define CONFIG_LZO
|
||||
|
||||
|
@ -89,7 +89,7 @@
|
|||
#endif /* _CONFIG_POGO_E02_H */
|
||||
--- a/include/configs/sheevaplug.h
|
||||
+++ b/include/configs/sheevaplug.h
|
||||
@@ -109,4 +109,6 @@
|
||||
@@ -99,4 +99,6 @@
|
||||
#define CONFIG_SYS_ATA_IDE1_OFFSET MV_SATA_PORT1_OFFSET
|
||||
#endif /* CONFIG_CMD_IDE */
|
||||
|
||||
|
@ -98,7 +98,7 @@
|
|||
#endif /* _CONFIG_SHEEVAPLUG_H */
|
||||
--- a/include/configs/goflexhome.h
|
||||
+++ b/include/configs/goflexhome.h
|
||||
@@ -122,4 +122,6 @@
|
||||
@@ -112,4 +112,6 @@
|
||||
#define CONFIG_RTC_MV
|
||||
#endif /* CONFIG_CMD_DATE */
|
||||
|
||||
|
@ -107,7 +107,7 @@
|
|||
#endif /* _CONFIG_GOFLEXHOME_H */
|
||||
--- a/include/configs/nsa310.h
|
||||
+++ b/include/configs/nsa310.h
|
||||
@@ -166,4 +166,6 @@
|
||||
@@ -165,4 +165,6 @@
|
||||
#define CONFIG_CMD_DNS
|
||||
#endif /* CONFIG_CMD_DATE */
|
||||
|
||||
|
|
Loading…
Reference in a new issue