mac80211: add brcmsmac driver
brcmsmac does not work on bcm47xx based devices or has AP mode support for now. SVN-Revision: 30643
This commit is contained in:
parent
bd1c29df74
commit
c5d940389b
4 changed files with 300 additions and 3 deletions
|
@ -52,6 +52,22 @@ endef
|
|||
$(eval $(call KernelPackage,lib-crc7))
|
||||
|
||||
|
||||
define KernelPackage/lib-crc8
|
||||
SUBMENU:=$(LIB_MENU)
|
||||
TITLE:=CRC8 support
|
||||
DEPENDS:= @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0)
|
||||
KCONFIG:=CONFIG_CRC8
|
||||
FILES:=$(LINUX_DIR)/lib/crc8.ko
|
||||
AUTOLOAD:=$(call AutoLoad,20,crc8)
|
||||
endef
|
||||
|
||||
define KernelPackage/lib-crc8/description
|
||||
Kernel module for CRC8 support
|
||||
endef
|
||||
|
||||
$(eval $(call KernelPackage,lib-crc8))
|
||||
|
||||
|
||||
define KernelPackage/lib-crc16
|
||||
SUBMENU:=$(LIB_MENU)
|
||||
TITLE:=CRC16 support
|
||||
|
@ -129,3 +145,19 @@ define KernelPackage/lib-zlib
|
|||
endef
|
||||
|
||||
$(eval $(call KernelPackage,lib-zlib))
|
||||
|
||||
|
||||
define KernelPackage/lib-cordic
|
||||
SUBMENU:=$(LIB_MENU)
|
||||
TITLE:=Cordic function support
|
||||
DEPENDS:= @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0)
|
||||
KCONFIG:=CONFIG_CORDIC
|
||||
FILES:=$(LINUX_DIR)/lib/cordic.ko
|
||||
AUTOLOAD:=$(call AutoLoad,20,cordic)
|
||||
endef
|
||||
|
||||
define KernelPackage/lib-cordic/description
|
||||
Kernel module for Cordic function support
|
||||
endef
|
||||
|
||||
$(eval $(call KernelPackage,lib-cordic))
|
||||
|
|
|
@ -1080,6 +1080,34 @@ define KernelPackage/b43legacy/description
|
|||
Kernel module for Broadcom 43xx-legacy wireless support (mac80211 stack) new
|
||||
endef
|
||||
|
||||
define KernelPackage/brcmsmac
|
||||
$(call KernelPackage/mac80211/Default)
|
||||
TITLE:=Broadcom IEEE802.11n PCIe SoftMAC WLAN driver
|
||||
URL:=http://linuxwireless.org/en/users/Drivers/brcm80211
|
||||
DEPENDS+= +@DRIVER_11N_SUPPORT +!TARGET_brcm47xx:kmod-bcma +kmod-lib-cordic +kmod-lib-crc8
|
||||
FILES:= \
|
||||
$(PKG_BUILD_DIR)/drivers/net/wireless/brcm80211/brcmsmac/brcmsmac.ko \
|
||||
$(PKG_BUILD_DIR)/drivers/net/wireless/brcm80211/brcmutil/brcmutil.ko
|
||||
AUTOLOAD:=$(call AutoLoad,30,brcmutil brcmsmac)
|
||||
MENU:=1
|
||||
endef
|
||||
|
||||
define KernelPackage/brcmsmac/description
|
||||
Kernel modules for Broadcom IEEE802.11n PCIe Wireless cards
|
||||
endef
|
||||
|
||||
define KernelPackage/brcmsmac/config
|
||||
menu "Configuration"
|
||||
depends on PACKAGE_kmod-brcmsmac
|
||||
|
||||
config PACKAGE_BRCM80211_DEBUG
|
||||
bool "brcmsmac wireless debugging"
|
||||
help
|
||||
Say Y, if you want to debug brcmsmac wireless driver.
|
||||
|
||||
endmenu
|
||||
endef
|
||||
|
||||
BUILDFLAGS:= \
|
||||
-I$(PKG_BUILD_DIR)/include \
|
||||
$(foreach opt,$(CONFOPTS),-DCONFIG_$(opt)) \
|
||||
|
@ -1116,7 +1144,8 @@ BUILDFLAGS:= \
|
|||
$(if $(CONFIG_TARGET_atheros),-DCONFIG_ATH5K_AHB,-DCONFIG_ATH5K_PCI) \
|
||||
$(if $(CONFIG_PACKAGE_kmod-iwl3945),-DCONFIG_IWL3945) \
|
||||
$(if $(CONFIG_PACKAGE_kmod-iwl4965),-DCONFIG_COMPAT_IWL4965) \
|
||||
$(if $(CONFIG_PACKAGE_kmod-wl12xx),-DCONFIG_WL12XX -DCONFIG_COMPAT_WL12XX_SDIO)
|
||||
$(if $(CONFIG_PACKAGE_kmod-wl12xx),-DCONFIG_WL12XX -DCONFIG_COMPAT_WL12XX_SDIO) \
|
||||
$(if $(CONFIG_PACKAGE_BRCM80211_DEBUG),-DCONFIG_BRCMDBG)
|
||||
|
||||
MAKE_OPTS:= \
|
||||
CROSS_COMPILE="$(KERNEL_CROSS)" \
|
||||
|
@ -1247,8 +1276,9 @@ MAKE_OPTS:= \
|
|||
CONFIG_ATL1E= \
|
||||
CONFIG_ATL1C= \
|
||||
CONFIG_BRCMFMAC= \
|
||||
CONFIG_BRCMUMAC= \
|
||||
CONFIG_BRCMSMAC= \
|
||||
CONFIG_BRCMUTIL=$(if $(CONFIG_PACKAGE_kmod-brcmsmac),m) \
|
||||
CONFIG_BRCMSMAC=$(if $(CONFIG_PACKAGE_kmod-brcmsmac),m) \
|
||||
CONFIG_BRCMDBG=$(if $(CONFIG_PACKAGE_BRCM80211_DEBUG),y) \
|
||||
KLIB_BUILD="$(LINUX_DIR)" \
|
||||
MODPROBE=true \
|
||||
KLIB=$(TARGET_MODULES_DIR) \
|
||||
|
@ -1492,6 +1522,14 @@ ifneq ($(CONFIG_B43LEGACY_FW_SQUASH),)
|
|||
endif
|
||||
endef
|
||||
|
||||
define KernelPackage/brcmsmac/install
|
||||
$(INSTALL_DIR) $(1)/lib/firmware/brcm
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/brcm/bcm43xx-0.fw \
|
||||
$(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/brcm/bcm43xx_hdr-0.fw \
|
||||
$(1)/lib/firmware/brcm/
|
||||
endef
|
||||
|
||||
$(eval $(call KernelPackage,ath5k))
|
||||
$(eval $(call KernelPackage,lib80211))
|
||||
$(eval $(call KernelPackage,libertas-usb))
|
||||
|
@ -1525,6 +1563,7 @@ $(eval $(call KernelPackage,ath))
|
|||
$(eval $(call KernelPackage,carl9170))
|
||||
$(eval $(call KernelPackage,b43))
|
||||
$(eval $(call KernelPackage,b43legacy))
|
||||
$(eval $(call KernelPackage,brcmsmac))
|
||||
$(eval $(call KernelPackage,net-libipw))
|
||||
$(eval $(call KernelPackage,net-ipw2100))
|
||||
$(eval $(call KernelPackage,net-ipw2200))
|
||||
|
|
166
package/mac80211/patches/022-remove_crc8_and_cordic.patch
Normal file
166
package/mac80211/patches/022-remove_crc8_and_cordic.patch
Normal file
|
@ -0,0 +1,166 @@
|
|||
--- a/compat/Makefile
|
||||
+++ b/compat/Makefile
|
||||
@@ -36,8 +36,6 @@ compat-$(CONFIG_COMPAT_KERNEL_2_6_39) +=
|
||||
compat-$(CONFIG_COMPAT_KERNEL_3_0) += compat-3.0.o
|
||||
compat-$(CONFIG_COMPAT_KERNEL_3_2) += compat-3.2.o
|
||||
|
||||
-compat-$(CONFIG_COMPAT_CORDIC) += cordic.o
|
||||
-compat-$(CONFIG_COMPAT_CRC8) += crc8.o
|
||||
|
||||
ifndef CONFIG_64BIT
|
||||
ifndef CONFIG_GENERIC_ATOMIC64
|
||||
--- a/include/linux/cordic.h
|
||||
+++ /dev/null
|
||||
@@ -1,48 +0,0 @@
|
||||
-/*
|
||||
- * Copyright (c) 2011 Broadcom Corporation
|
||||
- *
|
||||
- * Permission to use, copy, modify, and/or distribute this software for any
|
||||
- * purpose with or without fee is hereby granted, provided that the above
|
||||
- * copyright notice and this permission notice appear in all copies.
|
||||
- *
|
||||
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
||||
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
||||
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
|
||||
- * SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
||||
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION
|
||||
- * OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
|
||||
- * CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
- */
|
||||
-#ifndef __CORDIC_H_
|
||||
-#define __CORDIC_H_
|
||||
-
|
||||
-#include <linux/types.h>
|
||||
-
|
||||
-/**
|
||||
- * struct cordic_iq - i/q coordinate.
|
||||
- *
|
||||
- * @i: real part of coordinate (in phase).
|
||||
- * @q: imaginary part of coordinate (quadrature).
|
||||
- */
|
||||
-struct cordic_iq {
|
||||
- s32 i;
|
||||
- s32 q;
|
||||
-};
|
||||
-
|
||||
-/**
|
||||
- * cordic_calc_iq() - calculates the i/q coordinate for given angle.
|
||||
- *
|
||||
- * @theta: angle in degrees for which i/q coordinate is to be calculated.
|
||||
- * @coord: function output parameter holding the i/q coordinate.
|
||||
- *
|
||||
- * The function calculates the i/q coordinate for a given angle using
|
||||
- * cordic algorithm. The coordinate consists of a real (i) and an
|
||||
- * imaginary (q) part. The real part is essentially the cosine of the
|
||||
- * angle and the imaginary part is the sine of the angle. The returned
|
||||
- * values are scaled by 2^16 for precision. The range for theta is
|
||||
- * for -180 degrees to +180 degrees. Passed values outside this range are
|
||||
- * converted before doing the actual calculation.
|
||||
- */
|
||||
-struct cordic_iq cordic_calc_iq(s32 theta);
|
||||
-
|
||||
-#endif /* __CORDIC_H_ */
|
||||
--- a/include/linux/crc8.h
|
||||
+++ /dev/null
|
||||
@@ -1,101 +0,0 @@
|
||||
-/*
|
||||
- * Copyright (c) 2011 Broadcom Corporation
|
||||
- *
|
||||
- * Permission to use, copy, modify, and/or distribute this software for any
|
||||
- * purpose with or without fee is hereby granted, provided that the above
|
||||
- * copyright notice and this permission notice appear in all copies.
|
||||
- *
|
||||
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
||||
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
||||
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
|
||||
- * SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
||||
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION
|
||||
- * OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
|
||||
- * CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
- */
|
||||
-#ifndef __CRC8_H_
|
||||
-#define __CRC8_H_
|
||||
-
|
||||
-#include <linux/types.h>
|
||||
-
|
||||
-/* see usage of this value in crc8() description */
|
||||
-#define CRC8_INIT_VALUE 0xFF
|
||||
-
|
||||
-/*
|
||||
- * Return value of crc8() indicating valid message+crc. This is true
|
||||
- * if a CRC is inverted before transmission. The CRC computed over the
|
||||
- * whole received bitstream is _table[x], where x is the bit pattern
|
||||
- * of the modification (almost always 0xff).
|
||||
- */
|
||||
-#define CRC8_GOOD_VALUE(_table) (_table[0xFF])
|
||||
-
|
||||
-/* required table size for crc8 algorithm */
|
||||
-#define CRC8_TABLE_SIZE 256
|
||||
-
|
||||
-/* helper macro assuring right table size is used */
|
||||
-#define DECLARE_CRC8_TABLE(_table) \
|
||||
- static u8 _table[CRC8_TABLE_SIZE]
|
||||
-
|
||||
-/**
|
||||
- * crc8_populate_lsb - fill crc table for given polynomial in regular bit order.
|
||||
- *
|
||||
- * @table: table to be filled.
|
||||
- * @polynomial: polynomial for which table is to be filled.
|
||||
- *
|
||||
- * This function fills the provided table according the polynomial provided for
|
||||
- * regular bit order (lsb first). Polynomials in CRC algorithms are typically
|
||||
- * represented as shown below.
|
||||
- *
|
||||
- * poly = x^8 + x^7 + x^6 + x^4 + x^2 + 1
|
||||
- *
|
||||
- * For lsb first direction x^7 maps to the lsb. So the polynomial is as below.
|
||||
- *
|
||||
- * - lsb first: poly = 10101011(1) = 0xAB
|
||||
- */
|
||||
-void crc8_populate_lsb(u8 table[CRC8_TABLE_SIZE], u8 polynomial);
|
||||
-
|
||||
-/**
|
||||
- * crc8_populate_msb - fill crc table for given polynomial in reverse bit order.
|
||||
- *
|
||||
- * @table: table to be filled.
|
||||
- * @polynomial: polynomial for which table is to be filled.
|
||||
- *
|
||||
- * This function fills the provided table according the polynomial provided for
|
||||
- * reverse bit order (msb first). Polynomials in CRC algorithms are typically
|
||||
- * represented as shown below.
|
||||
- *
|
||||
- * poly = x^8 + x^7 + x^6 + x^4 + x^2 + 1
|
||||
- *
|
||||
- * For msb first direction x^7 maps to the msb. So the polynomial is as below.
|
||||
- *
|
||||
- * - msb first: poly = (1)11010101 = 0xD5
|
||||
- */
|
||||
-void crc8_populate_msb(u8 table[CRC8_TABLE_SIZE], u8 polynomial);
|
||||
-
|
||||
-/**
|
||||
- * crc8() - calculate a crc8 over the given input data.
|
||||
- *
|
||||
- * @table: crc table used for calculation.
|
||||
- * @pdata: pointer to data buffer.
|
||||
- * @nbytes: number of bytes in data buffer.
|
||||
- * @crc: previous returned crc8 value.
|
||||
- *
|
||||
- * The CRC8 is calculated using the polynomial given in crc8_populate_msb()
|
||||
- * or crc8_populate_lsb().
|
||||
- *
|
||||
- * The caller provides the initial value (either %CRC8_INIT_VALUE
|
||||
- * or the previous returned value) to allow for processing of
|
||||
- * discontiguous blocks of data. When generating the CRC the
|
||||
- * caller is responsible for complementing the final return value
|
||||
- * and inserting it into the byte stream. When validating a byte
|
||||
- * stream (including CRC8), a final return value of %CRC8_GOOD_VALUE
|
||||
- * indicates the byte stream data can be considered valid.
|
||||
- *
|
||||
- * Reference:
|
||||
- * "A Painless Guide to CRC Error Detection Algorithms", ver 3, Aug 1993
|
||||
- * Williams, Ross N., ross<at>ross.net
|
||||
- * (see URL http://www.ross.net/crc/download/crc_v3.txt).
|
||||
- */
|
||||
-u8 crc8(const u8 table[CRC8_TABLE_SIZE], u8 *pdata, size_t nbytes, u8 crc);
|
||||
-
|
||||
-#endif /* __CRC8_H_ */
|
|
@ -175,3 +175,63 @@
|
|||
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
|
||||
|
||||
#include <linux/module.h>
|
||||
--- a/drivers/net/wireless/brcm80211/brcmsmac/aiutils.c
|
||||
+++ b/drivers/net/wireless/brcm80211/brcmsmac/aiutils.c
|
||||
@@ -16,6 +16,7 @@
|
||||
* File contents: support functions for PCI/PCIe
|
||||
*/
|
||||
|
||||
+#undef pr_fmt
|
||||
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
|
||||
|
||||
#include <linux/delay.h>
|
||||
--- a/drivers/net/wireless/brcm80211/brcmsmac/dma.c
|
||||
+++ b/drivers/net/wireless/brcm80211/brcmsmac/dma.c
|
||||
@@ -14,6 +14,7 @@
|
||||
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
*/
|
||||
|
||||
+#undef pr_fmt
|
||||
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
|
||||
|
||||
#include <linux/slab.h>
|
||||
--- a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
|
||||
+++ b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
|
||||
@@ -15,6 +15,7 @@
|
||||
*/
|
||||
|
||||
#define __UNDEF_NO_VERSION__
|
||||
+#undef pr_fmt
|
||||
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
|
||||
|
||||
#include <linux/etherdevice.h>
|
||||
--- a/drivers/net/wireless/brcm80211/brcmsmac/phy/phy_n.c
|
||||
+++ b/drivers/net/wireless/brcm80211/brcmsmac/phy/phy_n.c
|
||||
@@ -14,6 +14,7 @@
|
||||
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
*/
|
||||
|
||||
+#undef pr_fmt
|
||||
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
|
||||
|
||||
#include <linux/kernel.h>
|
||||
--- a/drivers/net/wireless/brcm80211/brcmutil/utils.c
|
||||
+++ b/drivers/net/wireless/brcm80211/brcmutil/utils.c
|
||||
@@ -14,6 +14,7 @@
|
||||
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
*/
|
||||
|
||||
+#undef pr_fmt
|
||||
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
|
||||
|
||||
#include <linux/netdevice.h>
|
||||
--- a/drivers/net/wireless/brcm80211/brcmsmac/main.c
|
||||
+++ b/drivers/net/wireless/brcm80211/brcmsmac/main.c
|
||||
@@ -14,6 +14,7 @@
|
||||
* CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
*/
|
||||
|
||||
+#undef pr_fmt
|
||||
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
|
||||
|
||||
#include <linux/pci_ids.h>
|
||||
|
|
Loading…
Reference in a new issue