refresh 2.6.27 patches
SVN-Revision: 17061
This commit is contained in:
parent
252607a79c
commit
c5879ba76d
4 changed files with 18 additions and 16 deletions
|
@ -22,7 +22,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
|
|||
cpu_wait = r4k_wait;
|
||||
break;
|
||||
|
||||
@@ -802,11 +806,28 @@ static inline void cpu_probe_broadcom(st
|
||||
@@ -802,11 +805,28 @@ static inline void cpu_probe_broadcom(st
|
||||
decode_configs(c);
|
||||
switch (c->processor_id & 0xff00) {
|
||||
case PRID_IMP_BCM3302:
|
||||
|
@ -51,7 +51,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
|
|||
default:
|
||||
c->cputype = CPU_UNKNOWN;
|
||||
break;
|
||||
@@ -892,6 +913,10 @@ static __cpuinit const char *cpu_to_name
|
||||
@@ -892,6 +912,10 @@ static __cpuinit const char *cpu_to_name
|
||||
case CPU_SR71000: name = "Sandcraft SR71000"; break;
|
||||
case CPU_BCM3302: name = "Broadcom BCM3302"; break;
|
||||
case CPU_BCM4710: name = "Broadcom BCM4710"; break;
|
||||
|
|
|
@ -45,9 +45,9 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
|
|||
static inline unsigned int ehci_readl(const struct ehci_hcd *ehci,
|
||||
__u32 __iomem * regs)
|
||||
{
|
||||
--- a/drivers/usb/host/Kconfig 2009-07-03 01:33:19.000000000 +0200
|
||||
+++ b/drivers/usb/host/Kconfig 2009-07-17 17:53:11.000000000 +0200
|
||||
@@ -44,7 +44,7 @@
|
||||
--- a/drivers/usb/host/Kconfig
|
||||
+++ b/drivers/usb/host/Kconfig
|
||||
@@ -44,7 +44,7 @@ config USB_EHCI_HCD
|
||||
|
||||
config USB_EHCI_ROOT_HUB_TT
|
||||
bool "Root Hub Transaction Translators"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -549,6 +549,9 @@ endif
|
||||
@@ -550,6 +550,9 @@ endif
|
||||
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
||||
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
||||
|
||||
|
|
|
@ -27,16 +27,18 @@
|
|||
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
|
||||
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
|
||||
.features = RTL_FEATURE_MSI
|
||||
@@ -2878,10 +2878,12 @@ static irqreturn_t rtl8169_interrupt(int
|
||||
goto out;
|
||||
}
|
||||
|
||||
@@ -2872,12 +2872,12 @@ static irqreturn_t rtl8169_interrupt(int
|
||||
rtl8169_tx_timeout(dev);
|
||||
break;
|
||||
}
|
||||
-
|
||||
+#if 0
|
||||
if (unlikely(status & SYSErr)) {
|
||||
rtl8169_pcierr_interrupt(dev);
|
||||
goto out;
|
||||
}
|
||||
if (unlikely(status & SYSErr)) {
|
||||
rtl8169_pcierr_interrupt(dev);
|
||||
break;
|
||||
}
|
||||
-
|
||||
+#endif
|
||||
if (status & LinkChg)
|
||||
rtl8169_check_link_status(dev, tp, ioaddr);
|
||||
|
||||
if (status & LinkChg)
|
||||
rtl8169_check_link_status(dev, tp, ioaddr);
|
||||
|
|
Loading…
Reference in a new issue