mvebu: add support for the Marvell Armada 370 Reference Design board
Keep the patches in sync with the upstream developments. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35179
This commit is contained in:
parent
58f8c5d87a
commit
c53a347034
4 changed files with 134 additions and 3 deletions
|
@ -7,7 +7,8 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/image.mk
|
include $(INCLUDE_DIR)/image.mk
|
||||||
|
|
||||||
TARGET_DTBS := armada-xp-db armada-370-db armada-xp-openblocks-ax3-4 armada-370-mirabox
|
TARGET_DTBS := armada-xp-db armada-370-db armada-xp-openblocks-ax3-4 armada-370-mirabox \
|
||||||
|
armada-370-rd
|
||||||
|
|
||||||
LOADADDR:=0x00008000
|
LOADADDR:=0x00008000
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,6 @@ final product, it is not too bad.
|
||||||
|
|
||||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||||
---
|
---
|
||||||
[florian: changed status to "okay" for RD-A370-A1]
|
|
||||||
arch/arm/boot/dts/armada-370-db.dts | 15 +++++++++++++++
|
arch/arm/boot/dts/armada-370-db.dts | 15 +++++++++++++++
|
||||||
1 file changed, 15 insertions(+)
|
1 file changed, 15 insertions(+)
|
||||||
|
|
||||||
|
@ -37,7 +36,7 @@ index 0004402..43ff156 100644
|
||||||
+ * different connector
|
+ * different connector
|
||||||
+ * "DB-88F6710_MPP_RGMII_SD_Jumper".
|
+ * "DB-88F6710_MPP_RGMII_SD_Jumper".
|
||||||
+ */
|
+ */
|
||||||
+ status = "okay";
|
+ status = "disabled";
|
||||||
+ /* No CD or WP GPIOs */
|
+ /* No CD or WP GPIOs */
|
||||||
+ };
|
+ };
|
||||||
};
|
};
|
||||||
|
|
|
@ -0,0 +1,99 @@
|
||||||
|
From fcc7654b592cb80cfb33c509db1005ce9252192b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florian Fainelli <florian@openwrt.org>
|
||||||
|
Date: Wed, 9 Jan 2013 20:39:55 +0100
|
||||||
|
Subject: [PATCH] arm: mvebu: add DTS file for Marvell RD-A370-A1 board
|
||||||
|
|
||||||
|
This patch adds the DTS file to support the Marvell RD-A370-A1
|
||||||
|
(Reference Design board) also known as RD-88F6710 board. It is almost
|
||||||
|
entirely similar to the DB-A370 board except that the first Ethernet PHY
|
||||||
|
is SGMII-wired and the second is a switch which is RGMII-wired.
|
||||||
|
|
||||||
|
Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/Makefile | 1 +
|
||||||
|
arch/arm/boot/dts/armada-370-rd.dts | 61 +++++++++++++++++++++++++++++++++++
|
||||||
|
2 files changed, 62 insertions(+)
|
||||||
|
create mode 100644 arch/arm/boot/dts/armada-370-rd.dts
|
||||||
|
|
||||||
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||||
|
index b7246d6..7a75171 100644
|
||||||
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
|
@@ -78,6 +78,7 @@ dtb-$(CONFIG_ARCH_MSM) += msm8660-surf.dtb \
|
||||||
|
msm8960-cdp.dtb
|
||||||
|
dtb-$(CONFIG_ARCH_MVEBU) += armada-370-db.dtb \
|
||||||
|
armada-370-mirabox.dtb \
|
||||||
|
+ armada-370-rd.dtb \
|
||||||
|
armada-xp-db.dtb \
|
||||||
|
armada-xp-openblocks-ax3-4.dtb
|
||||||
|
dtb-$(CONFIG_ARCH_MXC) += imx51-babbage.dtb \
|
||||||
|
diff --git a/arch/arm/boot/dts/armada-370-rd.dts b/arch/arm/boot/dts/armada-370-rd.dts
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..d62dfac
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm/boot/dts/armada-370-rd.dts
|
||||||
|
@@ -0,0 +1,61 @@
|
||||||
|
+/*
|
||||||
|
+ * Device Tree file for Marvell Armada 370 Reference Design board
|
||||||
|
+ * (RD-88F6710-A1)
|
||||||
|
+ *
|
||||||
|
+ * Copied from arch/arm/boot/dts/armada-370-db.dts
|
||||||
|
+ *
|
||||||
|
+ * Copyright (C) 2013 Florian Fainelli <florian@openwrt.org>
|
||||||
|
+ *
|
||||||
|
+ * This file is licensed under the terms of the GNU General Public
|
||||||
|
+ * License version 2. This program is licensed "as is" without any
|
||||||
|
+ * warranty of any kind, whether express or implied.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/dts-v1/;
|
||||||
|
+/include/ "armada-370.dtsi"
|
||||||
|
+
|
||||||
|
+/ {
|
||||||
|
+ model = "Marvell Armada 370 Reference Design";
|
||||||
|
+ compatible = "marvell,a370-rd", "marvell,armada370", "marvell,armada-370-xp";
|
||||||
|
+
|
||||||
|
+ chosen {
|
||||||
|
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ memory {
|
||||||
|
+ device_type = "memory";
|
||||||
|
+ reg = <0x00000000 0x20000000>; /* 512 MB */
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ soc {
|
||||||
|
+ serial@d0012000 {
|
||||||
|
+ clock-frequency = <200000000>;
|
||||||
|
+ status = "okay";
|
||||||
|
+ };
|
||||||
|
+ sata@d00a0000 {
|
||||||
|
+ nr-ports = <2>;
|
||||||
|
+ status = "okay";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ mdio {
|
||||||
|
+ phy0: ethernet-phy@0 {
|
||||||
|
+ reg = <0>;
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ phy1: ethernet-phy@1 {
|
||||||
|
+ reg = <1>;
|
||||||
|
+ };
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ ethernet@d0070000 {
|
||||||
|
+ status = "okay";
|
||||||
|
+ phy = <&phy0>;
|
||||||
|
+ phy-mode = "sgmii";
|
||||||
|
+ };
|
||||||
|
+ ethernet@d0074000 {
|
||||||
|
+ status = "okay";
|
||||||
|
+ phy = <&phy1>;
|
||||||
|
+ phy-mode = "rgmii-id";
|
||||||
|
+ };
|
||||||
|
+ };
|
||||||
|
+};
|
||||||
|
--
|
||||||
|
1.7.10.4
|
||||||
|
|
|
@ -0,0 +1,32 @@
|
||||||
|
From 883b6ab543ea3f893447307c0e757668ca1b5396 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florian Fainelli <florian@openwrt.org>
|
||||||
|
Date: Wed, 9 Jan 2013 20:50:04 +0100
|
||||||
|
Subject: [PATCH] arm: mvebu: add SDIO support to Armada 370 Reference Design
|
||||||
|
|
||||||
|
This patch enables the use of the SDIO controller on the Armada 370
|
||||||
|
Reference Design board.
|
||||||
|
|
||||||
|
Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/armada-370-rd.dts | 6 ++++++
|
||||||
|
1 file changed, 6 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/arch/arm/boot/dts/armada-370-rd.dts b/arch/arm/boot/dts/armada-370-rd.dts
|
||||||
|
index d62dfac..43f68c2 100644
|
||||||
|
--- a/arch/arm/boot/dts/armada-370-rd.dts
|
||||||
|
+++ b/arch/arm/boot/dts/armada-370-rd.dts
|
||||||
|
@@ -57,5 +57,11 @@
|
||||||
|
phy = <&phy1>;
|
||||||
|
phy-mode = "rgmii-id";
|
||||||
|
};
|
||||||
|
+
|
||||||
|
+ mvsdio@d00d4000 {
|
||||||
|
+ pinctrl-0 = <&sdio_pins1>;
|
||||||
|
+ pinctrl-names = "default";
|
||||||
|
+ status = "okay";
|
||||||
|
+ };
|
||||||
|
};
|
||||||
|
};
|
||||||
|
--
|
||||||
|
1.7.10.4
|
||||||
|
|
Loading…
Reference in a new issue