ipq806x: Build image for Netgear Nighthawk X4 R7500v2
Signed-off-by: Alexis Green <alexis@cessp.it> [Jo-Philipp Wich: add missing DEVICE_TITLE, fix model name in commit title] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
This commit is contained in:
parent
d7e040f8bc
commit
c34f953fef
8 changed files with 383 additions and 1 deletions
|
@ -20,6 +20,7 @@ c2600)
|
|||
;;
|
||||
d7800 |\
|
||||
r7500 |\
|
||||
r7500v2 |\
|
||||
r7800)
|
||||
ucidef_set_led_usbdev "usb1" "USB 1" "${board}:white:usb1" "1-1"
|
||||
ucidef_set_led_usbdev "usb2" "USB 2" "${board}:white:usb3" "3-1"
|
||||
|
|
|
@ -17,6 +17,7 @@ ap148 |\
|
|||
c2600 |\
|
||||
d7800 |\
|
||||
r7500 |\
|
||||
r7500v2 |\
|
||||
r7800)
|
||||
ucidef_add_switch "switch0" \
|
||||
"1:lan" "2:lan" "3:lan" "4:lan" "6@eth1" "5:wan" "0@eth0"
|
||||
|
|
|
@ -56,6 +56,7 @@ case "$FIRMWARE" in
|
|||
hw_mac_addr=$(mtd_get_mac_ascii devinfo hw_mac_addr)
|
||||
ath10kcal_extract "art" 4096 12064
|
||||
;;
|
||||
r7500v2 |\
|
||||
r7800)
|
||||
ath10kcal_extract "art" 4096 12064
|
||||
;;
|
||||
|
@ -71,6 +72,7 @@ case "$FIRMWARE" in
|
|||
hw_mac_addr=$(mtd_get_mac_ascii devinfo hw_mac_addr)
|
||||
ath10kcal_extract "art" 20480 12064
|
||||
;;
|
||||
r7500v2 |\
|
||||
r7800)
|
||||
ath10kcal_extract "art" 20480 12064
|
||||
;;
|
||||
|
|
|
@ -29,6 +29,9 @@ ipq806x_board_detect() {
|
|||
*"R7500")
|
||||
name="r7500"
|
||||
;;
|
||||
*"R7500v2")
|
||||
name="r7500v2"
|
||||
;;
|
||||
*"Linksys EA8500"*)
|
||||
name="ea8500"
|
||||
;;
|
||||
|
|
|
@ -10,6 +10,7 @@ platform_check_image() {
|
|||
d7800 |\
|
||||
ea8500 |\
|
||||
r7500 |\
|
||||
r7500v2 |\
|
||||
r7800)
|
||||
nand_do_platform_check $board $1
|
||||
return $?;
|
||||
|
@ -34,6 +35,7 @@ platform_pre_upgrade() {
|
|||
ap148 |\
|
||||
d7800 |\
|
||||
r7500 |\
|
||||
r7500v2 |\
|
||||
r7800)
|
||||
nand_do_upgrade "$1"
|
||||
;;
|
||||
|
|
|
@ -0,0 +1,350 @@
|
|||
#include "qcom-ipq8064-v1.0.dtsi"
|
||||
|
||||
#include <dt-bindings/input/input.h>
|
||||
|
||||
/ {
|
||||
model = "Netgear Nighthawk X4 R7500v2";
|
||||
compatible = "netgear,r7500v2", "qcom,ipq8064";
|
||||
|
||||
memory@0 {
|
||||
reg = <0x42000000 0xe000000>;
|
||||
device_type = "memory";
|
||||
};
|
||||
|
||||
reserved-memory {
|
||||
#address-cells = <1>;
|
||||
#size-cells = <1>;
|
||||
ranges;
|
||||
rsvd@41200000 {
|
||||
reg = <0x41200000 0x300000>;
|
||||
no-map;
|
||||
};
|
||||
};
|
||||
|
||||
aliases {
|
||||
serial0 = &uart4;
|
||||
mdio-gpio0 = &mdio0;
|
||||
};
|
||||
|
||||
chosen {
|
||||
bootargs = "rootfstype=squashfs noinitrd";
|
||||
linux,stdout-path = "serial0:115200n8";
|
||||
};
|
||||
|
||||
soc {
|
||||
pinmux@800000 {
|
||||
i2c4_pins: i2c4_pinmux {
|
||||
pins = "gpio12", "gpio13";
|
||||
function = "gsbi4";
|
||||
bias-disable;
|
||||
};
|
||||
|
||||
nand_pins: nand_pins {
|
||||
mux {
|
||||
pins = "gpio34", "gpio35", "gpio36",
|
||||
"gpio37", "gpio38", "gpio39",
|
||||
"gpio40", "gpio41", "gpio42",
|
||||
"gpio43", "gpio44", "gpio45",
|
||||
"gpio46", "gpio47";
|
||||
function = "nand";
|
||||
drive-strength = <10>;
|
||||
bias-disable;
|
||||
};
|
||||
pullups {
|
||||
pins = "gpio39";
|
||||
bias-pull-up;
|
||||
};
|
||||
hold {
|
||||
pins = "gpio40", "gpio41", "gpio42",
|
||||
"gpio43", "gpio44", "gpio45",
|
||||
"gpio46", "gpio47";
|
||||
bias-bus-hold;
|
||||
};
|
||||
};
|
||||
|
||||
mdio0_pins: mdio0_pins {
|
||||
mux {
|
||||
pins = "gpio0", "gpio1";
|
||||
function = "gpio";
|
||||
drive-strength = <8>;
|
||||
bias-disable;
|
||||
};
|
||||
};
|
||||
|
||||
rgmii2_pins: rgmii2_pins {
|
||||
mux {
|
||||
pins = "gpio27", "gpio28", "gpio29", "gpio30", "gpio31", "gpio32",
|
||||
"gpio51", "gpio52", "gpio59", "gpio60", "gpio61", "gpio62" ;
|
||||
function = "rgmii2";
|
||||
drive-strength = <8>;
|
||||
bias-disable;
|
||||
};
|
||||
};
|
||||
};
|
||||
|
||||
gsbi@16300000 {
|
||||
qcom,mode = <GSBI_PROT_I2C_UART>;
|
||||
status = "ok";
|
||||
serial@16340000 {
|
||||
status = "ok";
|
||||
};
|
||||
/*
|
||||
* The i2c device on gsbi4 should not be enabled.
|
||||
* On ipq806x designs gsbi4 i2c is meant for exclusive
|
||||
* RPM usage. Turning this on in kernel manifests as
|
||||
* i2c failure for the RPM.
|
||||
*/
|
||||
};
|
||||
|
||||
sata-phy@1b400000 {
|
||||
status = "ok";
|
||||
};
|
||||
|
||||
sata@29000000 {
|
||||
status = "ok";
|
||||
};
|
||||
|
||||
phy@100f8800 { /* USB3 port 1 HS phy */
|
||||
status = "ok";
|
||||
};
|
||||
|
||||
phy@100f8830 { /* USB3 port 1 SS phy */
|
||||
status = "ok";
|
||||
};
|
||||
|
||||
phy@110f8800 { /* USB3 port 0 HS phy */
|
||||
status = "ok";
|
||||
};
|
||||
|
||||
phy@110f8830 { /* USB3 port 0 SS phy */
|
||||
status = "ok";
|
||||
};
|
||||
|
||||
usb30@0 {
|
||||
status = "ok";
|
||||
};
|
||||
|
||||
usb30@1 {
|
||||
status = "ok";
|
||||
};
|
||||
|
||||
pcie0: pci@1b500000 {
|
||||
status = "ok";
|
||||
reset-gpio = <&qcom_pinmux 3 GPIO_ACTIVE_LOW>;
|
||||
pinctrl-0 = <&pcie0_pins>;
|
||||
pinctrl-names = "default";
|
||||
};
|
||||
|
||||
pcie1: pci@1b700000 {
|
||||
status = "ok";
|
||||
reset-gpio = <&qcom_pinmux 48 GPIO_ACTIVE_LOW>;
|
||||
pinctrl-0 = <&pcie1_pins>;
|
||||
pinctrl-names = "default";
|
||||
};
|
||||
|
||||
nand@1ac00000 {
|
||||
status = "ok";
|
||||
|
||||
pinctrl-0 = <&nand_pins>;
|
||||
pinctrl-names = "default";
|
||||
|
||||
nand-ecc-strength = <4>;
|
||||
nand-bus-width = <8>;
|
||||
|
||||
#address-cells = <1>;
|
||||
#size-cells = <1>;
|
||||
|
||||
qcadata@0 {
|
||||
label = "qcadata";
|
||||
reg = <0x0000000 0x0c80000>;
|
||||
read-only;
|
||||
};
|
||||
|
||||
APPSBL@c80000 {
|
||||
label = "APPSBL";
|
||||
reg = <0x0c80000 0x0500000>;
|
||||
read-only;
|
||||
};
|
||||
|
||||
APPSBLENV@1180000 {
|
||||
label = "APPSBLENV";
|
||||
reg = <0x1180000 0x0080000>;
|
||||
read-only;
|
||||
};
|
||||
|
||||
art: art@1200000 {
|
||||
label = "art";
|
||||
reg = <0x1200000 0x0140000>;
|
||||
read-only;
|
||||
};
|
||||
|
||||
artbak: art@1340000 {
|
||||
label = "artbak";
|
||||
reg = <0x1340000 0x0140000>;
|
||||
read-only;
|
||||
};
|
||||
|
||||
kernel@1480000 {
|
||||
label = "kernel";
|
||||
reg = <0x1480000 0x0200000>;
|
||||
};
|
||||
|
||||
ubi@1680000 {
|
||||
label = "ubi";
|
||||
reg = <0x1680000 0x1E00000>;
|
||||
};
|
||||
|
||||
netgear@3480000 {
|
||||
label = "netgear";
|
||||
reg = <0x3480000 0x4480000>;
|
||||
read-only;
|
||||
};
|
||||
|
||||
reserve@7900000 {
|
||||
label = "reserve";
|
||||
reg = <0x7900000 0x0700000>;
|
||||
read-only;
|
||||
};
|
||||
|
||||
firmware@1480000 {
|
||||
label = "firmware";
|
||||
reg = <0x1480000 0x2000000>;
|
||||
};
|
||||
|
||||
};
|
||||
|
||||
mdio0: mdio {
|
||||
compatible = "virtual,mdio-gpio";
|
||||
#address-cells = <1>;
|
||||
#size-cells = <0>;
|
||||
gpios = <&qcom_pinmux 1 0 &qcom_pinmux 0 0>;
|
||||
pinctrl-0 = <&mdio0_pins>;
|
||||
pinctrl-names = "default";
|
||||
|
||||
phy0: ethernet-phy@0 {
|
||||
device_type = "ethernet-phy";
|
||||
reg = <0>;
|
||||
qca,ar8327-initvals = <
|
||||
0x00004 0x7600000 /* PAD0_MODE */
|
||||
0x00008 0x1000000 /* PAD5_MODE */
|
||||
0x0000c 0x80 /* PAD6_MODE */
|
||||
0x000e4 0xaa545 /* MAC_POWER_SEL */
|
||||
0x000e0 0xc74164de /* SGMII_CTRL */
|
||||
0x0007c 0x4e /* PORT0_STATUS */
|
||||
0x00094 0x4e /* PORT6_STATUS */
|
||||
>;
|
||||
};
|
||||
|
||||
phy4: ethernet-phy@4 {
|
||||
device_type = "ethernet-phy";
|
||||
reg = <4>;
|
||||
};
|
||||
};
|
||||
|
||||
gmac1: ethernet@37200000 {
|
||||
status = "ok";
|
||||
phy-mode = "rgmii";
|
||||
qcom,id = <1>;
|
||||
|
||||
pinctrl-0 = <&rgmii2_pins>;
|
||||
pinctrl-names = "default";
|
||||
|
||||
mtd-mac-address = <&art 6>;
|
||||
|
||||
fixed-link {
|
||||
speed = <1000>;
|
||||
full-duplex;
|
||||
};
|
||||
};
|
||||
|
||||
gmac2: ethernet@37400000 {
|
||||
status = "ok";
|
||||
phy-mode = "sgmii";
|
||||
qcom,id = <2>;
|
||||
|
||||
mtd-mac-address = <&art 0>;
|
||||
|
||||
fixed-link {
|
||||
speed = <1000>;
|
||||
full-duplex;
|
||||
};
|
||||
};
|
||||
};
|
||||
|
||||
gpio-keys {
|
||||
compatible = "gpio-keys";
|
||||
|
||||
wifi {
|
||||
label = "wifi";
|
||||
gpios = <&qcom_pinmux 6 1>;
|
||||
linux,code = <KEY_WLAN>;
|
||||
};
|
||||
|
||||
reset {
|
||||
label = "reset";
|
||||
gpios = <&qcom_pinmux 54 1>;
|
||||
linux,code = <KEY_RESTART>;
|
||||
};
|
||||
|
||||
wps {
|
||||
label = "wps";
|
||||
gpios = <&qcom_pinmux 65 1>;
|
||||
linux,code = <KEY_WPS_BUTTON>;
|
||||
};
|
||||
};
|
||||
|
||||
gpio-leds {
|
||||
compatible = "gpio-leds";
|
||||
|
||||
usb1 {
|
||||
label = "r7500v2:amber:usb1";
|
||||
gpios = <&qcom_pinmux 7 0>;
|
||||
};
|
||||
|
||||
usb3 {
|
||||
label = "r7500v2:amber:usb3";
|
||||
gpios = <&qcom_pinmux 8 0>;
|
||||
};
|
||||
|
||||
status {
|
||||
label = "r7500v2:amber:status";
|
||||
gpios = <&qcom_pinmux 9 0>;
|
||||
};
|
||||
|
||||
internet {
|
||||
label = "r7500v2:white:internet";
|
||||
gpios = <&qcom_pinmux 22 0>;
|
||||
};
|
||||
|
||||
wan {
|
||||
label = "r7500v2:white:wan";
|
||||
gpios = <&qcom_pinmux 23 0>;
|
||||
};
|
||||
|
||||
wps {
|
||||
label = "r7500v2:white:wps";
|
||||
gpios = <&qcom_pinmux 24 0>;
|
||||
};
|
||||
|
||||
esata {
|
||||
label = "r7500v2:white:esata";
|
||||
gpios = <&qcom_pinmux 26 0>;
|
||||
};
|
||||
|
||||
power {
|
||||
label = "r7500v2:white:power";
|
||||
gpios = <&qcom_pinmux 53 0>;
|
||||
default-state = "on";
|
||||
};
|
||||
|
||||
rfkill {
|
||||
label = "r7500v2:white:rfkill";
|
||||
gpios = <&qcom_pinmux 64 0>;
|
||||
};
|
||||
|
||||
};
|
||||
};
|
||||
|
||||
&adm_dma {
|
||||
status = "ok";
|
||||
};
|
|
@ -175,6 +175,19 @@ define Device/R7500
|
|||
DEVICE_PACKAGES := ath10k-firmware-qca99x0
|
||||
endef
|
||||
|
||||
define Device/R7500v2
|
||||
$(call Device/DniImage)
|
||||
DEVICE_DTS := qcom-ipq8064-r7500v2
|
||||
KERNEL_SIZE := 2097152
|
||||
NETGEAR_BOARD_ID := R7500v2
|
||||
NETGEAR_HW_ID := 29764958+0+128+512+3x3+4x4
|
||||
BLOCKSIZE := 128KiB
|
||||
PAGESIZE := 2048
|
||||
BOARD_NAME := r7500v2
|
||||
DEVICE_TITLE := Netgear Nighthawk X4 R7500v2
|
||||
DEVICE_PACKAGES := ath10k-firmware-qca99x0
|
||||
endef
|
||||
|
||||
define Device/R7800
|
||||
$(call Device/DniImage)
|
||||
DEVICE_DTS := qcom-ipq8064-r7800
|
||||
|
@ -188,6 +201,6 @@ define Device/R7800
|
|||
DEVICE_PACKAGES := ath10k-firmware-qca9984
|
||||
endef
|
||||
|
||||
TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7800
|
||||
TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7500v2 R7800
|
||||
|
||||
$(eval $(call BuildImage))
|
||||
|
|
|
@ -0,0 +1,10 @@
|
|||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -511,6 +511,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
||||
qcom-ipq8064-db149.dtb \
|
||||
qcom-ipq8064-ea8500.dtb \
|
||||
qcom-ipq8064-r7500.dtb \
|
||||
+ qcom-ipq8064-r7500v2.dtb \
|
||||
qcom-ipq8064-r7800.dtb \
|
||||
qcom-msm8660-surf.dtb \
|
||||
qcom-msm8960-cdp.dtb \
|
Loading…
Reference in a new issue