gdb: update to version 7.5
SVN-Revision: 33998
This commit is contained in:
parent
98ae11a58a
commit
bf9f43e912
2 changed files with 8 additions and 17 deletions
|
@ -8,15 +8,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gdb
|
PKG_NAME:=gdb
|
||||||
PKG_VERSION:=6.8a
|
PKG_VERSION:=7.5
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=@GNU/gdb
|
PKG_SOURCE_URL:=@GNU/gdb
|
||||||
PKG_MD5SUM:=da20d043e6729f74b909bd507bcae5c9
|
PKG_MD5SUM:=24a6779a9fe0260667710de1b082ef61
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-6.8
|
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=0
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -63,6 +63,9 @@ define Build/Compile
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
||||||
all
|
all
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Install
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff -urN gdb-6.8/gdb/linux-nat.h gdb-6.8a.new/gdb/linux-nat.h
|
|
||||||
--- gdb-6.8/gdb/linux-nat.h 2008-01-23 12:26:28.000000000 +0100
|
|
||||||
+++ gdb-6.8a.new/gdb/linux-nat.h 2012-09-19 16:37:10.468916796 +0200
|
|
||||||
@@ -60,7 +60,7 @@
|
|
||||||
|
|
||||||
/* Non-zero si_signo if this LWP stopped with a trap. si_addr may
|
|
||||||
be the address of a hardware watchpoint. */
|
|
||||||
- struct siginfo siginfo;
|
|
||||||
+ siginfo_t siginfo;
|
|
||||||
|
|
||||||
/* If WAITSTATUS->KIND != TARGET_WAITKIND_SPURIOUS, the waitstatus
|
|
||||||
for this LWP's last event. This may correspond to STATUS above,
|
|
Loading…
Reference in a new issue