add a package for ifxos (Infineon/Lantiq OS abstraction layer for drivers)
SVN-Revision: 20563
This commit is contained in:
parent
60c60c0516
commit
bb361f5517
2 changed files with 93 additions and 0 deletions
50
package/ifxos/Makefile
Normal file
50
package/ifxos/Makefile
Normal file
|
@ -0,0 +1,50 @@
|
||||||
|
#
|
||||||
|
# Copyright (C) 2009 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id: $
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
|
PKG_NAME:=lib_ifxos
|
||||||
|
PKG_VERSION:=1.5.10
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||||
|
PKG_MD5SUM:=3602797b0f531f37546c6beb748d50cf
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define KernelPackage/ifxos
|
||||||
|
SUBMENU:=Lantiq
|
||||||
|
TITLE:=Lantiq OS abstraction library
|
||||||
|
URL:=http://www.lantiq.com/
|
||||||
|
MAINTAINER:=Lantiq
|
||||||
|
DEPENDS:=@TARGET_ifxmips
|
||||||
|
FILES:=$(PKG_BUILD_DIR)/src/drv_ifxos.$(LINUX_KMOD_SUFFIX)
|
||||||
|
AUTOLOAD:=$(call AutoLoad,10,drv_ifxos)
|
||||||
|
endef
|
||||||
|
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
|
ARCH=$(LINUX_KARCH) \
|
||||||
|
--enable-linux-26 \
|
||||||
|
--enable-kernelbuild="$(LINUX_DIR)" \
|
||||||
|
--enable-kernelincl="$(LINUX_DIR)/include" \
|
||||||
|
--enable-add_drv_cflags="-fno-pic -mno-abicalls -mlong-calls -G 0"
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
(cd $(PKG_BUILD_DIR); aclocal && autoconf && automake)
|
||||||
|
$(call Build/Configure/Default)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) $(1)/usr/{lib,include/ifxos}
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/src/include/* $(1)/usr/include/ifxos
|
||||||
|
mkdir -p $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/src/libifxos.a $(1)/usr/lib/libifxos.a
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call KernelPackage,ifxos))
|
43
package/ifxos/patches/100-portability.patch
Normal file
43
package/ifxos/patches/100-portability.patch
Normal file
|
@ -0,0 +1,43 @@
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -149,12 +149,12 @@ AC_ARG_ENABLE(targetincl,
|
||||||
|
echo Set the target image include path $enableval
|
||||||
|
AC_SUBST([TARGET_INCL_PATH],[$enableval])
|
||||||
|
else
|
||||||
|
- echo -e Set the default target image include path $DEFAULT_TARGET_INCL_PATH
|
||||||
|
+ echo Set the default target image include path $DEFAULT_TARGET_INCL_PATH
|
||||||
|
AC_SUBST([TARGET_INCL_PATH],[$DEFAULT_TARGET_INCL_PATH])
|
||||||
|
fi
|
||||||
|
],
|
||||||
|
[
|
||||||
|
- echo -e Set the default target image include path $DEFAULT_TARGET_INCL_PATH
|
||||||
|
+ echo Set the default target image include path $DEFAULT_TARGET_INCL_PATH
|
||||||
|
AC_SUBST([TARGET_INCL_PATH],[$DEFAULT_TARGET_INCL_PATH])
|
||||||
|
]
|
||||||
|
)
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -610,7 +610,7 @@ if KERNEL_2_6
|
||||||
|
drv_ifxos_OBJS = "$(subst .c,.o,$(filter %.c,$(drv_ifxos_SOURCES)))"
|
||||||
|
|
||||||
|
drv_ifxos.ko: $(drv_ifxos_SOURCES)
|
||||||
|
- @echo -e "drv_ifxos: Making Linux 2.6.x kernel object"
|
||||||
|
+ @echo "drv_ifxos: Making Linux 2.6.x kernel object"
|
||||||
|
if test ! -e common/ifxos_debug.c ; then \
|
||||||
|
echo "copy source files (as links only!)"; \
|
||||||
|
for f in $(filter %.c,$(drv_ifxos_SOURCES)); do \
|
||||||
|
@@ -618,10 +618,10 @@ drv_ifxos.ko: $(drv_ifxos_SOURCES)
|
||||||
|
cp -s $(addprefix @abs_srcdir@/,$$f) $(PWD)/`dirname $$f`/ ; \
|
||||||
|
done \
|
||||||
|
fi
|
||||||
|
- @echo -e "# drv_ifxos: Generated to build Linux 2.6.x kernel object" > $(PWD)/Kbuild
|
||||||
|
- @echo -e "obj-m := $(subst .ko,.o,$@)" >> $(PWD)/Kbuild
|
||||||
|
- @echo -e "$(subst .ko,,$@)-y := $(drv_ifxos_OBJS)" >> $(PWD)/Kbuild
|
||||||
|
- @echo -e "EXTRA_CFLAGS := $(CFLAGS) -DHAVE_CONFIG_H $(drv_ifxos_CFLAGS) $(DSL_DRIVER_INCL_PATH) -I@abs_srcdir@/include -I$(PWD)/include" >> $(PWD)/Kbuild
|
||||||
|
+ @echo "# drv_ifxos: Generated to build Linux 2.6.x kernel object" > $(PWD)/Kbuild
|
||||||
|
+ @echo "obj-m := $(subst .ko,.o,$@)" >> $(PWD)/Kbuild
|
||||||
|
+ @echo "$(subst .ko,,$@)-y := $(drv_ifxos_OBJS)" >> $(PWD)/Kbuild
|
||||||
|
+ @echo "EXTRA_CFLAGS := $(CFLAGS) -DHAVE_CONFIG_H $(drv_ifxos_CFLAGS) $(DSL_DRIVER_INCL_PATH) -I@abs_srcdir@/include -I$(PWD)/include" >> $(PWD)/Kbuild
|
||||||
|
$(MAKE) ARCH=@KERNEL_ARCH@ -C @KERNEL_BUILD_PATH@ O=@KERNEL_BUILD_PATH@ M=$(PWD) modules
|
||||||
|
|
||||||
|
clean-generic:
|
Loading…
Reference in a new issue