ubi-utils: bump to version 1.5.1 for ubiblock support

ubiblock allows creating and removing read-only block devices
on top of ubi volumes.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>

SVN-Revision: 41033
This commit is contained in:
John Crispin 2014-06-06 09:34:47 +00:00
parent 1352b86627
commit b757deecad
2 changed files with 8 additions and 7 deletions

View file

@ -8,9 +8,9 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=mtd-utils PKG_NAME:=mtd-utils
PKG_REV:=ab8c6fb93ce9db0f09401c4b819b0b277dc00340 PKG_REV:=7d2839b8dede3ae368780364b4a07473d2303219
PKG_VERSION:=1.5.0 PKG_VERSION:=1.5.1
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=git://git.infradead.org/mtd-utils.git PKG_SOURCE_URL:=git://git.infradead.org/mtd-utils.git
@ -33,6 +33,7 @@ include $(INCLUDE_DIR)/package.mk
FILES:= \ FILES:= \
ubiattach \ ubiattach \
ubicrc32 \ ubicrc32 \
ubiblock \
ubidetach \ ubidetach \
ubiformat \ ubiformat \
ubimkvol \ ubimkvol \

View file

@ -2,10 +2,10 @@
+++ b/Makefile +++ b/Makefile
@@ -3,7 +3,7 @@ @@ -3,7 +3,7 @@
VERSION = 1.5.0 VERSION = 1.5.1
-CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) -CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS)
+CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) -I./include/linux/lzma +CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS) -I./include/linux/lzma
ifeq ($(WITHOUT_XATTR), 1) ifeq ($(WITHOUT_XATTR), 1)
CPPFLAGS += -DWITHOUT_XATTR CPPFLAGS += -DWITHOUT_XATTR
@ -5011,7 +5011,7 @@
+} +}
--- a/mkfs.jffs2.c --- a/mkfs.jffs2.c
+++ b/mkfs.jffs2.c +++ b/mkfs.jffs2.c
@@ -1658,11 +1658,11 @@ int main(int argc, char **argv) @@ -1659,11 +1659,11 @@ int main(int argc, char **argv)
} }
erase_block_size *= units; erase_block_size *= units;