upgrade iproute2 to 2.6.29-1 - includes support for the skbedit scheduler action
SVN-Revision: 16777
This commit is contained in:
parent
7dc435ea29
commit
b5730c409f
9 changed files with 61 additions and 104 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=2.6.25
|
||||
PKG_VERSION:=2.6.29-1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
|
||||
PKG_MD5SUM:=5737bade2f5e03fad0e2c81da91e551e
|
||||
PKG_MD5SUM:=c1bc258a6c345905e79935ac7a3cc582
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
|
||||
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
Index: iproute2-2.6.25/doc/ip-cref.tex
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/doc/ip-cref.tex 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/doc/ip-cref.tex 2008-05-01 00:26:48.000000000 +0100
|
||||
@@ -1315,6 +1315,19 @@ peers are allowed to send to us.
|
||||
--- a/doc/ip-cref.tex
|
||||
+++ b/doc/ip-cref.tex
|
||||
@@ -1324,6 +1324,19 @@ peers are allowed to send to us.
|
||||
If it is not given, Linux uses the value selected with \verb|sysctl|
|
||||
variable \verb|net/ipv4/tcp_reordering|.
|
||||
|
||||
|
@ -22,7 +20,7 @@ Index: iproute2-2.6.25/doc/ip-cref.tex
|
|||
|
||||
|
||||
\item \verb|nexthop NEXTHOP|
|
||||
@@ -2644,6 +2657,9 @@ http://www.cisco.com/univercd/cc/td/doc/
|
||||
@@ -2653,6 +2666,9 @@ http://www.cisco.com/univercd/cc/td/doc/
|
||||
\bibitem{RFC-DHCP} R.~Droms.
|
||||
``Dynamic Host Configuration Protocol.'', RFC-2131
|
||||
|
||||
|
@ -32,10 +30,8 @@ Index: iproute2-2.6.25/doc/ip-cref.tex
|
|||
\end{thebibliography}
|
||||
|
||||
|
||||
Index: iproute2-2.6.25/doc/Makefile
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/doc/Makefile 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/doc/Makefile 2008-05-01 00:26:48.000000000 +0100
|
||||
--- a/doc/Makefile
|
||||
+++ b/doc/Makefile
|
||||
@@ -14,6 +14,7 @@ PAGESIZE=a4
|
||||
PAGESPERPAGE=2
|
||||
|
||||
|
@ -67,10 +63,8 @@ Index: iproute2-2.6.25/doc/Makefile
|
|||
clean:
|
||||
- rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html
|
||||
+ rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html $(TXTFILES)
|
||||
Index: iproute2-2.6.25/include/linux/pkt_sched.h
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/include/linux/pkt_sched.h 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/include/linux/pkt_sched.h 2008-05-01 00:37:45.000000000 +0100
|
||||
--- a/include/linux/pkt_sched.h
|
||||
+++ b/include/linux/pkt_sched.h
|
||||
@@ -1,3 +1,409 @@
|
||||
+#if 0
|
||||
+#ifndef __LINUX_PKT_SCHED_H
|
||||
|
@ -481,9 +475,9 @@ Index: iproute2-2.6.25/include/linux/pkt_sched.h
|
|||
#ifndef __LINUX_PKT_SCHED_H
|
||||
#define __LINUX_PKT_SCHED_H
|
||||
|
||||
@@ -482,4 +888,116 @@ struct tc_netem_corrupt
|
||||
|
||||
#define NETEM_DIST_SCALE 8192
|
||||
@@ -518,4 +924,116 @@ struct tc_drr_stats
|
||||
__u32 deficit;
|
||||
};
|
||||
|
||||
+/* WRR section */
|
||||
+
|
||||
|
@ -598,10 +592,8 @@ Index: iproute2-2.6.25/include/linux/pkt_sched.h
|
|||
+};
|
||||
+
|
||||
#endif
|
||||
Index: iproute2-2.6.25/ip/iproute.c
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/ip/iproute.c 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/ip/iproute.c 2008-05-01 00:28:02.000000000 +0100
|
||||
--- a/ip/iproute.c
|
||||
+++ b/ip/iproute.c
|
||||
@@ -73,7 +73,7 @@ static void usage(void)
|
||||
fprintf(stderr, " [ rtt TIME ] [ rttvar TIME ]\n");
|
||||
fprintf(stderr, " [ window NUMBER] [ cwnd NUMBER ] [ initcwnd NUMBER ]\n");
|
||||
|
@ -611,7 +603,7 @@ Index: iproute2-2.6.25/ip/iproute.c
|
|||
fprintf(stderr, "TYPE := [ unicast | local | broadcast | multicast | throw |\n");
|
||||
fprintf(stderr, " unreachable | prohibit | blackhole | nat ]\n");
|
||||
fprintf(stderr, "TABLE_ID := [ local | main | default | all | NUMBER ]\n");
|
||||
@@ -780,6 +780,30 @@ int iproute_modify(int cmd, unsigned fla
|
||||
@@ -792,6 +792,30 @@ int iproute_modify(int cmd, unsigned fla
|
||||
invarg("\"reordering\" value is invalid\n", *argv);
|
||||
rta_addattr32(mxrta, sizeof(mxbuf), RTAX_REORDERING, reord);
|
||||
#endif
|
||||
|
@ -642,10 +634,8 @@ Index: iproute2-2.6.25/ip/iproute.c
|
|||
} else if (strcmp(*argv, "rtt") == 0) {
|
||||
unsigned rtt;
|
||||
NEXT_ARG();
|
||||
Index: iproute2-2.6.25/ip/iptunnel.c
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/ip/iptunnel.c 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/ip/iptunnel.c 2008-05-01 00:26:48.000000000 +0100
|
||||
--- a/ip/iptunnel.c
|
||||
+++ b/ip/iptunnel.c
|
||||
@@ -134,7 +134,7 @@ static int parse_args(int argc, char **a
|
||||
NEXT_ARG();
|
||||
p->o_flags |= GRE_KEY;
|
||||
|
@ -655,11 +645,9 @@ Index: iproute2-2.6.25/ip/iptunnel.c
|
|||
else {
|
||||
if (get_unsigned(&uval, *argv, 0)<0) {
|
||||
fprintf(stderr, "invalid value of \"okey\"\n");
|
||||
Index: iproute2-2.6.25/Makefile
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/Makefile 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/Makefile 2008-05-01 00:26:48.000000000 +0100
|
||||
@@ -48,7 +48,7 @@ install: all
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -49,7 +49,7 @@ install: all
|
||||
$(DESTDIR)$(DOCDIR)/examples
|
||||
install -m 0644 $(shell find examples/diffserv -maxdepth 1 -type f) \
|
||||
$(DESTDIR)$(DOCDIR)/examples/diffserv
|
||||
|
@ -668,7 +656,7 @@ Index: iproute2-2.6.25/Makefile
|
|||
install -m 0644 $(shell find etc/iproute2 -maxdepth 1 -type f) $(DESTDIR)$(CONFDIR)
|
||||
install -m 0755 -d $(DESTDIR)$(MANDIR)/man8
|
||||
install -m 0644 $(shell find man/man8 -maxdepth 1 -type f) $(DESTDIR)$(MANDIR)/man8
|
||||
@@ -65,7 +65,7 @@ snapshot:
|
||||
@@ -67,7 +67,7 @@ snapshot:
|
||||
|
||||
clean:
|
||||
rm -f cscope.*
|
||||
|
@ -677,10 +665,8 @@ Index: iproute2-2.6.25/Makefile
|
|||
do $(MAKE) $(MFLAGS) -C $$i clean; done
|
||||
|
||||
clobber: clean
|
||||
Index: iproute2-2.6.25/misc/Makefile
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/misc/Makefile 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/misc/Makefile 2008-05-01 00:26:48.000000000 +0100
|
||||
--- a/misc/Makefile
|
||||
+++ b/misc/Makefile
|
||||
@@ -1,7 +1,8 @@
|
||||
SSOBJ=ss.o ssfilter.o
|
||||
LNSTATOBJ=lnstat.o lnstat_util.o
|
||||
|
@ -691,22 +677,18 @@ Index: iproute2-2.6.25/misc/Makefile
|
|||
|
||||
include ../Config
|
||||
|
||||
Index: iproute2-2.6.25/tc/Makefile
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/tc/Makefile 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/tc/Makefile 2008-05-01 00:30:13.000000000 +0100
|
||||
@@ -13,6 +13,7 @@ TCMODULES += q_tbf.o
|
||||
TCMODULES += q_cbq.o
|
||||
--- a/tc/Makefile
|
||||
+++ b/tc/Makefile
|
||||
@@ -14,6 +14,7 @@ TCMODULES += q_cbq.o
|
||||
TCMODULES += q_rr.o
|
||||
TCMODULES += q_multiq.o
|
||||
TCMODULES += q_netem.o
|
||||
+TCMODULES += q_wrr.o
|
||||
TCMODULES += f_rsvp.o
|
||||
TCMODULES += f_u32.o
|
||||
TCMODULES += f_route.o
|
||||
Index: iproute2-2.6.25/tc/q_htb.c
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/tc/q_htb.c 2008-05-01 00:17:55.000000000 +0100
|
||||
+++ iproute2-2.6.25/tc/q_htb.c 2008-05-01 00:37:50.000000000 +0100
|
||||
--- a/tc/q_htb.c
|
||||
+++ b/tc/q_htb.c
|
||||
@@ -1,3 +1,311 @@
|
||||
+#if 0
|
||||
+/*
|
||||
|
@ -1019,10 +1001,8 @@ Index: iproute2-2.6.25/tc/q_htb.c
|
|||
/*
|
||||
* q_htb.c HTB.
|
||||
*
|
||||
Index: iproute2-2.6.25/tc/q_wrr.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ iproute2-2.6.25/tc/q_wrr.c 2008-05-01 00:37:17.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/tc/q_wrr.c
|
||||
@@ -0,0 +1,322 @@
|
||||
+#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
Index: iproute-2.6.20-070313/Config
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ iproute-2.6.20-070313/Config 2007-06-09 13:53:58.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/Config
|
||||
@@ -0,0 +1,4 @@
|
||||
+# Fixed config to disable ATM support even if present on host system
|
||||
+TC_CONFIG_ATM:=n
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
Index: iproute2-2.6.25/ip/ipxfrm.c
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/ip/ipxfrm.c 2008-04-17 18:12:54.000000000 +0100
|
||||
+++ iproute2-2.6.25/ip/ipxfrm.c 2008-05-01 00:38:40.000000000 +0100
|
||||
@@ -490,7 +490,6 @@ void xfrm_selector_print(struct xfrm_sel
|
||||
--- a/ip/ipxfrm.c
|
||||
+++ b/ip/ipxfrm.c
|
||||
@@ -491,7 +491,6 @@ void xfrm_selector_print(struct xfrm_sel
|
||||
switch (sel->proto) {
|
||||
case IPPROTO_TCP:
|
||||
case IPPROTO_UDP:
|
||||
|
@ -10,7 +8,7 @@ Index: iproute2-2.6.25/ip/ipxfrm.c
|
|||
case IPPROTO_DCCP:
|
||||
default: /* XXX */
|
||||
if (sel->sport_mask)
|
||||
@@ -1121,7 +1120,6 @@ static int xfrm_selector_upspec_parse(st
|
||||
@@ -1154,7 +1153,6 @@ static int xfrm_selector_upspec_parse(st
|
||||
switch (sel->proto) {
|
||||
case IPPROTO_TCP:
|
||||
case IPPROTO_UDP:
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
Index: iproute2-2.6.25/tc/q_htb.c
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/tc/q_htb.c 2008-05-01 00:37:50.000000000 +0100
|
||||
+++ iproute2-2.6.25/tc/q_htb.c 2008-05-01 20:30:28.000000000 +0100
|
||||
--- a/tc/q_htb.c
|
||||
+++ b/tc/q_htb.c
|
||||
@@ -35,10 +35,14 @@ static void explain(void)
|
||||
" default minor id of class to which unclassified packets are sent {0}\n"
|
||||
" r2q DRR quantums are computed as rate in Bps/r2q {10}\n"
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
Index: iproute-2.6.20-070313/netem/maketable.c
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/netem/maketable.c 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/netem/maketable.c 2007-06-09 13:54:01.000000000 +0100
|
||||
--- a/netem/maketable.c
|
||||
+++ b/netem/maketable.c
|
||||
@@ -10,7 +10,9 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
|
@ -12,10 +10,8 @@ Index: iproute-2.6.20-070313/netem/maketable.c
|
|||
#include <string.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
Index: iproute-2.6.20-070313/netem/normal.c
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/netem/normal.c 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/netem/normal.c 2007-06-09 13:54:01.000000000 +0100
|
||||
--- a/netem/normal.c
|
||||
+++ b/netem/normal.c
|
||||
@@ -8,8 +8,12 @@
|
||||
#include <string.h>
|
||||
#include <limits.h>
|
||||
|
@ -29,10 +25,8 @@ Index: iproute-2.6.20-070313/netem/normal.c
|
|||
|
||||
#define TABLESIZE 16384
|
||||
#define TABLEFACTOR NETEM_DIST_SCALE
|
||||
Index: iproute-2.6.20-070313/netem/pareto.c
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/netem/pareto.c 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/netem/pareto.c 2007-06-09 13:54:01.000000000 +0100
|
||||
--- a/netem/pareto.c
|
||||
+++ b/netem/pareto.c
|
||||
@@ -7,8 +7,12 @@
|
||||
#include <math.h>
|
||||
#include <limits.h>
|
||||
|
@ -46,10 +40,8 @@ Index: iproute-2.6.20-070313/netem/pareto.c
|
|||
|
||||
static const double a=3.0;
|
||||
#define TABLESIZE 16384
|
||||
Index: iproute-2.6.20-070313/netem/paretonormal.c
|
||||
===================================================================
|
||||
--- iproute-2.6.20-070313.orig/netem/paretonormal.c 2007-06-09 13:53:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313/netem/paretonormal.c 2007-06-09 13:54:01.000000000 +0100
|
||||
--- a/netem/paretonormal.c
|
||||
+++ b/netem/paretonormal.c
|
||||
@@ -15,10 +15,13 @@
|
||||
#include <string.h>
|
||||
#include <math.h>
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
Index: iproute-2.6.20-070313/tc/emp_ematch.lex.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ iproute-2.6.20-070313/tc/emp_ematch.lex.c 2007-06-09 13:54:02.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/tc/emp_ematch.lex.c
|
||||
@@ -0,0 +1,1764 @@
|
||||
+#define yy_create_buffer ematch__create_buffer
|
||||
+#define yy_delete_buffer ematch__delete_buffer
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
Index: iproute2-2.6.25/include/linux/pkt_sched.h
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/include/linux/pkt_sched.h 2008-05-01 00:37:45.000000000 +0100
|
||||
+++ iproute2-2.6.25/include/linux/pkt_sched.h 2008-05-01 20:30:49.000000000 +0100
|
||||
--- a/include/linux/pkt_sched.h
|
||||
+++ b/include/linux/pkt_sched.h
|
||||
@@ -174,8 +174,38 @@ struct tc_sfq_qopt
|
||||
*
|
||||
* The only reason for this is efficiency, it is possible
|
||||
|
@ -41,7 +39,7 @@ Index: iproute2-2.6.25/include/linux/pkt_sched.h
|
|||
/* RED section */
|
||||
|
||||
enum
|
||||
@@ -568,8 +598,37 @@ struct tc_sfq_xstats
|
||||
@@ -588,8 +618,37 @@ struct tc_sfq_xstats
|
||||
*
|
||||
* The only reason for this is efficiency, it is possible
|
||||
* to change these parameters in compile time.
|
||||
|
@ -79,10 +77,8 @@ Index: iproute2-2.6.25/include/linux/pkt_sched.h
|
|||
/* RED section */
|
||||
|
||||
enum
|
||||
Index: iproute2-2.6.25/tc/Makefile
|
||||
===================================================================
|
||||
--- iproute2-2.6.25.orig/tc/Makefile 2008-05-01 00:30:13.000000000 +0100
|
||||
+++ iproute2-2.6.25/tc/Makefile 2008-05-01 20:30:49.000000000 +0100
|
||||
--- a/tc/Makefile
|
||||
+++ b/tc/Makefile
|
||||
@@ -7,6 +7,7 @@ include ../Config
|
||||
TCMODULES :=
|
||||
TCMODULES += q_fifo.o
|
||||
|
@ -91,10 +87,8 @@ Index: iproute2-2.6.25/tc/Makefile
|
|||
TCMODULES += q_red.o
|
||||
TCMODULES += q_prio.o
|
||||
TCMODULES += q_tbf.o
|
||||
Index: iproute2-2.6.25/tc/q_esfq.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ iproute2-2.6.25/tc/q_esfq.c 2008-05-01 20:31:09.000000000 +0100
|
||||
--- /dev/null
|
||||
+++ b/tc/q_esfq.c
|
||||
@@ -0,0 +1,200 @@
|
||||
+/*
|
||||
+ * q_esfq.c ESFQ.
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
diff -urN iproute-2.6.20-070313/include/linux/netfilter_ipv4/ip_tables.h iproute-2.6.20-070313.new/include/linux/netfilter_ipv4/ip_tables.h
|
||||
--- iproute-2.6.20-070313/include/linux/netfilter_ipv4/ip_tables.h 2007-03-13 22:50:56.000000000 +0100
|
||||
+++ iproute-2.6.20-070313.new/include/linux/netfilter_ipv4/ip_tables.h 2007-06-13 19:50:04.000000000 +0200
|
||||
@@ -112,7 +112,10 @@
|
||||
--- a/include/linux/netfilter_ipv4/ip_tables.h
|
||||
+++ b/include/linux/netfilter_ipv4/ip_tables.h
|
||||
@@ -114,7 +114,10 @@ struct ipt_entry
|
||||
#define IPT_CONTINUE XT_CONTINUE
|
||||
#define IPT_RETURN XT_RETURN
|
||||
|
||||
|
||||
+#include <linux/version.h>
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
|
||||
#include <linux/netfilter/xt_tcpudp.h>
|
||||
|
|
Loading…
Reference in a new issue