openssl: fix build failure on arm, aes asm version is not shipped anymore (closes: #6778)

SVN-Revision: 19945
This commit is contained in:
Nicolas Thill 2010-03-02 04:56:49 +00:00
parent 45f7dc9459
commit b3f90f939b
2 changed files with 0 additions and 16 deletions

View file

@ -82,11 +82,7 @@ else
OPENSSL_OPTIONS += no-engines
endif
ifdef CONFIG_arm
OPENSSL_MAKEFLAGS := AES_ASM_OBJ="aes-armv4.o aes_cbc.o"
else
OPENSSL_OPTIONS += no-perlasm
endif
define Build/Configure
(cd $(PKG_BUILD_DIR); \

View file

@ -1,12 +0,0 @@
--- a/crypto/aes/Makefile
+++ b/crypto/aes/Makefile
@@ -47,6 +47,9 @@ lib: $(LIBOBJ)
$(LIBOBJ): $(LIBSRC)
+aes-armv4.s: asm/aes-armv4.pl
+ $(PERL) $^ > $@
+
aes-ia64.s: asm/aes-ia64.S
$(CC) $(CFLAGS) -E asm/aes-ia64.S > $@