parent
fbabc211c5
commit
b32d7ba705
4 changed files with 41 additions and 18 deletions
|
@ -9,7 +9,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openssl
|
||||
PKG_VERSION:=0.9.8j
|
||||
PKG_VERSION:=0.9.8k
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -17,7 +17,7 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
|
|||
ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
|
||||
ftp://ftp.webmonster.de/pub/openssl/source/ \
|
||||
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
|
||||
PKG_MD5SUM:=a5cb5f6c3d11affb387ecf7a997cac0c
|
||||
PKG_MD5SUM:=e555c6d58d276aec7fdc53363e338ab3
|
||||
|
||||
PKG_BUILD_DEPENDS:=ocf-crypto-headers
|
||||
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
Index: openssl-0.9.8e/util/domd
|
||||
===================================================================
|
||||
--- openssl-0.9.8e.orig/util/domd 2007-06-04 13:23:32.130849264 +0200
|
||||
+++ openssl-0.9.8e/util/domd 2007-06-04 13:23:32.408807008 +0200
|
||||
diff -burN openssl-0.9.8k/util/domd openssl-0.9.8k.patched/util/domd
|
||||
--- openssl-0.9.8k/util/domd 2009-01-21 22:44:52.000000000 +0100
|
||||
+++ openssl-0.9.8k.patched/util/domd 2009-03-26 15:46:28.600347986 +0100
|
||||
@@ -14,7 +14,8 @@
|
||||
cp Makefile Makefile.save
|
||||
# fake the presence of Kerberos
|
||||
|
@ -16,7 +15,7 @@ Index: openssl-0.9.8e/util/domd
|
|||
done
|
||||
sed -e '/^# DO NOT DELETE.*/,$d' < Makefile > Makefile.tmp
|
||||
echo '# DO NOT DELETE THIS LINE -- make depend depends on it.' >> Makefile.tmp
|
||||
- gcc -D OPENSSL_DOING_MAKEDEPEND -M $args >> Makefile.tmp
|
||||
- ${CC:-gcc} -D OPENSSL_DOING_MAKEDEPEND -M $args >> Makefile.tmp
|
||||
+ ${MAKEDEPEND} -D OPENSSL_DOING_MAKEDEPEND -M $args >> Makefile.tmp
|
||||
${PERL} $TOP/util/clean-depend.pl < Makefile.tmp > Makefile.new
|
||||
rm -f Makefile.tmp
|
||||
|
|
24
package/openssl/patches/121-ocf-config.patch
Normal file
24
package/openssl/patches/121-ocf-config.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
diff -burN openssl-0.9.8k/config openssl-0.9.8k.patched/config
|
||||
--- openssl-0.9.8k/config 2009-02-16 09:43:41.000000000 +0100
|
||||
+++ openssl-0.9.8k.patched/config 2009-03-27 19:38:37.262255825 +0100
|
||||
@@ -399,8 +399,11 @@
|
||||
# this is where the translation occurs into SSLeay terms
|
||||
# ---------------------------------------------------------------------------
|
||||
|
||||
+# figure out if gcc is available and if so we use it otherwise
|
||||
+# we fallback to whatever cc does on the system
|
||||
GCCVER=`(gcc -dumpversion) 2>/dev/null`
|
||||
if [ "$GCCVER" != "" ]; then
|
||||
+ CC=gcc
|
||||
# then strip off whatever prefix egcs prepends the number with...
|
||||
# Hopefully, this will work for any future prefixes as well.
|
||||
GCCVER=`echo $GCCVER | LC_ALL=C sed 's/^[a-zA-Z]*\-//'`
|
||||
@@ -409,6 +412,8 @@
|
||||
# major and minor version numbers.
|
||||
# peak single digit before and after first dot, e.g. 2.95.1 gives 29
|
||||
GCCVER=`echo $GCCVER | sed 's/\([0-9]\)\.\([0-9]\).*/\1\2/'`
|
||||
+else
|
||||
+ CC=cc
|
||||
fi
|
||||
|
||||
# Only set CC if not supplied already
|
|
@ -1,12 +1,12 @@
|
|||
diff -burN openssl-0.9.8j/Makefile openssl-0.9.8j.patched/Makefile
|
||||
--- openssl-0.9.8j/Makefile 2009-01-07 12:57:01.000000000 +0100
|
||||
+++ openssl-0.9.8j.patched/Makefile 2009-01-17 14:16:50.279667198 +0100
|
||||
diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
|
||||
--- openssl-0.9.8k/Makefile 2009-03-25 14:11:43.000000000 +0100
|
||||
+++ openssl-0.9.8k.patched/Makefile 2009-03-26 15:28:35.483566078 +0100
|
||||
@@ -133,7 +133,7 @@
|
||||
|
||||
BASEADDR=0xFB00000
|
||||
|
||||
-DIRS= crypto fips ssl engines apps test tools
|
||||
+DIRS= crypto fips ssl engines apps tools
|
||||
-DIRS= crypto ssl engines apps test tools
|
||||
+DIRS= crypto ssl engines apps tools
|
||||
SHLIBDIRS= crypto ssl
|
||||
|
||||
# dirs in crypto to build
|
||||
|
@ -15,7 +15,7 @@ diff -burN openssl-0.9.8j/Makefile openssl-0.9.8j.patched/Makefile
|
|||
# tests to perform. "alltests" is a special word indicating that all tests
|
||||
# should be performed.
|
||||
-TESTS = alltests
|
||||
+TESTS =
|
||||
+TESTS =
|
||||
|
||||
MAKEFILE= Makefile
|
||||
|
||||
|
@ -37,7 +37,7 @@ diff -burN openssl-0.9.8j/Makefile openssl-0.9.8j.patched/Makefile
|
|||
|
||||
build_libs: build_crypto build_fips build_ssl build_shared build_engines
|
||||
|
||||
@@ -610,7 +610,7 @@
|
||||
@@ -613,7 +613,7 @@
|
||||
dist_pem_h:
|
||||
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
|
||||
|
||||
|
@ -46,10 +46,10 @@ diff -burN openssl-0.9.8j/Makefile openssl-0.9.8j.patched/Makefile
|
|||
|
||||
install_sw:
|
||||
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
|
||||
diff -burN openssl-0.9.8j/Makefile.org openssl-0.9.8j.patched/Makefile.org
|
||||
--- openssl-0.9.8j/Makefile.org 2008-12-30 14:26:26.000000000 +0100
|
||||
+++ openssl-0.9.8j.patched/Makefile.org 2009-01-17 14:14:18.874409981 +0100
|
||||
@@ -608,7 +608,7 @@
|
||||
diff -burN openssl-0.9.8k/Makefile.org openssl-0.9.8k.patched/Makefile.org
|
||||
--- openssl-0.9.8k/Makefile.org 2009-03-03 23:40:29.000000000 +0100
|
||||
+++ openssl-0.9.8k.patched/Makefile.org 2009-03-26 15:29:05.243750064 +0100
|
||||
@@ -611,7 +611,7 @@
|
||||
dist_pem_h:
|
||||
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
|
||||
|
||||
|
|
Loading…
Reference in a new issue