avr32: upgrade to 2.6.25.6
SVN-Revision: 11450
This commit is contained in:
parent
f5e550f438
commit
b0fa59bef2
4 changed files with 40248 additions and 11145 deletions
|
@ -10,7 +10,7 @@ ARCH:=avr32
|
|||
BOARD:=avr32
|
||||
BOARDNAME:=Atmel AVR32
|
||||
FEATURES:=squashfs
|
||||
LINUX_VERSION:=2.6.24.7
|
||||
LINUX_VERSION:=2.6.25.6
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -7,10 +7,13 @@ CONFIG_AP700X_16_BIT_SMC=y
|
|||
# CONFIG_ARCH_HAVE_MEMORY_PRESENT is not set
|
||||
# CONFIG_ARCH_SPARSEMEM_ENABLE is not set
|
||||
# CONFIG_ARCH_SUPPORTS_MSI is not set
|
||||
CONFIG_ARCH_SUPPORTS_OPROFILE=y
|
||||
CONFIG_ARCH_SUSPEND_POSSIBLE=y
|
||||
CONFIG_AT32AP700X_WDT=m
|
||||
# CONFIG_ATMEL_PWM is not set
|
||||
# CONFIG_ATMEL_SSC is not set
|
||||
# CONFIG_ATMEL_TCLIB is not set
|
||||
CONFIG_ATMEL_TCB_CLKSRC=y
|
||||
CONFIG_ATMEL_TCB_CLKSRC_BLOCK=0
|
||||
CONFIG_ATMEL_TCLIB=y
|
||||
CONFIG_AVR32=y
|
||||
CONFIG_BASE_SMALL=0
|
||||
CONFIG_BITREVERSE=y
|
||||
|
@ -19,25 +22,38 @@ CONFIG_BOARD_ATNGW100=y
|
|||
# CONFIG_BOARD_ATSTK1000 is not set
|
||||
# CONFIG_BROADCOM_PHY is not set
|
||||
# CONFIG_BT is not set
|
||||
CONFIG_CLASSIC_RCU=y
|
||||
CONFIG_CPU_AT32AP7000=y
|
||||
CONFIG_CPU_AT32AP700X=y
|
||||
# CONFIG_CPU_FREQ is not set
|
||||
CONFIG_CRYPTO_AEAD=m
|
||||
CONFIG_CRYPTO_AUTHENC=m
|
||||
CONFIG_CRYPTO_GF128MUL=m
|
||||
# CONFIG_DEBUG_BUGVERBOSE is not set
|
||||
CONFIG_DW_DMAC=y
|
||||
# CONFIG_E1000E_ENABLED is not set
|
||||
CONFIG_ENTRY_ADDRESS=0x90000000
|
||||
# CONFIG_FIXED_PHY is not set
|
||||
CONFIG_FS_POSIX_ACL=y
|
||||
CONFIG_GENERIC_ALLOCATOR=y
|
||||
CONFIG_GENERIC_BUG=y
|
||||
CONFIG_GENERIC_CLOCKEVENTS=y
|
||||
CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
|
||||
CONFIG_GENERIC_GPIO=y
|
||||
# CONFIG_GEN_RTC is not set
|
||||
# CONFIG_GPIO_DEV is not set
|
||||
# CONFIG_GPIO_MCP23S08 is not set
|
||||
# CONFIG_GPIO_PCA953X is not set
|
||||
# CONFIG_GPIO_PCF857X is not set
|
||||
CONFIG_HARDIRQS_SW_RESEND=y
|
||||
CONFIG_HAS_DMA=y
|
||||
CONFIG_HAS_IOMEM=y
|
||||
CONFIG_HAS_IOPORT=y
|
||||
# CONFIG_HAVE_ARCH_BOOTMEM_NODE is not set
|
||||
CONFIG_HAVE_GPIO_LIB=y
|
||||
# CONFIG_HAVE_IDE is not set
|
||||
CONFIG_HAVE_KPROBES=y
|
||||
# CONFIG_HAVE_KRETPROBES is not set
|
||||
CONFIG_HAVE_OPROFILE=y
|
||||
# CONFIG_HW_RANDOM is not set
|
||||
CONFIG_I2C=y
|
||||
# CONFIG_I2C_ALGOBIT is not set
|
||||
|
@ -47,14 +63,23 @@ CONFIG_I2C_BOARDINFO=y
|
|||
# CONFIG_IBM_NEW_EMAC_RGMII is not set
|
||||
# CONFIG_IBM_NEW_EMAC_TAH is not set
|
||||
# CONFIG_IBM_NEW_EMAC_ZMII is not set
|
||||
# CONFIG_IDE is not set
|
||||
CONFIG_INITRAMFS_SOURCE=""
|
||||
# CONFIG_LEDS_ALIX is not set
|
||||
CONFIG_LEDS_GPIO=y
|
||||
CONFIG_LOADER_U_BOOT=y
|
||||
CONFIG_LOAD_ADDRESS=0x10000000
|
||||
CONFIG_LZO_COMPRESS=m
|
||||
CONFIG_LZO_DECOMPRESS=m
|
||||
CONFIG_MACB=y
|
||||
# CONFIG_MDIO_BITBANG is not set
|
||||
# CONFIG_MEMSTICK is not set
|
||||
CONFIG_MMC=m
|
||||
CONFIG_MMC_ATMELMCI=m
|
||||
CONFIG_MMC_BLOCK=m
|
||||
CONFIG_MMC_BLOCK_BOUNCE=y
|
||||
# CONFIG_MMC_DEBUG is not set
|
||||
# CONFIG_MMC_SPI is not set
|
||||
# CONFIG_MMC_UNSAFE_RESUME is not set
|
||||
CONFIG_MTD=y
|
||||
# CONFIG_MTD_ABSENT is not set
|
||||
CONFIG_MTD_BLKDEVS=y
|
||||
|
@ -104,16 +129,40 @@ CONFIG_MTD_PHYSMAP_START=0x80000000
|
|||
# CONFIG_NMI_DEBUGGING is not set
|
||||
CONFIG_NO_HZ=y
|
||||
# CONFIG_OWNERSHIP_TRACE is not set
|
||||
# CONFIG_PATA_AT32 is not set
|
||||
CONFIG_PERFORMANCE_COUNTERS=y
|
||||
CONFIG_PHYLIB=y
|
||||
CONFIG_PHYS_OFFSET=0x10000000
|
||||
CONFIG_PLATFORM_AT32AP=y
|
||||
# CONFIG_QSEMI_PHY is not set
|
||||
# CONFIG_RTC is not set
|
||||
# CONFIG_REALTEK_PHY is not set
|
||||
CONFIG_RTC_CLASS=m
|
||||
CONFIG_RTC_DRV_AT32AP700X=m
|
||||
# CONFIG_RTC_DRV_DS1307 is not set
|
||||
# CONFIG_RTC_DRV_DS1374 is not set
|
||||
# CONFIG_RTC_DRV_DS1553 is not set
|
||||
# CONFIG_RTC_DRV_DS1672 is not set
|
||||
# CONFIG_RTC_DRV_DS1742 is not set
|
||||
# CONFIG_RTC_DRV_ISL1208 is not set
|
||||
# CONFIG_RTC_DRV_M41T80 is not set
|
||||
# CONFIG_RTC_DRV_M48T59 is not set
|
||||
# CONFIG_RTC_DRV_M48T86 is not set
|
||||
# CONFIG_RTC_DRV_PCF8563 is not set
|
||||
# CONFIG_RTC_DRV_PCF8583 is not set
|
||||
# CONFIG_RTC_DRV_RS5C372 is not set
|
||||
# CONFIG_RTC_DRV_STK17TA8 is not set
|
||||
# CONFIG_RTC_DRV_TEST is not set
|
||||
# CONFIG_RTC_DRV_V3020 is not set
|
||||
# CONFIG_RTC_DRV_X1205 is not set
|
||||
CONFIG_RTC_INTF_DEV=y
|
||||
# CONFIG_RTC_INTF_DEV_UIE_EMUL is not set
|
||||
CONFIG_RTC_INTF_PROC=y
|
||||
CONFIG_RTC_INTF_SYSFS=y
|
||||
CONFIG_RTC_LIB=m
|
||||
CONFIG_RWSEM_GENERIC_SPINLOCK=y
|
||||
# CONFIG_RWSEM_XCHGADD_ALGORITHM is not set
|
||||
# CONFIG_SCHED_HRTICK is not set
|
||||
CONFIG_SCSI_WAIT_SCAN=m
|
||||
# CONFIG_SDIO_UART is not set
|
||||
# CONFIG_SERIAL_8250 is not set
|
||||
CONFIG_SERIAL_ATMEL=y
|
||||
CONFIG_SERIAL_ATMEL_CONSOLE=y
|
||||
|
@ -122,6 +171,7 @@ CONFIG_SERIAL_ATMEL_PDC=y
|
|||
CONFIG_SLABINFO=y
|
||||
# CONFIG_SMSC_PHY is not set
|
||||
# CONFIG_SND_ATMEL_AC97 is not set
|
||||
# CONFIG_SOFT_WATCHDOG is not set
|
||||
# CONFIG_SPARSEMEM_STATIC is not set
|
||||
# CONFIG_SPARSEMEM_VMEMMAP_ENABLE is not set
|
||||
CONFIG_SPI=y
|
||||
|
@ -133,11 +183,11 @@ CONFIG_SPI_MASTER=y
|
|||
CONFIG_SSB_POSSIBLE=y
|
||||
CONFIG_SUBARCH_AVR32B=y
|
||||
CONFIG_SYSVIPC_SYSCTL=y
|
||||
# CONFIG_THERMAL is not set
|
||||
CONFIG_TICK_ONESHOT=y
|
||||
# CONFIG_USB_ARCH_HAS_EHCI is not set
|
||||
# CONFIG_USB_ARCH_HAS_HCD is not set
|
||||
# CONFIG_USB_ARCH_HAS_OHCI is not set
|
||||
# CONFIG_USER_NS is not set
|
||||
# CONFIG_VGASTATE is not set
|
||||
# CONFIG_WATCHDOG is not set
|
||||
CONFIG_VIDEO_V4L2_COMMON=m
|
||||
CONFIG_ZONE_DMA_FLAG=0
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,25 +0,0 @@
|
|||
From: Haavard Skinnemoen <haavard.skinnemoen@atmel.com>
|
||||
Date: Tue, 27 May 2008 07:37:42 +0000 (+0200)
|
||||
Subject: avr32: Fix cpufreq oops when ondemand governor is default
|
||||
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Fhskinnemoen%2Favr32-2.6.git;a=commitdiff_plain;h=f04d264afc51acdffeba9cdf3baf04116687680c
|
||||
|
||||
avr32: Fix cpufreq oops when ondemand governor is default
|
||||
|
||||
Move the AP7 cpufreq init to late_initcall() so that we don't try to
|
||||
bring up cpufreq until the governor is ready. x86 also uses
|
||||
late_initcall() for this.
|
||||
|
||||
Signed-off-by: Haavard Skinnemoen <haavard.skinnemoen@atmel.com>
|
||||
---
|
||||
|
||||
diff --git a/arch/avr32/mach-at32ap/cpufreq.c b/arch/avr32/mach-at32ap/cpufreq.c
|
||||
index 235524b..5dd8d25 100644
|
||||
--- a/arch/avr32/mach-at32ap/cpufreq.c
|
||||
+++ b/arch/avr32/mach-at32ap/cpufreq.c
|
||||
@@ -108,5 +108,4 @@ static int __init at32_cpufreq_init(void)
|
||||
{
|
||||
return cpufreq_register_driver(&at32_driver);
|
||||
}
|
||||
-
|
||||
-arch_initcall(at32_cpufreq_init);
|
||||
+late_initcall(at32_cpufreq_init);
|
Loading…
Reference in a new issue