apex: Updated to version 1.5.6 (which includes the compiler inlining fixes).
SVN-Revision: 7451
This commit is contained in:
parent
414bc92dea
commit
ad2bc9c63b
2 changed files with 2 additions and 30 deletions
|
@ -9,14 +9,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=apex
|
||||
PKG_VERSION:=1.5.4
|
||||
PKG_VERSION:=1.5.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.buici.com/pub/apex/ \
|
||||
ftp://metalab.unc.edu/pub/Linux/system/boot/apex/
|
||||
PKG_MD5SUM:=b07790b259f48653c32955244c23cc57
|
||||
PKG_MD5SUM:=1ef0881f80b89c7c0fb5d1c66a3b5ea1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
--- apex-1.5.4/src/arch-arm/entry/apex.lds.S~ 2007-05-31 14:54:41.000000000 +0930
|
||||
+++ apex-1.5.4/src/arch-arm/entry/apex.lds.S 2007-06-02 14:26:51.000000000 +0930
|
||||
@@ -48,8 +48,8 @@
|
||||
}
|
||||
.reset.post : { /* Post-SDRAM init code.*/
|
||||
*(.reset.post)
|
||||
- *(.reset.postfn)
|
||||
- *(.reset.postex)
|
||||
+ *(.reset.post.func)
|
||||
+ *(.reset.post.exit)
|
||||
}
|
||||
.rlocate : { /* Final/only relocation of APEX to SDRAM */
|
||||
*(.rlocate)
|
||||
--- apex-1.5.4/src/arch-arm/entry/reset.c~ 2007-05-31 14:54:41.000000000 +0930
|
||||
+++ apex-1.5.4/src/arch-arm/entry/reset.c 2007-06-02 14:27:20.000000000 +0930
|
||||
@@ -292,10 +292,10 @@
|
||||
// __asm volatile ("mov sp, %0" :: "r" (&APEX_VMA_STACK_START));
|
||||
|
||||
__asm volatile ("mov r0, %0" :: "r" (offset));
|
||||
- __asm volatile ("b reset_post_2");
|
||||
+ __asm volatile ("b reset_post_exit");
|
||||
}
|
||||
|
||||
-void __naked __section (.reset.post) reset_post_2 (void)
|
||||
+void __naked __section (.reset.post.exit) reset_post_exit (void)
|
||||
{
|
||||
}
|
||||
|
Loading…
Reference in a new issue