ebtables: update to latest git 2018-05-15
66a9701 ebtables: Fix build errors and warnings 9fff3d5 include: Fix musl libc compatibility b1cdae8 extensions: Add string filter to ebtables Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
This commit is contained in:
parent
14ff1278ee
commit
ac70ac3532
2 changed files with 14 additions and 3 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ebtables
|
||||
PKG_SOURCE_DATE:=2018-04-11
|
||||
PKG_SOURCE_DATE:=2018-05-15
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=https://git.netfilter.org/ebtables
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_VERSION:=2e783b2277665c467138e7685309622456c41db4
|
||||
PKG_MIRROR_HASH:=601a41f579f76c8121bb6076ebcf5eb5efddf634ebb5949ec9e983a17e66e689
|
||||
PKG_SOURCE_VERSION:=66a97018a31eed416c6a25d051ea172e4d65be1b
|
||||
PKG_MIRROR_HASH:=3205285d4e92ab66d75681fd031b6bdc19954198b58dec1d8cbbf64312ebd445
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
||||
|
|
|
@ -247,3 +247,14 @@
|
|||
{
|
||||
ebt_register_table(&table);
|
||||
}
|
||||
--- a/extensions/ebt_string.c
|
||||
+++ b/extensions/ebt_string.c
|
||||
@@ -310,7 +310,7 @@ static struct ebt_u_match string_match =
|
||||
.extra_ops = opts,
|
||||
};
|
||||
|
||||
-void _init(void)
|
||||
+__attribute__((constructor)) static void extension_init(void)
|
||||
{
|
||||
ebt_register_match(&string_match);
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue