tools/cmake: Update to 3.11.0
Update cmake to 3.11.0 Remove 110-alpine_musl-compat.patch as it's integrated upstream Rename and refresh patches Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
parent
f6e6eadc99
commit
a8c315192b
6 changed files with 6 additions and 22 deletions
|
@ -7,13 +7,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=cmake
|
PKG_NAME:=cmake
|
||||||
PKG_VERSION:=3.10.1
|
PKG_VERSION:=3.11.0
|
||||||
PKG_CPE_ID:=cpe:/a:kitware:cmake
|
PKG_CPE_ID:=cpe:/a:kitware:cmake
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://cmake.org/files/v3.10/ \
|
PKG_SOURCE_URL:=https://cmake.org/files/v3.11/ \
|
||||||
https://fossies.org/linux/misc/
|
https://fossies.org/linux/misc/
|
||||||
PKG_HASH:=7be36ee24b0f5928251b644d29f5ff268330a916944ef4a75e23ba01e7573284
|
PKG_HASH:=c313bee371d4d255be2b4e96fd59b11d58bc550a7c78c021444ae565709a656b
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL:=1
|
HOST_BUILD_PARALLEL:=1
|
||||||
HOST_CONFIGURE_PARALLEL:=1
|
HOST_CONFIGURE_PARALLEL:=1
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Tests/RunCMake/CMakeLists.txt
|
--- a/Tests/RunCMake/CMakeLists.txt
|
||||||
+++ b/Tests/RunCMake/CMakeLists.txt
|
+++ b/Tests/RunCMake/CMakeLists.txt
|
||||||
@@ -273,15 +273,6 @@ add_RunCMake_test(no_install_prefix)
|
@@ -284,15 +284,6 @@ add_RunCMake_test(no_install_prefix)
|
||||||
add_RunCMake_test(configure_file)
|
add_RunCMake_test(configure_file)
|
||||||
add_RunCMake_test(CTestTimeoutAfterMatch)
|
add_RunCMake_test(CTestTimeoutAfterMatch)
|
||||||
|
|
||||||
|
@ -18,7 +18,7 @@
|
||||||
add_RunCMake_test(FindPkgConfig)
|
add_RunCMake_test(FindPkgConfig)
|
||||||
--- a/Tests/CMakeLists.txt
|
--- a/Tests/CMakeLists.txt
|
||||||
+++ b/Tests/CMakeLists.txt
|
+++ b/Tests/CMakeLists.txt
|
||||||
@@ -407,13 +407,6 @@ if(BUILD_TESTING)
|
@@ -422,13 +422,6 @@ if(BUILD_TESTING)
|
||||||
|
|
||||||
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
|
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
|
||||||
|
|
||||||
|
|
|
@ -1,16 +0,0 @@
|
||||||
--- a/Utilities/cmjsoncpp/include/json/assertions.h
|
|
||||||
+++ b/Utilities/cmjsoncpp/include/json/assertions.h
|
|
||||||
@@ -6,11 +6,12 @@
|
|
||||||
#ifndef CPPTL_JSON_ASSERTIONS_H_INCLUDED
|
|
||||||
#define CPPTL_JSON_ASSERTIONS_H_INCLUDED
|
|
||||||
|
|
||||||
+#include <stdlib.h>
|
|
||||||
+
|
|
||||||
#if !defined(JSON_IS_AMALGAMATION)
|
|
||||||
#include "config.h"
|
|
||||||
#endif // if !defined(JSON_IS_AMALGAMATION)
|
|
||||||
|
|
||||||
-#include <stdlib.h>
|
|
||||||
#include <sstream>
|
|
||||||
|
|
||||||
/** It should not be possible for a maliciously designed file to
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/bootstrap
|
--- a/bootstrap
|
||||||
+++ b/bootstrap
|
+++ b/bootstrap
|
||||||
@@ -1130,7 +1130,10 @@ int main(){ printf("1%c", (char)0x0a); r
|
@@ -1149,7 +1149,10 @@ int main(){ printf("1%c", (char)0x0a); r
|
||||||
' > "test.c"
|
' > "test.c"
|
||||||
cmake_original_make_flags="${cmake_make_flags}"
|
cmake_original_make_flags="${cmake_make_flags}"
|
||||||
if [ "x${cmake_parallel_make}" != "x" ]; then
|
if [ "x${cmake_parallel_make}" != "x" ]; then
|
Loading…
Reference in a new issue