Add mini_sendmail package
SVN-Revision: 1268
This commit is contained in:
parent
4779c70fe8
commit
a68c52edf0
6 changed files with 72 additions and 0 deletions
|
@ -49,6 +49,7 @@ source "package/l2tpd/Config.in"
|
||||||
source "package/lighttpd/Config.in"
|
source "package/lighttpd/Config.in"
|
||||||
source "package/maradns/Config.in"
|
source "package/maradns/Config.in"
|
||||||
source "package/mini_httpd/Config.in"
|
source "package/mini_httpd/Config.in"
|
||||||
|
source "package/mini_sendmail/Config.in"
|
||||||
source "package/ndisc/Config.in"
|
source "package/ndisc/Config.in"
|
||||||
source "package/net-snmp/Config.in"
|
source "package/net-snmp/Config.in"
|
||||||
source "package/nfs-server/Config.in"
|
source "package/nfs-server/Config.in"
|
||||||
|
|
|
@ -63,6 +63,7 @@ package-$(BR2_PACKAGE_MATRIXSSL) += matrixssl
|
||||||
package-$(BR2_PACKAGE_MICROCOM) += microcom
|
package-$(BR2_PACKAGE_MICROCOM) += microcom
|
||||||
package-$(BR2_PACKAGE_MICROPERL) += microperl
|
package-$(BR2_PACKAGE_MICROPERL) += microperl
|
||||||
package-$(BR2_PACKAGE_MINI_HTTPD) += mini_httpd
|
package-$(BR2_PACKAGE_MINI_HTTPD) += mini_httpd
|
||||||
|
package-$(BR2_PACKAGE_MINI_SENDMAIL) += mini_sendmail
|
||||||
package-$(BR2_PACKAGE_MONIT) += monit
|
package-$(BR2_PACKAGE_MONIT) += monit
|
||||||
package-$(BR2_PACKAGE_MYSQL) += mysql
|
package-$(BR2_PACKAGE_MYSQL) += mysql
|
||||||
package-$(BR2_PACKAGE_NCURSES) += ncurses
|
package-$(BR2_PACKAGE_NCURSES) += ncurses
|
||||||
|
|
11
openwrt/package/mini_sendmail/Config.in
Normal file
11
openwrt/package/mini_sendmail/Config.in
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
config BR2_PACKAGE_MINI_SENDMAIL
|
||||||
|
tristate "mini-sendmail - A small sendmail-compatible mail forwarder"
|
||||||
|
default m if CONFIG_DEVEL
|
||||||
|
help
|
||||||
|
mini_sendmail reads its standard input up to an end-of-file and sends a
|
||||||
|
copy of the message found there to all of the addresses listed.
|
||||||
|
The message is sent by connecting to a local SMTP server. This means
|
||||||
|
mini_sendmail can be used to send email from inside a chroot(2) area.
|
||||||
|
|
||||||
|
http://www.acme.com/software/mini_sendmail/
|
||||||
|
|
36
openwrt/package/mini_sendmail/Makefile
Normal file
36
openwrt/package/mini_sendmail/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=mini-sendmail
|
||||||
|
PKG_VERSION:=1.3.5
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_MD5SUM:=
|
||||||
|
|
||||||
|
PKG_SOURCE_URL:=http://www.acme.com/software/mini_sendmail/
|
||||||
|
PKG_SOURCE:=mini_sendmail-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/mini_sendmail-$(PKG_VERSION)
|
||||||
|
|
||||||
|
include $(TOPDIR)/package/rules.mk
|
||||||
|
|
||||||
|
$(eval $(call PKG_template,MINI_SENDMAIL,mini-sendmail,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
|
|
||||||
|
|
||||||
|
$(PKG_BUILD_DIR)/.configured:
|
||||||
|
touch $@
|
||||||
|
|
||||||
|
$(PKG_BUILD_DIR)/.built:
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
CC=$(TARGET_CC) \
|
||||||
|
OFLAGS="$(TARGET_CFLAGS)" \
|
||||||
|
all
|
||||||
|
touch $@
|
||||||
|
|
||||||
|
$(IPKG_MINI_SENDMAIL):
|
||||||
|
install -d -m0755 $(IDIR_MINI_SENDMAIL)/usr/sbin
|
||||||
|
install -m0755 $(PKG_BUILD_DIR)/mini_sendmail $(IDIR_MINI_SENDMAIL)/usr/sbin/
|
||||||
|
ln -sf mini_sendmail $(IDIR_MINI_SENDMAIL)/usr/sbin/sendmail
|
||||||
|
$(RSTRIP) $(IDIR_MINI_SENDMAIL)
|
||||||
|
$(IPKG_BUILD) $(IDIR_MINI_SENDMAIL) $(PACKAGE_DIR)
|
8
openwrt/package/mini_sendmail/ipkg/mini-sendmail.control
Normal file
8
openwrt/package/mini_sendmail/ipkg/mini-sendmail.control
Normal file
|
@ -0,0 +1,8 @@
|
||||||
|
Package: mini-sendmail
|
||||||
|
Priority: optional
|
||||||
|
Section: net
|
||||||
|
Version: [TBDL]
|
||||||
|
Architecture: [TBDL]
|
||||||
|
Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
|
||||||
|
Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/mini_httpd/
|
||||||
|
Description: A small sendmail-compatible mail forwarder
|
15
openwrt/package/mini_sendmail/patches/500-flags.patch
Normal file
15
openwrt/package/mini_sendmail/patches/500-flags.patch
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
--- mini_sendmail-1.3.5/Makefile.orig 2002-01-04 07:05:25.000000000 +0100
|
||||||
|
+++ mini_sendmail-1.3.5/Makefile 2005-06-17 01:57:06.000000000 +0200
|
||||||
|
@@ -7,9 +7,10 @@
|
||||||
|
BINDIR = /usr/local/sbin
|
||||||
|
MANDIR = /usr/local/man
|
||||||
|
CC = gcc
|
||||||
|
-CFLAGS = -O
|
||||||
|
+OFLAGS = -O
|
||||||
|
+CFLAGS = $(OFLAGS)
|
||||||
|
#CFLAGS = -g
|
||||||
|
-LDFLAGS = -s -static
|
||||||
|
+LDFLAGS =
|
||||||
|
#LDFLAGS = -g -static
|
||||||
|
LDLIBS = $(SYSV_LIBS)
|
||||||
|
|
Loading…
Reference in a new issue