refresh 2.6.28 patches

SVN-Revision: 13655
This commit is contained in:
Gabor Juhos 2008-12-15 14:49:40 +00:00
parent 5f1640713e
commit a5f66cd0e8
6 changed files with 10 additions and 10 deletions

View file

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -500,6 +500,10 @@ static struct flash_info __devinitdata m
@@ -503,6 +503,10 @@ static struct flash_info __devinitdata m
{ "at26df161a", 0x1f4601, 0, 64 * 1024, 32, SECT_4K, },
{ "at26df321", 0x1f4701, 0, 64 * 1024, 64, SECT_4K, },

View file

@ -1,8 +1,8 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -83,6 +83,11 @@ config MVSWITCH_PHY
@@ -77,6 +77,11 @@ config ADM6996_PHY
---help---
Currently supports the Marvell 88E6060 switch.
Currently supports the ADM6996F switch
+config MICREL_PHY
+ tristate "Drivers for Micrel/Kendin PHYs"
@ -14,9 +14,9 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o

View file

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -707,12 +707,17 @@ static int __devinit m25p_probe(struct s
@@ -711,12 +711,17 @@ static int __devinit m25p_probe(struct s
struct mtd_partition *parts = NULL;
int nr_parts = 0;

View file

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -500,6 +500,9 @@ static struct flash_info __devinitdata m
@@ -503,6 +503,9 @@ static struct flash_info __devinitdata m
{ "at26df161a", 0x1f4601, 0, 64 * 1024, 32, SECT_4K, },
{ "at26df321", 0x1f4701, 0, 64 * 1024, 64, SECT_4K, },

View file

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -717,6 +717,9 @@ static int __devinit m25p_probe(struct s
@@ -721,6 +721,9 @@ static int __devinit m25p_probe(struct s
#ifdef CONFIG_MTD_MYLOADER_PARTS
"MyLoader",
#endif

View file

@ -68,7 +68,7 @@
platform_set_drvdata(pdev, NULL);
--- a/drivers/net/ag71xx/ag71xx.h
+++ b/drivers/net/ag71xx/ag71xx.h
@@ -101,7 +101,7 @@ struct ag71xx_ring {
@@ -102,7 +102,7 @@ struct ag71xx_ring {
};
struct ag71xx_mdio {
@ -79,7 +79,7 @@
};
--- a/drivers/net/ag71xx/ag71xx_main.c
+++ b/drivers/net/ag71xx/ag71xx_main.c
@@ -807,7 +807,7 @@ static int __init ag71xx_probe(struct pl
@@ -797,7 +797,7 @@ static int __init ag71xx_probe(struct pl
ag = netdev_priv(dev);
ag->pdev = pdev;
ag->dev = dev;