kernel: update kernel 4.4 to version 4.4.28
Refresh patches for all targets that support kernel 4.4. compile/run-tested on ar71xx, brcm47xx, kirkwood. Signed-off-by: Paul Wassi <p.wassi@gmx.at> Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
9e8e8b7253
commit
a569354481
8 changed files with 19 additions and 19 deletions
|
@ -4,11 +4,11 @@ LINUX_RELEASE?=1
|
|||
|
||||
LINUX_VERSION-3.18 = .43
|
||||
LINUX_VERSION-4.1 = .34
|
||||
LINUX_VERSION-4.4 = .27
|
||||
LINUX_VERSION-4.4 = .28
|
||||
|
||||
LINUX_KERNEL_MD5SUM-3.18.43 = b1faeb4a2e1e70ffe061bdbb3452840a
|
||||
LINUX_KERNEL_MD5SUM-4.1.34 = fba99f0f4765ebf01033e69518740a3c
|
||||
LINUX_KERNEL_MD5SUM-4.4.27 = 6c437dd8f9e964c843211cf99a876b42724fe9f2013241c13e14b6ce17846afd
|
||||
LINUX_KERNEL_MD5SUM-4.4.28 = 841acb9109a893ab2f60b02355e1527e80fa09251e46339317f6984d69b1f4fc
|
||||
|
||||
ifdef KERNEL_PATCHVER
|
||||
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
|
||||
|
|
|
@ -16,7 +16,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
|
||||
--- a/drivers/mmc/card/block.c
|
||||
+++ b/drivers/mmc/card/block.c
|
||||
@@ -2552,6 +2552,13 @@ static const struct mmc_fixup blk_fixups
|
||||
@@ -2553,6 +2553,13 @@ static const struct mmc_fixup blk_fixups
|
||||
MMC_FIXUP("V10016", CID_MANFID_KINGSTON, CID_OEMID_ANY, add_quirk_mmc,
|
||||
MMC_QUIRK_TRIM_BROKEN),
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
|
||||
--- a/drivers/mmc/card/block.c
|
||||
+++ b/drivers/mmc/card/block.c
|
||||
@@ -2558,6 +2558,10 @@ static const struct mmc_fixup blk_fixups
|
||||
@@ -2559,6 +2559,10 @@ static const struct mmc_fixup blk_fixups
|
||||
*/
|
||||
MMC_FIXUP("SD16G", 0x41, 0x3432, add_quirk_mmc,
|
||||
MMC_QUIRK_ERASE_BROKEN),
|
||||
|
|
|
@ -31,7 +31,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
static inline int mmc_blk_part_switch(struct mmc_card *card,
|
||||
struct mmc_blk_data *md);
|
||||
static int get_card_status(struct mmc_card *card, u32 *status, int retries);
|
||||
@@ -2570,6 +2577,7 @@ static int mmc_blk_probe(struct mmc_card
|
||||
@@ -2571,6 +2578,7 @@ static int mmc_blk_probe(struct mmc_card
|
||||
{
|
||||
struct mmc_blk_data *md, *part_md;
|
||||
char cap_str[10];
|
||||
|
@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
|
||||
/*
|
||||
* Check that the card supports the command class(es) we need.
|
||||
@@ -2577,7 +2585,16 @@ static int mmc_blk_probe(struct mmc_card
|
||||
@@ -2578,7 +2586,16 @@ static int mmc_blk_probe(struct mmc_card
|
||||
if (!(card->csd.cmdclass & CCC_BLOCK_READ))
|
||||
return -ENODEV;
|
||||
|
||||
|
@ -57,7 +57,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
|
||||
md = mmc_blk_alloc(card);
|
||||
if (IS_ERR(md))
|
||||
@@ -2585,9 +2602,14 @@ static int mmc_blk_probe(struct mmc_card
|
||||
@@ -2586,9 +2603,14 @@ static int mmc_blk_probe(struct mmc_card
|
||||
|
||||
string_get_size((u64)get_capacity(md->disk), 512, STRING_UNITS_2,
|
||||
cap_str, sizeof(cap_str));
|
||||
|
|
|
@ -10,7 +10,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|||
|
||||
--- a/drivers/mmc/card/block.c
|
||||
+++ b/drivers/mmc/card/block.c
|
||||
@@ -2563,12 +2563,9 @@ static const struct mmc_fixup blk_fixups
|
||||
@@ -2564,12 +2564,9 @@ static const struct mmc_fixup blk_fixups
|
||||
* On some Kingston SD cards, multiple erases of less than 64
|
||||
* sectors can cause corruption.
|
||||
*/
|
||||
|
|
|
@ -58,7 +58,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
|
|||
|
||||
--- a/fs/overlayfs/copy_up.c
|
||||
+++ b/fs/overlayfs/copy_up.c
|
||||
@@ -305,7 +305,6 @@ int ovl_copy_up_one(struct dentry *paren
|
||||
@@ -315,7 +315,6 @@ int ovl_copy_up_one(struct dentry *paren
|
||||
struct dentry *upperdir;
|
||||
struct dentry *upperdentry;
|
||||
const struct cred *old_cred;
|
||||
|
@ -66,7 +66,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
|
|||
char *link = NULL;
|
||||
|
||||
if (WARN_ON(!workdir))
|
||||
@@ -324,28 +323,7 @@ int ovl_copy_up_one(struct dentry *paren
|
||||
@@ -334,28 +333,7 @@ int ovl_copy_up_one(struct dentry *paren
|
||||
return PTR_ERR(link);
|
||||
}
|
||||
|
||||
|
@ -96,7 +96,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
|
|||
|
||||
err = -EIO;
|
||||
if (lock_rename(workdir, upperdir) != NULL) {
|
||||
@@ -368,9 +346,7 @@ int ovl_copy_up_one(struct dentry *paren
|
||||
@@ -378,9 +356,7 @@ int ovl_copy_up_one(struct dentry *paren
|
||||
out_unlock:
|
||||
unlock_rename(workdir, upperdir);
|
||||
revert_creds(old_cred);
|
||||
|
@ -105,10 +105,10 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
|
|||
-out_free_link:
|
||||
if (link)
|
||||
free_page((unsigned long) link);
|
||||
|
||||
|
||||
--- a/fs/overlayfs/dir.c
|
||||
+++ b/fs/overlayfs/dir.c
|
||||
@@ -405,28 +405,13 @@ static int ovl_create_or_link(struct den
|
||||
@@ -408,28 +408,13 @@ static int ovl_create_or_link(struct den
|
||||
err = ovl_create_upper(dentry, inode, &stat, link, hardlink);
|
||||
} else {
|
||||
const struct cred *old_cred;
|
||||
|
@ -138,7 +138,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
|
|||
}
|
||||
|
||||
if (!err)
|
||||
@@ -656,32 +641,11 @@ static int ovl_do_remove(struct dentry *
|
||||
@@ -659,32 +644,11 @@ static int ovl_do_remove(struct dentry *
|
||||
if (OVL_TYPE_PURE_UPPER(type)) {
|
||||
err = ovl_remove_upper(dentry, is_dir);
|
||||
} else {
|
||||
|
@ -172,7 +172,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
|
|||
}
|
||||
out_drop_write:
|
||||
ovl_drop_write(dentry);
|
||||
@@ -720,7 +684,6 @@ static int ovl_rename2(struct inode *old
|
||||
@@ -723,7 +687,6 @@ static int ovl_rename2(struct inode *old
|
||||
bool new_is_dir = false;
|
||||
struct dentry *opaquedir = NULL;
|
||||
const struct cred *old_cred = NULL;
|
||||
|
@ -180,7 +180,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
|
|||
|
||||
err = -EINVAL;
|
||||
if (flags & ~(RENAME_EXCHANGE | RENAME_NOREPLACE))
|
||||
@@ -789,26 +752,8 @@ static int ovl_rename2(struct inode *old
|
||||
@@ -792,26 +755,8 @@ static int ovl_rename2(struct inode *old
|
||||
old_opaque = !OVL_TYPE_PURE_UPPER(old_type);
|
||||
new_opaque = !OVL_TYPE_PURE_UPPER(new_type);
|
||||
|
||||
|
@ -209,7 +209,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
|
|||
|
||||
if (overwrite && OVL_TYPE_MERGE_OR_LOWER(new_type) && new_is_dir) {
|
||||
opaquedir = ovl_check_empty_and_clear(new);
|
||||
@@ -939,10 +884,8 @@ out_dput_old:
|
||||
@@ -942,10 +887,8 @@ out_dput_old:
|
||||
out_unlock:
|
||||
unlock_rename(new_upperdir, old_upperdir);
|
||||
out_revert_creds:
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
+++ b/arch/mips/vdso/Makefile
|
||||
@@ -77,7 +77,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
|
||||
|
||||
$(obj)/vdso.lds: KBUILD_CPPFLAGS := $(native-abi)
|
||||
$(obj)/vdso.lds: KBUILD_CPPFLAGS := $(ccflags-vdso) $(native-abi)
|
||||
|
||||
-$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) FORCE
|
||||
+$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) $(obj)/genvdso FORCE
|
||||
|
|
|
@ -263,7 +263,7 @@
|
|||
IPC_MSG_IDS, sysvipc_msg_proc_show);
|
||||
--- a/ipc/sem.c
|
||||
+++ b/ipc/sem.c
|
||||
@@ -191,6 +191,8 @@ void sem_exit_ns(struct ipc_namespace *n
|
||||
@@ -198,6 +198,8 @@ void sem_exit_ns(struct ipc_namespace *n
|
||||
void __init sem_init(void)
|
||||
{
|
||||
sem_init_ns(&init_ipc_ns);
|
||||
|
|
Loading…
Reference in a new issue