net/utils/tcpdump: update to 4.8.1
Update tcpdump to upstream release 4.8.1 Signed-off-by: Paul Wassi <p.wassi@gmx.at>
This commit is contained in:
parent
64590f3c7e
commit
a4a00d794f
4 changed files with 937 additions and 813 deletions
|
@ -8,15 +8,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=tcpdump
|
PKG_NAME:=tcpdump
|
||||||
PKG_VERSION:=4.5.1
|
PKG_VERSION:=4.8.1
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
|
PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
|
||||||
http://ftp.gwdg.de/pub/misc/tcpdump/ \
|
http://www.at.tcpdump.org/
|
||||||
http://www.at.tcpdump.org/ \
|
PKG_MD5SUM:=32f57943649f276e09236ba66622bb0c
|
||||||
http://www.br.tcpdump.org/
|
|
||||||
PKG_MD5SUM:=973a2513d0076e34aa9da7e15ed98e1b
|
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
|
@ -1,23 +1,100 @@
|
||||||
--- a/tcpdump.c
|
--- a/configure
|
||||||
+++ b/tcpdump.c
|
+++ b/configure
|
||||||
@@ -1095,20 +1095,6 @@ main(int argc, char **argv)
|
@@ -6260,97 +6260,6 @@ $as_echo "no" >&6; }
|
||||||
error("invalid data link type %s", gndo->ndo_dltname);
|
fi
|
||||||
break;
|
fi
|
||||||
|
|
||||||
-#if defined(HAVE_PCAP_DEBUG) || defined(HAVE_YYDEBUG)
|
-#
|
||||||
- case 'Y':
|
-# Check for special debugging functions
|
||||||
- {
|
-#
|
||||||
- /* Undocumented flag */
|
-for ac_func in pcap_set_parser_debug
|
||||||
-#ifdef HAVE_PCAP_DEBUG
|
-do :
|
||||||
- extern int pcap_debug;
|
- ac_fn_c_check_func "$LINENO" "pcap_set_parser_debug" "ac_cv_func_pcap_set_parser_debug"
|
||||||
- pcap_debug = 1;
|
-if test "x$ac_cv_func_pcap_set_parser_debug" = xyes; then :
|
||||||
-#else
|
- cat >>confdefs.h <<_ACEOF
|
||||||
|
-#define HAVE_PCAP_SET_PARSER_DEBUG 1
|
||||||
|
-_ACEOF
|
||||||
|
-
|
||||||
|
-fi
|
||||||
|
-done
|
||||||
|
-
|
||||||
|
-if test "$ac_cv_func_pcap_set_parser_debug" = "no" ; then
|
||||||
|
- #
|
||||||
|
- # OK, we don't have pcap_set_parser_debug() to set the libpcap
|
||||||
|
- # filter expression parser debug flag; can we directly set the
|
||||||
|
- # flag?
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether pcap_debug is defined by libpcap" >&5
|
||||||
|
-$as_echo_n "checking whether pcap_debug is defined by libpcap... " >&6; }
|
||||||
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
-/* end confdefs.h. */
|
||||||
|
-
|
||||||
|
-int
|
||||||
|
-main ()
|
||||||
|
-{
|
||||||
|
-
|
||||||
|
- extern int pcap_debug;
|
||||||
|
-
|
||||||
|
- return pcap_debug;
|
||||||
|
-
|
||||||
|
- ;
|
||||||
|
- return 0;
|
||||||
|
-}
|
||||||
|
-_ACEOF
|
||||||
|
-if ac_fn_c_try_link "$LINENO"; then :
|
||||||
|
- ac_lbl_cv_pcap_debug_defined=yes
|
||||||
|
-else
|
||||||
|
- ac_lbl_cv_pcap_debug_defined=no
|
||||||
|
-fi
|
||||||
|
-rm -f core conftest.err conftest.$ac_objext \
|
||||||
|
- conftest$ac_exeext conftest.$ac_ext
|
||||||
|
- if test "$ac_lbl_cv_pcap_debug_defined" = yes ; then
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||||
|
-$as_echo "yes" >&6; }
|
||||||
|
-
|
||||||
|
-$as_echo "#define HAVE_PCAP_DEBUG 1" >>confdefs.h
|
||||||
|
-
|
||||||
|
- else
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||||
|
-$as_echo "no" >&6; }
|
||||||
|
- #
|
||||||
|
- # OK, what about "yydebug"?
|
||||||
|
- #
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether yydebug is defined by libpcap" >&5
|
||||||
|
-$as_echo_n "checking whether yydebug is defined by libpcap... " >&6; }
|
||||||
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
-/* end confdefs.h. */
|
||||||
|
-
|
||||||
|
-int
|
||||||
|
-main ()
|
||||||
|
-{
|
||||||
|
-
|
||||||
- extern int yydebug;
|
- extern int yydebug;
|
||||||
- yydebug = 1;
|
-
|
||||||
-#endif
|
- return yydebug;
|
||||||
- }
|
-
|
||||||
- break;
|
- ;
|
||||||
-#endif
|
- return 0;
|
||||||
case 'z':
|
-}
|
||||||
if (optarg) {
|
-_ACEOF
|
||||||
zflag = strdup(optarg);
|
-if ac_fn_c_try_link "$LINENO"; then :
|
||||||
|
- ac_lbl_cv_yydebug_defined=yes
|
||||||
|
-else
|
||||||
|
- ac_lbl_cv_yydebug_defined=no
|
||||||
|
-fi
|
||||||
|
-rm -f core conftest.err conftest.$ac_objext \
|
||||||
|
- conftest$ac_exeext conftest.$ac_ext
|
||||||
|
- if test "$ac_lbl_cv_yydebug_defined" = yes ; then
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||||
|
-$as_echo "yes" >&6; }
|
||||||
|
-
|
||||||
|
-$as_echo "#define HAVE_YYDEBUG 1" >>confdefs.h
|
||||||
|
-
|
||||||
|
- else
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||||
|
-$as_echo "no" >&6; }
|
||||||
|
- fi
|
||||||
|
- fi
|
||||||
|
-fi
|
||||||
|
for ac_func in pcap_set_optimizer_debug
|
||||||
|
do :
|
||||||
|
ac_fn_c_check_func "$LINENO" "pcap_set_optimizer_debug" "ac_cv_func_pcap_set_optimizer_debug"
|
||||||
|
|
|
@ -1,35 +1,44 @@
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -5813,28 +5813,6 @@ $as_echo "Using $pfopen" >&6; }
|
@@ -5472,37 +5472,6 @@ $as_echo "Using $pfopen" >&6; }
|
||||||
LIBS="$LIBS $pfopen"
|
LIBS="$LIBS $pfopen"
|
||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for local pcap library" >&5
|
- libpcap=FAIL
|
||||||
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for local pcap library" >&5
|
||||||
-$as_echo_n "checking for local pcap library... " >&6; }
|
-$as_echo_n "checking for local pcap library... " >&6; }
|
||||||
- libpcap=FAIL
|
-
|
||||||
- lastdir=FAIL
|
-# Check whether --with-system-libpcap was given.
|
||||||
- places=`ls $srcdir/.. | sed -e 's,/$,,' -e "s,^,$srcdir/../," | \
|
-if test "${with_system_libpcap+set}" = set; then :
|
||||||
- egrep '/libpcap-[0-9]+\.[0-9]+(\.[0-9]*)?([ab][0-9]*|-PRE-GIT)?$'`
|
- withval=$with_system_libpcap;
|
||||||
- for dir in $places $srcdir/../libpcap $srcdir/libpcap ; do
|
-fi
|
||||||
- basedir=`echo $dir | sed -e 's/[ab][0-9]*$//' | \
|
-
|
||||||
- sed -e 's/-PRE-GIT$//' `
|
- if test "x$with_system_libpcap" != xyes ; then
|
||||||
- if test $lastdir = $basedir ; then
|
- lastdir=FAIL
|
||||||
- continue;
|
- places=`ls $srcdir/.. | sed -e 's,/$,,' -e "s,^,$srcdir/../," | \
|
||||||
- fi
|
- egrep '/libpcap-[0-9]+\.[0-9]+(\.[0-9]*)?([ab][0-9]*|-PRE-GIT)?$'`
|
||||||
- lastdir=$dir
|
- places2=`ls .. | sed -e 's,/$,,' -e "s,^,../," | \
|
||||||
- if test -r $dir/libpcap.a ; then
|
- egrep '/libpcap-[0-9]+\.[0-9]+(\.[0-9]*)?([ab][0-9]*|-PRE-GIT)?$'`
|
||||||
- libpcap=$dir/libpcap.a
|
- for dir in $places $srcdir/../libpcap ../libpcap $srcdir/libpcap $places2 ; do
|
||||||
- d=$dir
|
- basedir=`echo $dir | sed -e 's/[ab][0-9]*$//' | \
|
||||||
- fi
|
- sed -e 's/-PRE-GIT$//' `
|
||||||
- done
|
- if test $lastdir = $basedir ; then
|
||||||
|
- continue;
|
||||||
|
- fi
|
||||||
|
- lastdir=$dir
|
||||||
|
- if test -r $dir/libpcap.a ; then
|
||||||
|
- libpcap=$dir/libpcap.a
|
||||||
|
- d=$dir
|
||||||
|
- fi
|
||||||
|
- done
|
||||||
|
- fi
|
||||||
- if test $libpcap = FAIL ; then
|
- if test $libpcap = FAIL ; then
|
||||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: not found" >&5
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: not found" >&5
|
||||||
-$as_echo "not found" >&6; }
|
-$as_echo "not found" >&6; }
|
||||||
-
|
|
||||||
#
|
#
|
||||||
# Look for pcap-config.
|
# Look for pcap-config.
|
||||||
#
|
@@ -5658,51 +5627,6 @@ if test "x$ac_cv_lib_pcap_main" = xyes;
|
||||||
@@ -5989,41 +5967,6 @@ if test "x$ac_cv_lib_pcap_main" = xyes;
|
|
||||||
libpcap="-lpcap"
|
libpcap="-lpcap"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
@ -59,13 +68,23 @@
|
||||||
- V_PCAPDEP=$libpcap
|
- V_PCAPDEP=$libpcap
|
||||||
- places=`ls $srcdir/.. | sed -e 's,/$,,' -e "s,^,$srcdir/../," | \
|
- places=`ls $srcdir/.. | sed -e 's,/$,,' -e "s,^,$srcdir/../," | \
|
||||||
- egrep '/libpcap-[0-9]*.[0-9]*(.[0-9]*)?([ab][0-9]*)?$'`
|
- egrep '/libpcap-[0-9]*.[0-9]*(.[0-9]*)?([ab][0-9]*)?$'`
|
||||||
|
- places2=`ls .. | sed -e 's,/$,,' -e "s,^,../," | \
|
||||||
|
- egrep '/libpcap-[0-9]*.[0-9]*(.[0-9]*)?([ab][0-9]*)?$'`
|
||||||
|
- pcapH=FAIL
|
||||||
- if test -r $d/pcap.h; then
|
- if test -r $d/pcap.h; then
|
||||||
- V_INCLS="-I$d $V_INCLS"
|
- pcapH=$d
|
||||||
- elif test -r $places/pcap.h; then
|
|
||||||
- V_INCLS="-I$places $V_INCLS"
|
|
||||||
- else
|
- else
|
||||||
- as_fn_error see INSTALL "cannot find pcap.h" "$LINENO" 5
|
- for dir in $places $srcdir/../libpcap ../libpcap $srcdir/libpcap $places2 ; do
|
||||||
|
- if test -r $dir/pcap.h ; then
|
||||||
|
- pcapH=$dir
|
||||||
|
- fi
|
||||||
|
- done
|
||||||
|
- fi
|
||||||
|
-
|
||||||
|
- if test $pcapH = FAIL ; then
|
||||||
|
- as_fn_error $? "cannot find pcap.h: see INSTALL" "$LINENO" 5
|
||||||
- fi
|
- fi
|
||||||
|
- V_INCLS="-I$pcapH $V_INCLS"
|
||||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libpcap" >&5
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libpcap" >&5
|
||||||
-$as_echo "$libpcap" >&6; }
|
-$as_echo "$libpcap" >&6; }
|
||||||
# Extract the first word of "pcap-config", so it can be a program name with args.
|
# Extract the first word of "pcap-config", so it can be a program name with args.
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue