dropbear: bump to 2015.68
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 46769
This commit is contained in:
parent
7d6cff4882
commit
a0d06f65ae
7 changed files with 12 additions and 12 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dropbear
|
PKG_NAME:=dropbear
|
||||||
PKG_VERSION:=2015.67
|
PKG_VERSION:=2015.68
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
http://matt.ucc.asn.au/dropbear/releases/ \
|
http://matt.ucc.asn.au/dropbear/releases/ \
|
||||||
https://dropbear.nl/mirror/releases/
|
https://dropbear.nl/mirror/releases/
|
||||||
PKG_MD5SUM:=e967e320344cd4bfebe321e3ab8514d6
|
PKG_MD5SUM:=7664ac10f7cc2301c530eb80c756fc5d
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
|
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/svr-authpubkey.c
|
--- a/svr-authpubkey.c
|
||||||
+++ b/svr-authpubkey.c
|
+++ b/svr-authpubkey.c
|
||||||
@@ -208,17 +208,21 @@ static int checkpubkey(unsigned char* al
|
@@ -218,17 +218,21 @@ static int checkpubkey(char* algo, unsig
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -33,7 +33,7 @@
|
||||||
if (authfile == NULL) {
|
if (authfile == NULL) {
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
@@ -371,26 +375,35 @@ static int checkpubkeyperms() {
|
@@ -381,26 +385,35 @@ static int checkpubkeyperms() {
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/svr-chansession.c
|
--- a/svr-chansession.c
|
||||||
+++ b/svr-chansession.c
|
+++ b/svr-chansession.c
|
||||||
@@ -920,12 +920,12 @@ static void execchild(void *user_data) {
|
@@ -922,12 +922,12 @@ static void execchild(void *user_data) {
|
||||||
/* We can only change uid/gid as root ... */
|
/* We can only change uid/gid as root ... */
|
||||||
if (getuid() == 0) {
|
if (getuid() == 0) {
|
||||||
|
|
||||||
|
|
|
@ -18,7 +18,7 @@
|
||||||
|
|
||||||
/* Whether to support "-c" and "-m" flags to choose ciphers/MACs at runtime */
|
/* Whether to support "-c" and "-m" flags to choose ciphers/MACs at runtime */
|
||||||
#define ENABLE_USER_ALGO_LIST
|
#define ENABLE_USER_ALGO_LIST
|
||||||
@@ -126,9 +126,9 @@ much traffic. */
|
@@ -131,9 +131,9 @@ If you test it please contact the Dropbe
|
||||||
* If you disable MD5, Dropbear will fall back to SHA1 fingerprints,
|
* If you disable MD5, Dropbear will fall back to SHA1 fingerprints,
|
||||||
* which are not the standard form. */
|
* which are not the standard form. */
|
||||||
#define DROPBEAR_SHA1_HMAC
|
#define DROPBEAR_SHA1_HMAC
|
||||||
|
@ -31,7 +31,7 @@
|
||||||
#define DROPBEAR_MD5_HMAC
|
#define DROPBEAR_MD5_HMAC
|
||||||
|
|
||||||
/* You can also disable integrity. Don't bother disabling this if you're
|
/* You can also disable integrity. Don't bother disabling this if you're
|
||||||
@@ -184,7 +184,7 @@ much traffic. */
|
@@ -189,7 +189,7 @@ If you test it please contact the Dropbe
|
||||||
|
|
||||||
/* Whether to print the message of the day (MOTD). This doesn't add much code
|
/* Whether to print the message of the day (MOTD). This doesn't add much code
|
||||||
* size */
|
* size */
|
||||||
|
@ -40,7 +40,7 @@
|
||||||
|
|
||||||
/* The MOTD file path */
|
/* The MOTD file path */
|
||||||
#ifndef MOTD_FILENAME
|
#ifndef MOTD_FILENAME
|
||||||
@@ -226,7 +226,7 @@ much traffic. */
|
@@ -231,7 +231,7 @@ Homedir is prepended unless path begins
|
||||||
* note that it will be provided for all "hidden" client-interactive
|
* note that it will be provided for all "hidden" client-interactive
|
||||||
* style prompts - if you want something more sophisticated, use
|
* style prompts - if you want something more sophisticated, use
|
||||||
* SSH_ASKPASS instead. Comment out this var to remove this functionality.*/
|
* SSH_ASKPASS instead. Comment out this var to remove this functionality.*/
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/dbutil.h
|
--- a/dbutil.h
|
||||||
+++ b/dbutil.h
|
+++ b/dbutil.h
|
||||||
@@ -101,7 +101,11 @@ int m_str_to_uint(const char* str, unsig
|
@@ -88,7 +88,11 @@ int m_str_to_uint(const char* str, unsig
|
||||||
#define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL}
|
#define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL}
|
||||||
|
|
||||||
/* Dropbear assertion */
|
/* Dropbear assertion */
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
--- a/options.h
|
--- a/options.h
|
||||||
+++ b/options.h
|
+++ b/options.h
|
||||||
@@ -5,6 +5,11 @@
|
@@ -5,6 +5,11 @@
|
||||||
#ifndef _OPTIONS_H_
|
#ifndef DROPBEAR_OPTIONS_H_
|
||||||
#define _OPTIONS_H_
|
#define DROPBEAR_OPTIONS_H_
|
||||||
|
|
||||||
+#if !defined(DROPBEAR_CLIENT) && !defined(DROPBEAR_SERVER)
|
+#if !defined(DROPBEAR_CLIENT) && !defined(DROPBEAR_SERVER)
|
||||||
+#define DROPBEAR_SERVER
|
+#define DROPBEAR_SERVER
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/options.h
|
--- a/options.h
|
||||||
+++ b/options.h
|
+++ b/options.h
|
||||||
@@ -336,7 +336,7 @@ be overridden at runtime with -I. 0 disa
|
@@ -341,7 +341,7 @@ be overridden at runtime with -I. 0 disa
|
||||||
#define DEFAULT_IDLE_TIMEOUT 0
|
#define DEFAULT_IDLE_TIMEOUT 0
|
||||||
|
|
||||||
/* The default path. This will often get replaced by the shell */
|
/* The default path. This will often get replaced by the shell */
|
||||||
|
|
Loading…
Reference in a new issue